[bug#33334] :gnu:add ne:the nice editor

Message ID c30ac82d42e6c59dddd68858b8903f5a624e53b4.camel@gmail.com
State Accepted
Headers show
Series [bug#33334] :gnu:add ne:the nice editor | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

guy fleury iteriteka Nov. 10, 2018, 9:25 a.m. UTC
hi all,

i have packaged: ne "the nice editor".
it is my first tempt to contribute to any project,if i do things wrong
tell me with additionnal informations!

Guy.

Comments

swedebugia Nov. 10, 2018, 9:20 p.m. UTC | #1
Hi :)
Did you run ./pre-inst-env guix lint on the package?
It has trailing whitespaces in two places.

On 2018-11-10 10:25, guy fleury wrote:
> hi all,
> 
> i have packaged: ne "the nice editor".
> it is my first tempt to contribute to any project,if i do things wrong
> tell me with additionnal informations!

Thank you! Me too. I submitted my first patch ever to Guix a few days 
ago. :)

> 
> 0001-gnu-add-ne-the-nice-editor.patch
> 
>  From 1ec45eaa225e7203a98b36cddb7d42db418b773b Mon Sep 17 00:00:00 2001
> From: guy fleury<hoonandon@gmail.com>
> Date: Sat, 10 Nov 2018 10:51:17 +0200
> Subject: [PATCH] gnu:add ne:the nice editor

snip

> +    (build-system gnu-build-system)
> +    (arguments
> +       `(#:tests? #f

Could you please explain why the tests are disabled?
Search the packages to see examples of explanations.

> +          #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
> +                   "CC=gcc")
> +         #:parallel-build? #f
> +         #:phases (modify-phases %standard-phases
> +                                 (delete 'configure))))

Same here. Please explain.

Tested the compilation and ran the editor. Seemed nice!

Maybe this could complement nano if it highlights scheme and has a macro 
to help with e.g. finding missing parens.

Could you send an updated patch?
swedebugia Nov. 10, 2018, 9:32 p.m. UTC | #2
Additionally:

On 2018-11-10 10:25, guy fleury wrote:
> +    (description
> +   "ne is a free text editor based on the POSIX standard,
> +    it is easy to use it and fully configurable")

We don't mention that it is free because in Guix all packages are free.
What about:

"ne is fast, small, powerful and simple text editor that can be fully 
configured.  It has a simple scripting language where scripts can be 
easily generated and played."
swedebugia Jan. 3, 2019, 4:23 p.m. UTC | #3
On 2018-11-10 22:32, swedebugia wrote:
> Additionally:
> 
> On 2018-11-10 10:25, guy fleury wrote:
>> +    (description
>> +   "ne is a free text editor based on the POSIX standard,
>> +    it is easy to use it and fully configurable")
> 
> We don't mention that it is free because in Guix all packages are free.
> What about:
> 
> "ne is fast, small, powerful and simple text editor that can be fully 
> configured.  It has a simple scripting language where scripts can be 
> easily generated and played."
> 

Could you update the patch?
swedebugia Jan. 7, 2019, 5:37 a.m. UTC | #4
Guy fleury <hoonandon@gmail.com> skrev: (6 januari 2019 15:48:07 CET)
>hi swedebugia,
>
>sorry for the long delay,
>
>here is the update patch.
>i follow your sugestion .
>but i don't know what others think.
>feel free to change synopsis and description.
>
>thanks,
>
>Le jeu. 3 janv. 2019 à 17:16, swedebugia <swedebugia@riseup.net> a
>écrit :
>
>> On 2018-11-10 22:32, swedebugia wrote:
>> > Additionally:
>> >
>> > On 2018-11-10 10:25, guy fleury wrote:
>> >> +    (description
>> >> +   "ne is a free text editor based on the POSIX standard,
>> >> +    it is easy to use it and fully configurable")
>> >
>> > We don't mention that it is free because in Guix all packages are
>free.
>> > What about:
>> >
>> > "ne is fast, small, powerful and simple text editor that can be
>fully
>> > configured.  It has a simple scripting language where scripts can
>be
>> > easily generated and played."
>> >
>>
>> Could you update the patch?
>>
>> --
>> Cheers Swedebugia
>>

Did you forget to attach the patch?
guy fleury iteriteka Jan. 24, 2020, 8:41 a.m. UTC | #5
close

Patch

From 1ec45eaa225e7203a98b36cddb7d42db418b773b Mon Sep 17 00:00:00 2001
From: guy fleury <hoonandon@gmail.com>
Date: Sat, 10 Nov 2018 10:51:17 +0200
Subject: [PATCH] gnu:add ne:the nice editor

---
 gnu/packages/text-editors.scm | 36 +++++++++++++++++++++++++++++++++++
 1 file changed, 36 insertions(+)

diff --git a/gnu/packages/text-editors.scm b/gnu/packages/text-editors.scm
index 0c60d202a..85e95d48d 100644
--- a/gnu/packages/text-editors.scm
+++ b/gnu/packages/text-editors.scm
@@ -343,3 +343,39 @@  team.")
      "@code{ghostwriter} provides a relaxing, distraction-free writing
 environment with Markdown markup.")
     (license license:gpl3+)))           ;icons/* under CC-BY-SA3
+
+(define-public ne
+  (package
+    (name "ne")
+    (version "3.1.2")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://ne.di.unimi.it/ne-" version
+                                  ".tar.gz"))
+              (sha256
+              (base32
+              "06qk3cqxyn098i1yn686bigpgh8vrrnj0qpkrgs6zwnq42s1y0d2"))
+              (modules '((guix build utils)))
+              (snippet
+               ;; use lncurses instead of lcurses
+               '(begin
+                  (substitute* "src/makefile"
+                    (("-lcurses")
+                     "-lncurses"))
+                  #t))))
+    (build-system gnu-build-system)
+    (arguments
+       `(#:tests? #f
+          #:make-flags (list (string-append "PREFIX=" (assoc-ref %outputs "out"))
+                   "CC=gcc")
+         #:parallel-build? #f
+         #:phases (modify-phases %standard-phases
+                                 (delete 'configure))))       
+    (inputs
+     `(("ncurses" ,ncurses)))
+    (synopsis "ne, the nice editor")
+    (description
+   "ne is a free text editor based on the POSIX standard,
+    it is easy to use it and fully configurable") 
+    (home-page "http://ne.di.unimi.it/ne")
+    (license license:gpl3+)))
-- 
2.19.0