[bug#33895] gnu: Add dummy linker for arm-elf.

Message ID 20181228133637.18665-1-dannym@scratchpost.org
State Accepted
Commit 7f2d67c826cf5c0653aea2637462b0964e2e1984
Headers show
Series [bug#33895] gnu: Add dummy linker for arm-elf. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Danny Milosavljevic Dec. 28, 2018, 1:36 p.m. UTC
* gnu/packages/bootstrap.scm (glibc-dynamic-linker): Add case for arm-elf.
---
 gnu/packages/bootstrap.scm | 1 +
 1 file changed, 1 insertion(+)

Comments

Ludovic Courtès Jan. 6, 2019, 8:14 p.m. UTC | #1
Hi Danny,

Danny Milosavljevic <dannym@scratchpost.org> skribis:

> * gnu/packages/bootstrap.scm (glibc-dynamic-linker): Add case for arm-elf.

OK!

Ludo'.

Patch

diff --git a/gnu/packages/bootstrap.scm b/gnu/packages/bootstrap.scm
index 936d6c1a2..a3ecbeb07 100644
--- a/gnu/packages/bootstrap.scm
+++ b/gnu/packages/bootstrap.scm
@@ -180,6 +180,7 @@  return value is ignored."
 
         ;; XXX: This one is used bare-bones, without a libc, so add a case
         ;; here just so we can keep going.
+        ((string=? system "arm-elf") "no-ld.so")
         ((string=? system "arm-eabi") "no-ld.so")
         ((string=? system "xtensa-elf") "no-ld.so")
         ((string=? system "avr") "no-ld.so")