[bug#33931] gnu: ruby-pg: Update to 1.1.3.

Message ID 20181230194019.20955-1-va511e@yahoo.com
State Accepted
Headers show
Series [bug#33931] gnu: ruby-pg: Update to 1.1.3. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Vasile Dumitrascu Dec. 30, 2018, 7:40 p.m. UTC
* gnu/packages/ruby.scm (ruby-pg): Update to 1.1.3.
---
 gnu/packages/ruby.scm | 7 ++++---
 1 file changed, 4 insertions(+), 3 deletions(-)

Comments

Christopher Baines Jan. 1, 2019, 2:56 p.m. UTC | #1
Vasile Dumitrascu <va511e@yahoo.com> writes:

> * gnu/packages/ruby.scm (ruby-pg): Update to 1.1.3.
> ---
>  gnu/packages/ruby.scm | 7 ++++---
>  1 file changed, 4 insertions(+), 3 deletions(-)

Thanks Vasile, I've pushed this now as
4db80f8b118c28b7adfe7bd6fca7ebadff701bb9.

Chris
Vasile Dumitrascu Jan. 6, 2019, 1:31 p.m. UTC | #2
Hi Chris

Thank you for the merge,

  Vasile

GNU bug Tracking System:
> Your bug report
> 
> #33931: [PATCH] gnu: ruby-pg: Update to 1.1.3.
> 
> which was filed against the guix-patches package, has been closed.
> 
> The explanation is attached below, along with your original report.
> If you require more details, please reply to 33931@debbugs.gnu.org.
>

Patch

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 52832eeeb..343e0e872 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -10,6 +10,7 @@ 
 ;;; Copyright © 2017, 2018 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3327,14 +3328,14 @@  alternative to Marshal for Object serialization. ")
 (define-public ruby-pg
   (package
     (name "ruby-pg")
-    (version "0.21.0")
+    (version "1.1.3")
     (source
      (origin
        (method url-fetch)
        (uri (rubygems-uri "pg" version))
        (sha256
         (base32
-         "00vhasqwc4f98qb4wxqn2h07fjwzhp5lwyi41j2gndi2g02wrdqh"))))
+         "1pnjw3rspdfjssxyf42jnbsdlgri8ylysimp0s28wxb93k6ff2qb"))))
     (build-system ruby-build-system)
     (arguments
      '(#:test-target "spec"))
@@ -3346,7 +3347,7 @@  alternative to Marshal for Object serialization. ")
      `(("postgresql" ,postgresql-9.6)))
     (synopsis "Ruby interface to PostgreSQL")
     (description "Pg is the Ruby interface to the PostgreSQL RDBMS.  It works
-with PostgreSQL 8.4 and later.")
+with PostgreSQL 9.0 and later.")
     (home-page "https://bitbucket.org/ged/ruby-pg")
     (license license:ruby)))