[bug#33902] gnu: Add wlstream.

Message ID 20181229134626.7c48f721@mykolab.com
State Accepted
Headers show
Series [bug#33902] gnu: Add wlstream. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Rutger Helling Dec. 29, 2018, 12:46 p.m. UTC
Hey Guix,

these patches add wlstream. It needs libdrm support in ffmpeg, which
the first patch does.

Tested and working under Sway with:
wlstream 25 vaapi /dev/dri/renderD128 libx264rgb bgr0 12 output.mkv

Comments

Brendan Tildesley Dec. 29, 2018, 2:38 p.m. UTC | #1
The description for wlstream is vague and the English unnatural
("streams" should be "stream"). I'm not sure what it does and the git
repo doesn't even provide an explanation. Could you write  a more
thorough description?

Patch

From 5593f737c1fbbc9761c3ec667539a99be0f40526 Mon Sep 17 00:00:00 2001
From: Rutger Helling <rhelling@mykolab.com>
Date: Fri, 28 Dec 2018 20:37:01 +0100
Subject: [PATCH 2/2] gnu: Add wlstream.

* gnu/packages/video.scm (wlstream): New variable.
---
 gnu/packages/video.scm | 28 ++++++++++++++++++++++++++++
 1 file changed, 28 insertions(+)

diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index d7675d5cd..8edf3fb8c 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -3286,3 +3286,31 @@  transitions, and effects and then export your film to many common formats.")
     (description "dav1d is a new AV1 cross-platform decoder, and focused on
 speed and correctness.")
     (license license:bsd-2)))
+
+(define-public wlstream
+  (let ((commit "182076a94562b128c3a97ecc53cc68905ea86838")
+        (revision "1"))
+    (package
+     (name "wlstream")
+     (version (git-version "0.0" revision commit))
+     (source
+      (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/atomnuker/wlstream.git")
+             (commit commit)))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32
+         "01qbcgfl3g9kfwn1jf1z9pdj3bvf5lmg71d1vwkcllc2az24bjqp"))))
+     (build-system meson-build-system)
+     (native-inputs `(("libdrm" ,libdrm)
+                      ("pkg-config" ,pkg-config)))
+     (inputs `(("ffmpeg" ,ffmpeg)
+               ("pulseaudio" ,pulseaudio)
+               ("wayland" ,wayland)
+               ("wayland-protocols" ,wayland-protocols)))
+     (home-page "https://github.com/atomnuker/wlstream")
+     (synopsis "Record and streams from a Wayland session")
+     (description "Wlstream can record and streams from a Wayland session.")
+     (license license:lgpl2.1+))))
-- 
2.20.1