[bug#33888] gnu: Add sway.

Message ID 20181227160503.2d059a36@mykolab.com
State Accepted
Headers show
Series [bug#33888] gnu: Add sway. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Rutger Helling Dec. 27, 2018, 3:05 p.m. UTC
Hey Guix,

these patches add Sway.

Note that with
(screen-locker-service sway "swaylock")
we should now have a native Wayland screen locker.

Supposedly this can be done without making the swaylock binary SUID,
but I've been unable to figure out how.

Comments

Rutger Helling Dec. 29, 2018, 1:01 p.m. UTC | #1
I've been told that the Sway developers don't want this release
packaged. And it unfortunately also depends on staging, which I
missed.

Having said that, if there are no objections I'd like to merge this
once it hits 1.0 and staging is merged.

On Thu, 27 Dec 2018 16:05:03 +0100
Rutger Helling <rhelling@mykolab.com> wrote:

> Hey Guix,
> 
> these patches add Sway.
> 
> Note that with
> (screen-locker-service sway "swaylock")
> we should now have a native Wayland screen locker.
> 
> Supposedly this can be done without making the swaylock binary SUID,
> but I've been unable to figure out how.
Rutger Helling March 11, 2019, 7:37 p.m. UTC | #2
Sway 1.0 just got released. Since this bug has been open for a very
long time and all the pieces are in place, I've gone ahead with
rebasing and merging.

On Sat, 29 Dec 2018 14:01:07 +0100
Rutger Helling <rhelling@mykolab.com> wrote:

> I've been told that the Sway developers don't want this release
> packaged. And it unfortunately also depends on staging, which I
> missed.
> 
> Having said that, if there are no objections I'd like to merge this
> once it hits 1.0 and staging is merged.
> 
> On Thu, 27 Dec 2018 16:05:03 +0100
> Rutger Helling <rhelling@mykolab.com> wrote:
> 
> > Hey Guix,
> > 
> > these patches add Sway.
> > 
> > Note that with
> > (screen-locker-service sway "swaylock")
> > we should now have a native Wayland screen locker.
> > 
> > Supposedly this can be done without making the swaylock binary SUID,
> > but I've been unable to figure out how.  
>
Marius Bakke March 11, 2019, 7:55 p.m. UTC | #3
Rutger Helling <rhelling@mykolab.com> writes:

> Sway 1.0 just got released. Since this bug has been open for a very
> long time and all the pieces are in place, I've gone ahead with
> rebasing and merging.

Excellent!  I have used this for a while and it works great.  Thanks!
Meiyo Peng March 14, 2019, 4:01 a.m. UTC | #4
Hi Rutger,

Rutger Helling writes:

> Sway 1.0 just got released. Since this bug has been open for a very
> long time and all the pieces are in place, I've gone ahead with
> rebasing and merging.

Cool!  I will try it out.


--
Meiyo Peng
https://www.pengmeiyu.com/

Patch

From ac73b2a037fb73547b5e14f5b90e1cc8383b8bad Mon Sep 17 00:00:00 2001
From: Rutger Helling <rhelling@mykolab.com>
Date: Thu, 27 Dec 2018 15:49:54 +0100
Subject: [PATCH 2/2] gnu: Add sway.

* gnu/packages/wm.scm (sway): New variable.
---
 gnu/packages/wm.scm | 39 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 39 insertions(+)

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index b9500f8db..0bced1bc9 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -80,6 +80,9 @@ 
   #:use-module (gnu packages mpd)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages video)
+  #:use-module (gnu packages gtk)
+  #:use-module (gnu packages man)
+  #:use-module (gnu packages version-control)
   #:use-module (guix download)
   #:use-module (guix git-download))
 
@@ -1143,3 +1146,39 @@  Wayland compositor")
 modules for building a Wayland compositor.")
    ; MIT license
    (license license:expat)))
+
+(define-public sway
+  (package
+   (name "sway")
+   (version "1.0-beta.2")
+   (source
+    (origin
+     (method git-fetch)
+     (uri (git-reference
+           (url "https://github.com/swaywm/sway.git")
+           (commit version)))
+     (file-name (git-file-name name version))
+     (sha256
+      (base32 "0f9rniwizbc3vzxdy6rc47749p6gczfbgfdy4r458134rbl551hw"))))
+   (build-system meson-build-system)
+   (native-inputs `(("cairo" ,cairo)
+                    ("elogind" ,elogind)
+                    ("gdk-pixbuf" ,gdk-pixbuf)
+                    ("git" ,git)
+                    ("json-c" ,json-c)
+                    ("libcap" ,libcap)
+                    ("libinput" ,libinput)
+                    ("libxkbcommon" ,libxkbcommon)
+                    ("linux-pam" ,linux-pam)
+                    ("mesa" ,mesa)
+                    ("pango" ,pango)
+                    ("pkg-config" ,pkg-config)
+                    ("scdoc" ,scdoc)
+                    ("wayland" ,wayland)
+                    ("wayland-protocols" ,wayland-protocols)
+                    ("wlroots" ,wlroots)))
+   (home-page "https://github.com/swaywm/sway")
+   (synopsis "Wayland compositor compatible with i3")
+   (description "Sway is a i3-compatible Wayland compositor.")
+   ; MIT license
+   (license license:expat)))
2.20.1