[bug#33849] gnu: Add polybar

Message ID 878t0f5tii.fsf@gmail.com
State Accepted
Headers show
Series [bug#33849] gnu: Add polybar | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Meiyo Peng Dec. 24, 2018, 6:27 a.m. UTC
Hi,

Ludovic Courtès <ludo@gnu.org> writes:

>> +    (source
>> +     (origin
>> +       (method url-fetch)
>> +       (uri (string-append "https://github.com/jaagr/polybar/releases/"
>> +                           "download/" version "/polybar.tar"))
>> +       (sha256
>> +        (base32 "1zpsvh1n77bx7s6mqqh3ba828k9xbp35c2mjmcl9nywfp6r5ldqi"))
>> +       (file-name (string-append name "-" version ".tar"))))
>
> Please use ‘git-fetch’ rather than downloading a generated tarball (it’s
> a generated tarball, right?).

No. This is a user uploaded release tarball. You can notice their
difference. User uploaded tarball has "/releases/download/" in its URL.

#+BEGIN_EXAMPLE
  User uploaded:  https://github.com/jaagr/polybar/releases/download/3.3.0/polybar.tar
  Auto generated: https://github.com/jaagr/polybar/archive/3.3.0.tar.gz
#+END_EXAMPLE

I tried to use the git-fetch method first, but it failed to build
because git-fetch doesn't fetch git submodules. Do we support
recursively fetching git submodules?

>> +    (build-system cmake-build-system)
>> +    (arguments
>> +     ;; Test is disabled because it requires downloading googletest from the
>> +     ;; Internet.
>> +     '(#:tests? #f))
>
> Did you try adding ‘googletest’ to ‘native-inputs’, and perhaps also
> disabling the code that tries to download it?

I checked the CMakeLists.txt, but it's too complex for me.  I am not
familiar with cmake, so I prefer not to patch it.

> The rest LGTM!  Could you send an updated patch?

The author released a new version after I sent the last patch. So here
is a new patch with version 3.3.0.
--
Meiyo Peng
https://www.pengmeiyu.com/

Comments

Ludovic Courtès Dec. 25, 2018, 4:45 p.m. UTC | #1
Hi,

Meiyo Peng <meiyo.peng@gmail.com> skribis:

> Ludovic Courtès <ludo@gnu.org> writes:
>
>>> +    (source
>>> +     (origin
>>> +       (method url-fetch)
>>> +       (uri (string-append "https://github.com/jaagr/polybar/releases/"
>>> +                           "download/" version "/polybar.tar"))
>>> +       (sha256
>>> +        (base32 "1zpsvh1n77bx7s6mqqh3ba828k9xbp35c2mjmcl9nywfp6r5ldqi"))
>>> +       (file-name (string-append name "-" version ".tar"))))
>>
>> Please use ‘git-fetch’ rather than downloading a generated tarball (it’s
>> a generated tarball, right?).
>
> No. This is a user uploaded release tarball. You can notice their
> difference. User uploaded tarball has "/releases/download/" in its URL.
>
> #+BEGIN_EXAMPLE
>   User uploaded:  https://github.com/jaagr/polybar/releases/download/3.3.0/polybar.tar
>   Auto generated: https://github.com/jaagr/polybar/archive/3.3.0.tar.gz
> #+END_EXAMPLE

Oh right, so that’s OK.

> I tried to use the git-fetch method first, but it failed to build
> because git-fetch doesn't fetch git submodules. Do we support
> recursively fetching git submodules?

Yes, just add (recursive? #t).

>>From 3faa9dcf77ca83972db6234a9af6b22325ee0311 Mon Sep 17 00:00:00 2001
> From: Meiyo Peng <meiyo.peng@gmail.com>
> Date: Sun, 23 Dec 2018 23:05:38 +0800
> Subject: [PATCH] gnu: Add polybar.
>
> * gnu/packages/wm.scm (polybar): New variable.

Applied, thanks!

Ludo’.

Patch

From 3faa9dcf77ca83972db6234a9af6b22325ee0311 Mon Sep 17 00:00:00 2001
From: Meiyo Peng <meiyo.peng@gmail.com>
Date: Sun, 23 Dec 2018 23:05:38 +0800
Subject: [PATCH] gnu: Add polybar.

* gnu/packages/wm.scm (polybar): New variable.
---
 gnu/packages/wm.scm | 43 +++++++++++++++++++++++++++++++++++++++++++
 1 file changed, 43 insertions(+)

diff --git a/gnu/packages/wm.scm b/gnu/packages/wm.scm
index 2e211e389..a761bce23 100644
--- a/gnu/packages/wm.scm
+++ b/gnu/packages/wm.scm
@@ -76,6 +76,7 @@ 
   #:use-module (gnu packages lua)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages suckless)
+  #:use-module (gnu packages mpd)
   #:use-module (guix download)
   #:use-module (guix git-download))
 
@@ -1051,3 +1052,45 @@  its size
 @item Display preview images in a tiled icon layout
 @end itemize")
     (license license:gpl2+)))
+
+(define-public polybar
+  (package
+    (name "polybar")
+    (version "3.3.0")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://github.com/jaagr/polybar/releases/"
+                           "download/" version "/polybar.tar"))
+       (sha256
+        (base32 "0sjh3xmf11g09spi88zj7xsc3a3vv78kixab6n5i7436py7xwzb4"))
+       (file-name (string-append name "-" version ".tar"))))
+    (build-system cmake-build-system)
+    (arguments
+     ;; Test is disabled because it requires downloading googletest from the
+     ;; Internet.
+     '(#:tests? #f))
+    (inputs
+     `(("alsa-lib" ,alsa-lib)
+       ("cairo" ,cairo)
+       ("i3-wm" ,i3-wm)
+       ("libmpdclient" ,libmpdclient)
+       ("libnl" ,libnl)
+       ("libxcb" ,libxcb)
+       ("pulseaudio" ,pulseaudio)
+       ("xcb-proto" ,xcb-proto)
+       ("xcb-util" ,xcb-util)
+       ("xcb-util-cursor" ,xcb-util-cursor)
+       ("xcb-util-image" ,xcb-util-image)
+       ("xcb-util-wm" ,xcb-util-wm)
+       ("xcb-util-xrm" ,xcb-util-xrm)))
+    (native-inputs
+     `(("pkg-config" ,pkg-config)
+       ("python-2" ,python-2)           ; lib/xpp depends on python 2
+       ("python" ,python)))             ; xcb-proto depends on python 3
+    (home-page "https://polybar.github.io/")
+    (synopsis "Fast and easy-to-use status bar")
+    (description "Polybar aims to help users build beautiful and highly
+customizable status bars for their desktop environment.  It has built-in
+functionality to display information about the most commonly used services.")
+    (license license:expat)))
-- 
2.20.0