[bug#33846] gnu: ruby: Remove versions 1.8, 2.1 and 2.2.

Message ID 87ftuod1ky.fsf@gmail.com
State Accepted
Headers show
Series [bug#33846] gnu: ruby: Remove versions 1.8, 2.1 and 2.2. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Alex Vong Dec. 23, 2018, 9:39 a.m. UTC
Hello,

This patch removes all ruby versions which have reached EOL since they
no longer receive official security updates.

However, please do complain if you need to use one of these
versions. IMO, it is better to have a central place for them to receive
(unofficial) security updates (e.g. Debian will support ruby 2.1 until
2020), than to roll your own security updates (which is error-prone and
duplicate effort).
Cheers,
Alex

Comments

Pjotr Prins Dec. 24, 2018, 8:22 a.m. UTC | #1
On Sun, Dec 23, 2018 at 05:39:09PM +0800, Alex Vong wrote:
> Hello,
> 
> This patch removes all ruby versions which have reached EOL since they
> no longer receive official security updates.
> 
> However, please do complain if you need to use one of these
> versions. IMO, it is better to have a central place for them to receive
> (unofficial) security updates (e.g. Debian will support ruby 2.1 until
> 2020), than to roll your own security updates (which is error-prone and
> duplicate effort).
> 

Thanks Alex,

No objection. Note that we now have the channel mechanism to suport
older versions of software we don't need to maintain older versions
inside GNU Guix if there are no down stream dependencies.

Pj.
Alex Vong Dec. 25, 2018, 5:59 p.m. UTC | #2
Pjotr Prins <pjotr.public12@thebird.nl> writes:

> On Sun, Dec 23, 2018 at 05:39:09PM +0800, Alex Vong wrote:
>> Hello,
>> 
>> This patch removes all ruby versions which have reached EOL since they
>> no longer receive official security updates.
>> 
>> However, please do complain if you need to use one of these
>> versions. IMO, it is better to have a central place for them to receive
>> (unofficial) security updates (e.g. Debian will support ruby 2.1 until
>> 2020), than to roll your own security updates (which is error-prone and
>> duplicate effort).
>> 
>
> Thanks Alex,
>
> No objection. Note that we now have the channel mechanism to suport
> older versions of software we don't need to maintain older versions
> inside GNU Guix if there are no down stream dependencies.
>
OK. I have found that there is a guix-chromium channel. So I think I
understand what you mean now.

> Pj.

Thanks,
Alex
Alex Vong Jan. 2, 2019, 8 a.m. UTC | #3
I add the missing copyright notice
and push as 8ef06557473e4394c2d0d9d54b45c43456419b66

Alex Vong <alexvong1995@gmail.com> writes:

> Pjotr Prins <pjotr.public12@thebird.nl> writes:
>
>> On Sun, Dec 23, 2018 at 05:39:09PM +0800, Alex Vong wrote:
>>> Hello,
>>> 
>>> This patch removes all ruby versions which have reached EOL since they
>>> no longer receive official security updates.
>>> 
>>> However, please do complain if you need to use one of these
>>> versions. IMO, it is better to have a central place for them to receive
>>> (unofficial) security updates (e.g. Debian will support ruby 2.1 until
>>> 2020), than to roll your own security updates (which is error-prone and
>>> duplicate effort).
>>> 
>>
>> Thanks Alex,
>>
>> No objection. Note that we now have the channel mechanism to suport
>> older versions of software we don't need to maintain older versions
>> inside GNU Guix if there are no down stream dependencies.
>>
> OK. I have found that there is a guix-chromium channel. So I think I
> understand what you mean now.
>
>> Pj.
>
> Thanks,
> Alex

Patch

From 2063870b76c6197e34764750f7ca6be1f41d8871 Mon Sep 17 00:00:00 2001
From: Alex Vong <alexvong1995@gmail.com>
Date: Sat, 22 Dec 2018 07:30:41 +0800
Subject: [PATCH] gnu: ruby: Remove versions 1.8, 2.1 and 2.2.

Remove ruby versions which have reached EOL.

See <https://lists.gnu.org/archive/html/guix-devel/2018-11/msg00421.html>.

* gnu/packages/ruby.scm (ruby-1.8, ruby-2.1, ruby-2.2): Remove variables.
---
 gnu/packages/ruby.scm | 68 -------------------------------------------
 1 file changed, 68 deletions(-)

diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 52832eeeb..2063579e0 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -126,74 +126,6 @@  a focus on simplicity and productivity.")
                    (delete-file-recursively "ext/fiddle/libffi-3.2.1")
                    #t))))))
 
-(define-public ruby-2.2
-  (package (inherit ruby)
-    (version "2.2.10")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "http://cache.ruby-lang.org/pub/ruby/"
-                           (version-major+minor version)
-                           "/ruby-" version ".tar.xz"))
-       (sha256
-        (base32
-         "0l5nk9mc0q4769d2i9d9y1izk0pk0lms2bl8s3lclv36wsvvqxxz"))))))
-
-(define-public ruby-2.1
-  (package (inherit ruby)
-    (version "2.1.10")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "http://cache.ruby-lang.org/pub/ruby/"
-                           (version-major+minor version)
-                           "/ruby-" version ".tar.bz2"))
-       (sha256
-        (base32
-         "1wglbd599mlwxfcb2xgqcxi2shr363pjn5dpbv11m04si9bpaim7"))))
-    (arguments
-     `(#:test-target "test"
-       #:parallel-tests? #f
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'replace-bin-sh
-           (lambda _
-             (substitute* '("Makefile.in"
-                            "ext/pty/pty.c"
-                            "io.c"
-                            "lib/mkmf.rb"
-                            "process.c")
-               (("/bin/sh") (which "sh")))
-             #t)))))))
-
-(define-public ruby-1.8
-  (package (inherit ruby)
-    (version "1.8.7-p374")
-    (source
-     (origin
-       (method url-fetch)
-       (uri (string-append "http://cache.ruby-lang.org/pub/ruby/"
-                           (version-major+minor version)
-                           "/ruby-" version ".tar.bz2"))
-       (sha256
-        (base32
-         "1qq7khilwkayrhwmzlxk83scrmiqfi7lgsn4c63znyvz2c1lgqxl"))))
-    (native-search-paths '())
-    (arguments
-     `(#:test-target "test"
-       #:parallel-tests? #f
-       #:phases
-       (modify-phases %standard-phases
-         (add-before 'configure 'replace-bin-sh
-           (lambda _
-             (substitute* '("Makefile.in"
-                            "ext/pty/pty.c"
-                            "io.c"
-                            "lib/mkmf.rb"
-                            "process.c")
-               (("/bin/sh") (which "sh")))
-             #t)))))))
-
 (define-public ruby-highline
   (package
     (name "ruby-highline")
-- 
2.19.2