[bug#33800] gnu: Add grim.

Message ID 20181219103851.7cbbd4f2@mykolab.com
State Accepted
Headers show
Series [bug#33800] gnu: Add grim. | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Rutger Helling Dec. 19, 2018, 9:38 a.m. UTC
Hey Guix,

these patches add grim. Basically scrot, but for Wayland instead of X11.

Comments

Ludovic Courtès Dec. 19, 2018, 9:40 p.m. UTC | #1
Hi,

Rutger Helling <rhelling@mykolab.com> skribis:

> From a55c2fedeca18627e8f0aa23efc0c78e846e40ee Mon Sep 17 00:00:00 2001
> From: Rutger Helling <rhelling@mykolab.com>
> Date: Wed, 19 Dec 2018 10:27:28 +0100
> Subject: [PATCH 1/2] gnu: Add scdoc.
>
> * gnu/packages/man.scm (scdoc): New variable.

[...]

> +   (home-page "https://git.sr.ht/~sircmpwn/scdoc")
> +   (synopsis "Simple man page generator")
> +   (description "scdoc is a simple man page generator written for POSIX systems
> +written in C99.")

s/written in C99/in C99/

> +   ;; MIT license, see /share/doc/scdoc-1.6.0/COPYING.
> +   (license (x11-style "file://COPYING"))))

Should be ‘license:expat’.

> From 793ae79c8bbd68b981f4c4b94b43784011776ede Mon Sep 17 00:00:00 2001
> From: Rutger Helling <rhelling@mykolab.com>
> Date: Wed, 19 Dec 2018 10:31:50 +0100
> Subject: [PATCH 2/2] gnu: Add grim.
>
> * gnu/packages/image.scm (grim): New variable.

[...]

> +(define-public grim
> +  (package
> +  (name "grim")
> +  (version "1.0")
> +  (source
> +   (origin
> +    (method url-fetch)
> +    (uri (string-append "https://github.com/emersion/grim/archive/v" version
> +                        ".tar.gz"))
> +    (file-name (string-append name "-" version ".tar.gz"))
> +    (sha256
> +     (base32 "0xkk5nqyp1px0sxz4asmchznc0q39wdx1b67ql741k8aj815km0f"))))
> +  (build-system meson-build-system)
> +  (native-inputs `(("pkg-config" ,pkg-config)))
> +  (inputs `(("cairo" ,cairo)
> +            ("libjpeg-turbo" ,libjpeg-turbo)
> +            ("scdoc" ,scdoc)
> +            ("wayland" ,wayland)
> +            ("wayland-protocols" ,wayland-protocols)))
> +  (home-page "https://github.com/emersion/grim")
> +  (synopsis "Grab images from a Wayland compositor")
> +  (description "grim can grab images from a Wayland compositor.")

s/grab images/create screenshots/ ?  That would make it easier to find
via ‘guix package -s’.  :-)

> +  ;; MIT license.
> +  (license (license:x11-style
> +"https://raw.githubusercontent.com/emersion/grim/master/LICENSE"))))

‘license:expat’ as well, AFAICS:

  https://directory.fsf.org/wiki/License:Expat

OK with these changes, thanks!

Ludo’.
Rutger Helling Dec. 20, 2018, 8:03 a.m. UTC | #2
Pushed as e2dd54c09035aadce8a363c3b1faf703f025d62d and
0290f533cc879239f275e45a704334c545f77f3a with your changes, thanks for
the review!

On Wed, 19 Dec 2018 22:40:48 +0100
Ludovic Courtès <ludo@gnu.org> wrote:

> Hi,
> 
> Rutger Helling <rhelling@mykolab.com> skribis:
> 
> > From a55c2fedeca18627e8f0aa23efc0c78e846e40ee Mon Sep 17 00:00:00
> > 2001 From: Rutger Helling <rhelling@mykolab.com>
> > Date: Wed, 19 Dec 2018 10:27:28 +0100
> > Subject: [PATCH 1/2] gnu: Add scdoc.
> >
> > * gnu/packages/man.scm (scdoc): New variable.  
> 
> [...]
> 
> > +   (home-page "https://git.sr.ht/~sircmpwn/scdoc")
> > +   (synopsis "Simple man page generator")
> > +   (description "scdoc is a simple man page generator written for
> > POSIX systems +written in C99.")  
> 
> s/written in C99/in C99/
> 
> > +   ;; MIT license, see /share/doc/scdoc-1.6.0/COPYING.
> > +   (license (x11-style "file://COPYING"))))  
> 
> Should be ‘license:expat’.
> 
> > From 793ae79c8bbd68b981f4c4b94b43784011776ede Mon Sep 17 00:00:00
> > 2001 From: Rutger Helling <rhelling@mykolab.com>
> > Date: Wed, 19 Dec 2018 10:31:50 +0100
> > Subject: [PATCH 2/2] gnu: Add grim.
> >
> > * gnu/packages/image.scm (grim): New variable.  
> 
> [...]
> 
> > +(define-public grim
> > +  (package
> > +  (name "grim")
> > +  (version "1.0")
> > +  (source
> > +   (origin
> > +    (method url-fetch)
> > +    (uri (string-append
> > "https://github.com/emersion/grim/archive/v" version
> > +                        ".tar.gz"))
> > +    (file-name (string-append name "-" version ".tar.gz"))
> > +    (sha256
> > +     (base32
> > "0xkk5nqyp1px0sxz4asmchznc0q39wdx1b67ql741k8aj815km0f"))))
> > +  (build-system meson-build-system)
> > +  (native-inputs `(("pkg-config" ,pkg-config)))
> > +  (inputs `(("cairo" ,cairo)
> > +            ("libjpeg-turbo" ,libjpeg-turbo)
> > +            ("scdoc" ,scdoc)
> > +            ("wayland" ,wayland)
> > +            ("wayland-protocols" ,wayland-protocols)))
> > +  (home-page "https://github.com/emersion/grim")
> > +  (synopsis "Grab images from a Wayland compositor")
> > +  (description "grim can grab images from a Wayland compositor.")  
> 
> s/grab images/create screenshots/ ?  That would make it easier to find
> via ‘guix package -s’.  :-)
> 
> > +  ;; MIT license.
> > +  (license (license:x11-style
> > +"https://raw.githubusercontent.com/emersion/grim/master/LICENSE"))))  
> 
> ‘license:expat’ as well, AFAICS:
> 
>   https://directory.fsf.org/wiki/License:Expat
> 
> OK with these changes, thanks!
> 
> Ludo’.

Patch

From 793ae79c8bbd68b981f4c4b94b43784011776ede Mon Sep 17 00:00:00 2001
From: Rutger Helling <rhelling@mykolab.com>
Date: Wed, 19 Dec 2018 10:31:50 +0100
Subject: [PATCH 2/2] gnu: Add grim.

* gnu/packages/image.scm (grim): New variable.
---
 gnu/packages/image.scm | 30 ++++++++++++++++++++++++++++++
 1 file changed, 30 insertions(+)

diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 1a6b8fe1c..0a7164059 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -22,6 +22,7 @@ 
 ;;; Copyright © 2018 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2018 Pierre-Antoine Rouby <contact@parouby.fr>
 ;;; Copyright © 2018 Alex Vong <alexvong1995@gmail.com>
+;;; Copyright © 2018 Rutger Helling <rhelling@mykolab.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -49,6 +50,7 @@ 
   #:use-module (gnu packages compression)
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages freedesktop)
   ;; To provide gcc@5 and gcc@6, to work around <http://bugs.gnu.org/24703>.
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages gettext)
@@ -58,6 +60,7 @@ 
   #:use-module (gnu packages graphics)
   #:use-module (gnu packages gtk)
   #:use-module (gnu packages lua)
+  #:use-module (gnu packages man)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages mcrypt)
   #:use-module (gnu packages perl)
@@ -73,6 +76,7 @@ 
   #:use-module (guix git-download)
   #:use-module (guix build-system gnu)
   #:use-module (guix build-system cmake)
+  #:use-module (guix build-system meson)
   #:use-module (guix build-system python)
   #:use-module (guix build-system r)
   #:use-module (guix build-system scons)
@@ -1566,3 +1570,29 @@  identical visual appearance.")
     (description
      "Jp2a is a small utility that converts JPEG images to ASCII.")
     (license license:gpl2)))
+
+(define-public grim
+  (package
+  (name "grim")
+  (version "1.0")
+  (source
+   (origin
+    (method url-fetch)
+    (uri (string-append "https://github.com/emersion/grim/archive/v" version
+                        ".tar.gz"))
+    (file-name (string-append name "-" version ".tar.gz"))
+    (sha256
+     (base32 "0xkk5nqyp1px0sxz4asmchznc0q39wdx1b67ql741k8aj815km0f"))))
+  (build-system meson-build-system)
+  (native-inputs `(("pkg-config" ,pkg-config)))
+  (inputs `(("cairo" ,cairo)
+            ("libjpeg-turbo" ,libjpeg-turbo)
+            ("scdoc" ,scdoc)
+            ("wayland" ,wayland)
+            ("wayland-protocols" ,wayland-protocols)))
+  (home-page "https://github.com/emersion/grim")
+  (synopsis "Grab images from a Wayland compositor")
+  (description "grim can grab images from a Wayland compositor.")
+  ;; MIT license.
+  (license (license:x11-style
+"https://raw.githubusercontent.com/emersion/grim/master/LICENSE"))))
-- 
2.20.1