[bug#33706] gnu: php: Update to 7.3.0.

Message ID 20181211164214.26945-1-go.wigust@gmail.com
State Accepted
Headers show
Series [bug#33706] gnu: php: Update to 7.3.0. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Oleg Pykhalov Dec. 11, 2018, 4:42 p.m. UTC
* gnu/packages/php.scm (php)[version]: Update to 7.3.0.
[arguments]: Delete "sapi/cli/tests/upload_2G.phpt" substitution and
delete "ext/pcre/tests/bug76909.phpt" file.
[inputs]: Replace 'pcre' with 'pcre2'.
---
 gnu/packages/php.scm | 17 +++++++----------
 1 file changed, 7 insertions(+), 10 deletions(-)

Comments

Julien Lepiller Dec. 11, 2018, 8:25 p.m. UTC | #1
Hi,

Thanks for the patch! I haven't tested it yet, but I was wondering why update pcre to pcre2 while not stripping pcrelib anymore. Is thc directory not available anymore?

Le 11 décembre 2018 17:42:14 GMT+01:00, Oleg Pykhalov <go.wigust@gmail.com> a écrit :
>* gnu/packages/php.scm (php)[version]: Update to 7.3.0.
>[arguments]: Delete "sapi/cli/tests/upload_2G.phpt" substitution and
>delete "ext/pcre/tests/bug76909.phpt" file.
>[inputs]: Replace 'pcre' with 'pcre2'.
>---
> gnu/packages/php.scm | 17 +++++++----------
> 1 file changed, 7 insertions(+), 10 deletions(-)
>
>diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
>index a28cb31e5..491e08481 100644
>--- a/gnu/packages/php.scm
>+++ b/gnu/packages/php.scm
>@@ -53,7 +53,7 @@
> (define-public php
>   (package
>     (name "php")
>-    (version "7.2.12")
>+    (version "7.3.0")
>     (home-page "https://secure.php.net/")
>     (source (origin
>               (method url-fetch)
>@@ -61,7 +61,7 @@
>                                   name "-" version ".tar.xz"))
>               (sha256
>                (base32
>-               
>"1qbz2j9kzqxxp0mmx02zavvz20ji7izqdnri25g1mrwyhz60974q"))
>+               
>"1db0lm84hynilrjj3k1s7skp1y2gl4ip1ihr7662i2xgannmq6bx"))
>               (modules '((guix build utils)))
>               (snippet
>                '(with-directory-excursion "ext"
>@@ -74,7 +74,6 @@
>         ;;"fileinfo/libmagic" ; This is a patched version of libmagic.
>                             '("gd/libgd"
>                               "mbstring/oniguruma"
>-                              "pcre/pcrelib"
>                               "sqlite3/libsqlite"
>                               "xmlrpc/libxmlrpc"
>                               "zip/lib"))
>@@ -176,11 +175,6 @@
>              (substitute* "ext/standard/tests/streams/bug60602.phpt"
>                (("'ls'") (string-append "'" (which "ls") "'")))
> 
>-             ;; The expected output is slightly different from what is
>given,
>-             ;; in a section that's not related to the actual test
>-             (substitute* "sapi/cli/tests/upload_2G.phpt"
>-               (("Test\\\\n") "Test\n\n"))
>-
>              ;; Drop tests that are known to fail.
>              (for-each delete-file
>      '("ext/posix/tests/posix_getgrgid.phpt"    ; Requires /etc/group.
>@@ -291,7 +285,10 @@
>                          "ext/ldap/tests/ldap_set_option_error.phpt"
> 
>                          ;; Sometimes cannot start the LDAP server.
>-                         "ext/ldap/tests/bug76248.phpt"))
>+                         "ext/ldap/tests/bug76248.phpt"
>+
>+                         ;; Bug #76909 preg_match difference between
>7.3 and < 7.3
>+                         "ext/pcre/tests/bug76909.phpt"))
> 
>              ;; Skip tests requiring network access.
>              (setenv "SKIP_ONLINE_TESTS" "1")
>@@ -324,7 +321,7 @@
>        ("oniguruma" ,oniguruma-5)
>        ("openldap" ,openldap)
>        ("openssl" ,openssl)
>-       ("pcre" ,pcre)
>+       ("pcre" ,pcre2)
>        ("postgresql" ,postgresql)
>        ("readline" ,readline)
>        ("sqlite" ,sqlite)

Patch

diff --git a/gnu/packages/php.scm b/gnu/packages/php.scm
index a28cb31e5..491e08481 100644
--- a/gnu/packages/php.scm
+++ b/gnu/packages/php.scm
@@ -53,7 +53,7 @@ 
 (define-public php
   (package
     (name "php")
-    (version "7.2.12")
+    (version "7.3.0")
     (home-page "https://secure.php.net/")
     (source (origin
               (method url-fetch)
@@ -61,7 +61,7 @@ 
                                   name "-" version ".tar.xz"))
               (sha256
                (base32
-                "1qbz2j9kzqxxp0mmx02zavvz20ji7izqdnri25g1mrwyhz60974q"))
+                "1db0lm84hynilrjj3k1s7skp1y2gl4ip1ihr7662i2xgannmq6bx"))
               (modules '((guix build utils)))
               (snippet
                '(with-directory-excursion "ext"
@@ -74,7 +74,6 @@ 
                             ;;"fileinfo/libmagic" ; This is a patched version of libmagic.
                             '("gd/libgd"
                               "mbstring/oniguruma"
-                              "pcre/pcrelib"
                               "sqlite3/libsqlite"
                               "xmlrpc/libxmlrpc"
                               "zip/lib"))
@@ -176,11 +175,6 @@ 
              (substitute* "ext/standard/tests/streams/bug60602.phpt"
                (("'ls'") (string-append "'" (which "ls") "'")))
 
-             ;; The expected output is slightly different from what is given,
-             ;; in a section that's not related to the actual test
-             (substitute* "sapi/cli/tests/upload_2G.phpt"
-               (("Test\\\\n") "Test\n\n"))
-
              ;; Drop tests that are known to fail.
              (for-each delete-file
                        '("ext/posix/tests/posix_getgrgid.phpt"    ; Requires /etc/group.
@@ -291,7 +285,10 @@ 
                          "ext/ldap/tests/ldap_set_option_error.phpt"
 
                          ;; Sometimes cannot start the LDAP server.
-                         "ext/ldap/tests/bug76248.phpt"))
+                         "ext/ldap/tests/bug76248.phpt"
+
+                         ;; Bug #76909 preg_match difference between 7.3 and < 7.3
+                         "ext/pcre/tests/bug76909.phpt"))
 
              ;; Skip tests requiring network access.
              (setenv "SKIP_ONLINE_TESTS" "1")
@@ -324,7 +321,7 @@ 
        ("oniguruma" ,oniguruma-5)
        ("openldap" ,openldap)
        ("openssl" ,openssl)
-       ("pcre" ,pcre)
+       ("pcre" ,pcre2)
        ("postgresql" ,postgresql)
        ("readline" ,readline)
        ("sqlite" ,sqlite)