Message ID | 1544040360-1238-1-git-send-email-pgarlick@tourbillion-technology.com |
---|---|
State | Accepted |
Commit | 72f95783f118a90e593e8c37922389ab199fdaeb |
Headers | show |
Series | [bug#33635] gnu: petsc-openmpi: Ensure compatibility of SCOTCH dependency. | expand |
Context | Check | Description |
---|---|---|
cbaines/applying patch | success | Successfully applied |
Hi Paul, Paul Garlick <pgarlick@tourbillion-technology.com> skribis: > * gnu/packages/maths.scm (petsc-openmpi)[inputs]: Replace pt-scotch > with pt-scotch32 in order to prevent 'incompatible pointer' warnings > being generated in the 'build' phase. Applied! Did it lead to crashes at run time? Thanks, Ludo’.
Hi Ludo,
> Did it lead to crashes at run time?
I have not seen any crashes at runtime. The issue is to do with the
integer values used for matrix indexing. PETSc can be built using 64-
bit indexing but defaults to 32-bit. So this patch enforces
consistency between PETSc and SCOTCH.
Best regards,
Paul.
diff --git a/gnu/packages/maths.scm b/gnu/packages/maths.scm index f88cede..c35bf9e 100644 --- a/gnu/packages/maths.scm +++ b/gnu/packages/maths.scm @@ -1772,7 +1772,7 @@ scientific applications modeled by partial differential equations.") ("mumps" ,mumps-openmpi) ("openmpi" ,openmpi) ("scalapack" ,scalapack) - ("scotch" ,pt-scotch) + ("scotch" ,pt-scotch32) ,@(package-inputs petsc))) (arguments (substitute-keyword-arguments (package-arguments petsc)