diff mbox series

[bug#53878,v5,14/22] gnu: chez-scheme: Use shared zlib and lz4.

Message ID 20220226130254.1301333-15-philip@philipmcgrath.com
State Accepted
Headers show
Series Update Racket to 8.4. Adjust Chez Scheme packages. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Philip McGrath Feb. 26, 2022, 1:02 p.m. UTC
This change also involves building 'libkernel.a' instead of 'kernel.o'.

Support for these build options was merged upstream in 2019: see
discussion at <https://github.com/cisco/ChezScheme/pull/443>.

* gnu/packages/chez.scm (chez-scheme)[inputs]: Remove 'zlib:static' and
'lz4:static'.
[arguments]: Adjust configure phase accordingly.
---
 gnu/packages/chez.scm | 18 ++++++++----------
 1 file changed, 8 insertions(+), 10 deletions(-)
diff mbox series

Patch

diff --git a/gnu/packages/chez.scm b/gnu/packages/chez.scm
index 0a84a07247..43332c06ad 100644
--- a/gnu/packages/chez.scm
+++ b/gnu/packages/chez.scm
@@ -211,9 +211,7 @@  (define-public chez-scheme
     (inputs
      `(("libuuid" ,util-linux "lib")
        ("zlib" ,zlib)
-       ("zlib:static" ,zlib "static")
        ("lz4" ,lz4)
-       ("lz4:static" ,lz4 "static")
        ;; for expeditor:
        ("ncurses" ,ncurses)
        ;; for X11 clipboard support in expeditor:
@@ -266,14 +264,14 @@  (define src
                     (lz4-static (assoc-ref inputs "lz4:static"))
                     (out (assoc-ref outputs "out"))
                     ;; add flags which are always required:
-                    (flags (cons*
-                            (string-append "--installprefix=" out)
-                            (string-append "ZLIB=" zlib-static "/lib/libz.a")
-                            (string-append "LZ4=" lz4-static "/lib/liblz4.a")
-                            ;; Guix will do compress man pages,
-                            ;; and letting Chez try causes an error
-                            "--nogzip-man-pages"
-                            configure-flags)))
+                    (flags (cons* (string-append "--installprefix=" out)
+                                  "ZLIB=-lz"
+                                  "LZ4=-llz4"
+                                  "--libkernel"
+                                  ;; Guix will do compress-man-pages,
+                                  ;; and letting Chez try causes an error
+                                  "--nogzip-man-pages"
+                                  configure-flags)))
                (format #t "configure flags: ~s~%" flags)
                ;; Some makefiles (for tests) don't seem to propagate CC
                ;; properly, so we take it out of their hands: