[bug#53813] gnu: Add emacs-consult-dir.
Commit Message
* gnu/packages/emacs-xyz.scm (emacs-consult-dir): New variable.
---
gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
1 file changed, 25 insertions(+)
Comments
Andrew Tropin schreef op zo 06-02-2022 om 07:58 [+0300]:
> +When using the minibuffer, you can switch - with completion and
> +filtering provided by your completion setup - to any directory
> you’ve
Typographically, these should be two or three dashes (or a fancy
unicode em dash or figure dash, not sure which one exactly), not a
single dash, typographically speaking.
Greetings,
Maxime.
Hello,
Andrew Tropin <andrew@trop.in> writes:
> * gnu/packages/emacs-xyz.scm (emacs-consult-dir): New variable.
Thank you.
I fixed indentation, typographic issues in the description and moved the
package definition elsewhere than at the bottom of the module.
Applied!
Regards,
On 2022-02-06 22:14, GNU bug Tracking System wrote:
> Your bug report
>
> #53813: [PATCH] gnu: Add emacs-consult-dir.
>
> which was filed against the guix-patches package, has been closed.
>
> The explanation is attached below, along with your original report.
> If you require more details, please reply to 53813@debbugs.gnu.org.
>
> --
> 53813: http://debbugs.gnu.org/cgi/bugreport.cgi?bug=53813
> GNU Bug Tracking System
> Contact help-debbugs@gnu.org with problems
> From: Nicolas Goaziou <mail@nicolasgoaziou.fr>
> Subject: Re: [bug#53813] [PATCH] gnu: Add emacs-consult-dir.
> To: Andrew Tropin <andrew@trop.in>
> Cc: 53813-done@debbugs.gnu.org
> Date: Sun, 06 Feb 2022 23:13:30 +0100
>
> Hello,
>
> Andrew Tropin <andrew@trop.in> writes:
>
>> * gnu/packages/emacs-xyz.scm (emacs-consult-dir): New variable.
>
> Thank you.
>
> I fixed indentation, typographic issues in the description and moved the
> package definition elsewhere than at the bottom of the module.
>
> Applied!
Oops, I'm a little bit late. Thank you very much for fixing it!)
Maxime, thank you for catching the issue :)
>
> Regards,
> --
> Nicolas Goaziou
>
> From: Andrew Tropin <andrew@trop.in>
> Subject: [PATCH] gnu: Add emacs-consult-dir.
> To: guix-patches@gnu.org
> Date: Sun, 06 Feb 2022 07:58:46 +0300
>
>
> * gnu/packages/emacs-xyz.scm (emacs-consult-dir): New variable.
> ---
> gnu/packages/emacs-xyz.scm | 25 +++++++++++++++++++++++++
> 1 file changed, 25 insertions(+)
>
> diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
> index 444b761116..6bdfb8de04 100644
> --- a/gnu/packages/emacs-xyz.scm
> +++ b/gnu/packages/emacs-xyz.scm
> @@ -30090,3 +30090,28 @@ (define-public emacs-fennel-mode
> "Fennel mode provides font-lock, indentation, navigation, and REPL for
> Fennel code within Emacs.")
> (license license:gpl3+)))
> +
> +(define-public emacs-consult-dir
> + (package
> + (name "emacs-consult-dir")
> + (version "0.1")
> + (source (origin
> + (method git-fetch)
> + (uri (git-reference
> + (url "https://github.com/karthink/consult-dir")
> + (commit (string-append "v" version))))
> + (sha256
> + (base32 "1cff4ssrn1mw2s5n090pdmwdirnfih8idg5f0ll2bi2djc4hq5kn"))
> + (file-name (git-file-name name version))))
> + (build-system emacs-build-system)
> + (license license:gpl3+)
> + (propagated-inputs (list emacs-consult))
> + (home-page "https://github.com/karthink/consult-dir")
> + (synopsis "Insert paths into minibuffer prompts in Emacs")
> + (description "Consult-dir allows you to easily insert directory
> +paths into the minibuffer prompt in Emacs.
> +
> +When using the minibuffer, you can switch - with completion and
> +filtering provided by your completion setup - to any directory you’ve
> +visited recently, or to a project or bookmarked directory. The
> +minibuffer prompt will be replaced with the directory you choose.")))
@@ -30090,3 +30090,28 @@ (define-public emacs-fennel-mode
"Fennel mode provides font-lock, indentation, navigation, and REPL for
Fennel code within Emacs.")
(license license:gpl3+)))
+
+(define-public emacs-consult-dir
+ (package
+ (name "emacs-consult-dir")
+ (version "0.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/karthink/consult-dir")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32 "1cff4ssrn1mw2s5n090pdmwdirnfih8idg5f0ll2bi2djc4hq5kn"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (license license:gpl3+)
+ (propagated-inputs (list emacs-consult))
+ (home-page "https://github.com/karthink/consult-dir")
+ (synopsis "Insert paths into minibuffer prompts in Emacs")
+ (description "Consult-dir allows you to easily insert directory
+paths into the minibuffer prompt in Emacs.
+
+When using the minibuffer, you can switch - with completion and
+filtering provided by your completion setup - to any directory you’ve
+visited recently, or to a project or bookmarked directory. The
+minibuffer prompt will be replaced with the directory you choose.")))