[bug#33600,3/3] build: Default to https://ci.guix.info for substitutes.

Message ID 20181203155335.10629-3-ludo@gnu.org
State Accepted
Commit 0a5fa004f7f21dc3e01747b8e94fbb21e056e4ca
Headers show
Series Defaulting to ci.guix.info (aka. berlin.guixsd.org) | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch success Successfully applied

Commit Message

Ludovic Courtès Dec. 3, 2018, 3:53 p.m. UTC
* config-daemon.ac (guix_substitute_urls): Always default to
"https://ci.guix.info".
* doc/guix.texi (SUBSTITUTE-SERVER): Switch to ci.guix.info.
* guix/scripts/build.scm (%default-log-urls): Likewise.
* guix/scripts/substitute.scm (%default-substitute-urls): Likewise.
* guix/store.scm (%default-substitute-urls): Likewise.
---
 config-daemon.ac            | 10 +---------
 doc/guix.texi               | 13 ++++---------
 guix/scripts/build.scm      |  2 +-
 guix/scripts/substitute.scm |  2 +-
 guix/store.scm              |  2 +-
 5 files changed, 8 insertions(+), 21 deletions(-)

Comments

Ricardo Wurmus Dec. 3, 2018, 8:38 p.m. UTC | #1
Ludovic Courtès <ludo@gnu.org> writes:

> * doc/guix.texi (SUBSTITUTE-SERVER): Switch to ci.guix.info.
[…]
> diff --git a/doc/guix.texi b/doc/guix.texi
> index d96c35eace..a5ae1c65e6 100644
> --- a/doc/guix.texi
> +++ b/doc/guix.texi
> @@ -14,7 +14,7 @@
>  @set KEY-SERVER pool.sks-keyservers.net
>  
>  @c The official substitute server used by default.
> -@set SUBSTITUTE-SERVER ci.guix.info
> +@set SUBSTITUTE-SERVER mirror.hydra.gnu.org

Is this really correct?
Ludovic Courtès Dec. 4, 2018, 2:14 p.m. UTC | #2
Ricardo Wurmus <rekado@elephly.net> skribis:

> Ludovic Courtès <ludo@gnu.org> writes:
>
>> * doc/guix.texi (SUBSTITUTE-SERVER): Switch to ci.guix.info.
> […]
>> diff --git a/doc/guix.texi b/doc/guix.texi
>> index d96c35eace..a5ae1c65e6 100644
>> --- a/doc/guix.texi
>> +++ b/doc/guix.texi
>> @@ -14,7 +14,7 @@
>>  @set KEY-SERVER pool.sks-keyservers.net
>>  
>>  @c The official substitute server used by default.
>> -@set SUBSTITUTE-SERVER ci.guix.info
>> +@set SUBSTITUTE-SERVER mirror.hydra.gnu.org
>
> Is this really correct?

Oops, I must have messed up while preparing the patches.
Thanks for the heads-up!

Ludo’.

Patch

diff --git a/config-daemon.ac b/config-daemon.ac
index aac46817f5..e5b0ee082c 100644
--- a/config-daemon.ac
+++ b/config-daemon.ac
@@ -120,15 +120,7 @@  if test "x$guix_build_daemon" = "xyes"; then
 
   dnl Determine the appropriate default list of substitute URLs (GnuTLS
   dnl is required so we can default to 'https'.)
-  case "x$host_cpu" in
-    xaarch64)
-      # Currently only berlin.guixsd.org provides aarch64 binaries.
-      guix_substitute_urls="https://berlin.guixsd.org"
-      ;;
-    *)
-      guix_substitute_urls="https://mirror.hydra.gnu.org"
-      ;;
-  esac
+  guix_substitute_urls="https://ci.guix.info"
 
   AC_MSG_CHECKING([for default substitute URLs])
   AC_MSG_RESULT([$guix_substitute_urls])
diff --git a/doc/guix.texi b/doc/guix.texi
index d96c35eace..a5ae1c65e6 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -14,7 +14,7 @@ 
 @set KEY-SERVER pool.sks-keyservers.net
 
 @c The official substitute server used by default.
-@set SUBSTITUTE-SERVER ci.guix.info
+@set SUBSTITUTE-SERVER mirror.hydra.gnu.org
 
 @copying
 Copyright @copyright{} 2012, 2013, 2014, 2015, 2016, 2017, 2018 Ludovic Courtès@*
@@ -2374,14 +2374,9 @@  Then, you can run something like this:
 @end example
 
 @quotation Note
-Similarly, the @file{berlin.guixsd.org.pub} file contains the public key
-for the project's new build farm, reachable at
-@indicateurl{https://berlin.guixsd.org}.
-
-As of this writing @code{berlin.guixsd.org} is being upgraded so it can
-better scale up, but you might want to give it a try.  It is backed by
-20 x86_64/i686 build nodes and may be able to provide substitutes more
-quickly than @code{mirror.hydra.gnu.org}.
+Similarly, the @file{hydra.gnu.org.pub} file contains the public key
+of an independent build farm also run by the project, reachable at
+@indicateurl{https://mirror.hydra.gnu.org}.
 @end quotation
 
 Once this is in place, the output of a command like @code{guix build}
diff --git a/guix/scripts/build.scm b/guix/scripts/build.scm
index 5532c65eb6..0b7da3189e 100644
--- a/guix/scripts/build.scm
+++ b/guix/scripts/build.scm
@@ -65,7 +65,7 @@ 
 
 (define %default-log-urls
   ;; Default base URLs for build logs.
-  '("http://hydra.gnu.org/log"))
+  '("http://ci.guix.info/log"))
 
 ;; XXX: The following procedure cannot be in (guix store) because of the
 ;; dependency on (guix derivations).
diff --git a/guix/scripts/substitute.scm b/guix/scripts/substitute.scm
index eb82224016..d6dc9b6448 100755
--- a/guix/scripts/substitute.scm
+++ b/guix/scripts/substitute.scm
@@ -1052,7 +1052,7 @@  found."
     (#f
      ;; This can only happen when this script is not invoked by the
      ;; daemon.
-     '("http://hydra.gnu.org"))))
+     '("http://ci.guix.info"))))
 
 (define substitute-urls
   ;; List of substitute URLs.
diff --git a/guix/store.scm b/guix/store.scm
index 9dc651b26c..509fd4def6 100644
--- a/guix/store.scm
+++ b/guix/store.scm
@@ -693,7 +693,7 @@  encoding conversion errors."
   (map (if (false-if-exception (resolve-interface '(gnutls)))
            (cut string-append "https://" <>)
            (cut string-append "http://" <>))
-       '("mirror.hydra.gnu.org")))
+       '("ci.guix.info")))
 
 (define* (set-build-options server
                             #:key keep-failed? keep-going? fallback?