[bug#33578] gnu: enlightenment: Use absolute path to 'edje_cc'.

Message ID b9e499d7-3f76-eea1-65b4-9db903453419@fn.de
State Accepted
Commit 3a1835128db463f7daa190e72ed6e2d3e72675b2
Headers show
Series [bug#33578] gnu: enlightenment: Use absolute path to 'edje_cc'. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Timo Eisenmann Dec. 2, 2018, 11:24 a.m. UTC
Hello,
this patch should fix Enlightenment's background import dialog by replacing
'e_prefix_bin_get()' with the proper path to 'edje_cc'.
Regards,
Timo Eisenmann
From 0db44da76a1586a4d8d827f2640df95666448d4c Mon Sep 17 00:00:00 2001
From: Timo Eisenmann <eisenmann@fn.de>
Date: Sun, 2 Dec 2018 11:44:37 +0100
Subject: [PATCH] gnu: enlightenment: Use absolute path to 'edje_cc'.

* gnu/packages/enlightenment.scm (enlightenment)[arguments]: In
'set-system-actions', set absolute file name to 'edje_cc'.
---
 gnu/packages/enlightenment.scm | 6 +++++-
 1 file changed, 5 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès Dec. 4, 2018, 10:12 a.m. UTC | #1
Hello,

Timo Eisenmann <eisenmann@fn.de> skribis:

> this patch should fix Enlightenment's background import dialog by replacing
> 'e_prefix_bin_get()' with the proper path to 'edje_cc'.

Good catch.

> From 0db44da76a1586a4d8d827f2640df95666448d4c Mon Sep 17 00:00:00 2001
> From: Timo Eisenmann <eisenmann@fn.de>
> Date: Sun, 2 Dec 2018 11:44:37 +0100
> Subject: [PATCH] gnu: enlightenment: Use absolute path to 'edje_cc'.
>
> * gnu/packages/enlightenment.scm (enlightenment)[arguments]: In
> 'set-system-actions', set absolute file name to 'edje_cc'.

Applied, thanks!

Ludo’.

Patch

diff --git a/gnu/packages/enlightenment.scm b/gnu/packages/enlightenment.scm
index 43ac388b2..9989e2f5a 100644
--- a/gnu/packages/enlightenment.scm
+++ b/gnu/packages/enlightenment.scm
@@ -275,7 +275,8 @@  Libraries with some extra bells and whistles.")
              (let ((xkeyboard (assoc-ref inputs "xkeyboard-config"))
                    (setxkbmap (assoc-ref inputs "setxkbmap"))
                    (utils     (assoc-ref inputs "util-linux"))
-                   (libc      (assoc-ref inputs "libc")))
+                   (libc      (assoc-ref inputs "libc"))
+                   (efl       (assoc-ref inputs "efl")))
                ;; We need to patch the path to 'base.lst' to be able
                ;; to switch the keyboard layout in E.
                (substitute* (list "src/modules/xkbswitch/e_mod_parse.c"
@@ -290,6 +291,9 @@  Libraries with some extra bells and whistles.")
                                   "src/modules/conf_intl/e_int_config_intl.c"
                                   "src/modules/wizard/page_010.c")
                  (("locale -a") (string-append libc "/bin/locale -a")))
+               (substitute* "src/bin/e_import_config_dialog.c"
+                 (("%s/edje_cc -v %s %s %s\", e_prefix_bin_get\\(\\)")
+                  (string-append efl "/bin/edje_cc -v %s %s %s\"")))
                (substitute* "src/modules/everything/evry_plug_apps.c"
                  (("/usr/bin/") ""))
                (substitute* "configure"