[bug#33565] gnu: Add python-xmltodict.

Message ID 20181201201832.6344-1-go.wigust@gmail.com
State Accepted
Headers show
Series [bug#33565] gnu: Add python-xmltodict. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Oleg Pykhalov Dec. 1, 2018, 8:18 p.m. UTC
* gnu/packages/xml.scm (python-xmltodict, python2-xmltodict): New variables.
---
 gnu/packages/xml.scm | 25 +++++++++++++++++++++++++
 1 file changed, 25 insertions(+)

Comments

Ludovic Courtès Dec. 3, 2018, 1:32 p.m. UTC | #1
Oleg Pykhalov <go.wigust@gmail.com> skribis:

> * gnu/packages/xml.scm (python-xmltodict, python2-xmltodict): New variables.

[...]

> +    (home-page "https://github.com/martinblech/xmltodict")
> +    (synopsis "Work with XML like you are working with JSON")
> +    (description "This package provides a Python library to work with XML like
> +you are working with JSON")

Could you expound a bit on what this means (I’m curious!) and add a
period?

> +(define-public python2-xmltodict
> +  (package-with-python2 python-xmltodict))

Unless you really need it, you should omit the Python 2.x variant.

Otherwise LGTM, thanks!

Ludo’.
Oleg Pykhalov Dec. 4, 2018, 5:13 a.m. UTC | #2
Hi Ludovic.

Thank you for review.

ludo@gnu.org (Ludovic Courtès) writes:

> Oleg Pykhalov <go.wigust@gmail.com> skribis:
>
>> * gnu/packages/xml.scm (python-xmltodict, python2-xmltodict): New variables.
>
> [...]
>
>> +    (home-page "https://github.com/martinblech/xmltodict")
>> +    (synopsis "Work with XML like you are working with JSON")
>> +    (description "This package provides a Python library to work with XML like
>> +you are working with JSON")
>
> Could you expound a bit on what this means (I’m curious!) and add a
> period?

It's a quote from the home page. :-) But in reality this Python library
converts input string which contains XML to an OrderedDict object which
looks like a JSON.  Queries for data inside OrderedDict feels (I guess)
like you're working with JSON.  Maybe we should change a description to
“This package provides a Python library to convert XML to OrderedDict.”,
WDYT?

>> +(define-public python2-xmltodict
>> +  (package-with-python2 python-xmltodict))
>
> Unless you really need it, you should omit the Python 2.x variant.

Sure, I'll omit.

Oleg.
Ludovic Courtès Dec. 4, 2018, 8:47 a.m. UTC | #3
Hi!

Oleg Pykhalov <go.wigust@gmail.com> skribis:

> ludo@gnu.org (Ludovic Courtès) writes:
>
>> Oleg Pykhalov <go.wigust@gmail.com> skribis:
>>
>>> * gnu/packages/xml.scm (python-xmltodict, python2-xmltodict): New variables.
>>
>> [...]
>>
>>> +    (home-page "https://github.com/martinblech/xmltodict")
>>> +    (synopsis "Work with XML like you are working with JSON")
>>> +    (description "This package provides a Python library to work with XML like
>>> +you are working with JSON")
>>
>> Could you expound a bit on what this means (I’m curious!) and add a
>> period?
>
> It's a quote from the home page. :-) But in reality this Python library
> converts input string which contains XML to an OrderedDict object which
> looks like a JSON.  Queries for data inside OrderedDict feels (I guess)
> like you're working with JSON.  Maybe we should change a description to
> “This package provides a Python library to convert XML to OrderedDict.”,

@code{OrderedDict} even.  :-)

LGTM with this change, thank you!

Ludo’.
Oleg Pykhalov Dec. 5, 2018, 12:45 a.m. UTC | #4
ludo@gnu.org (Ludovic Courtès) writes:

> Oleg Pykhalov <go.wigust@gmail.com> skribis:
>
>> ludo@gnu.org (Ludovic Courtès) writes:
>>
>>> Oleg Pykhalov <go.wigust@gmail.com> skribis:
>>>
>>>> * gnu/packages/xml.scm (python-xmltodict, python2-xmltodict): New variables.
>>>
>>> [...]
>>>
>>>> +    (home-page "https://github.com/martinblech/xmltodict")
>>>> +    (synopsis "Work with XML like you are working with JSON")
>>>> +    (description "This package provides a Python library to work with XML like
>>>> +you are working with JSON")
>>>
>>> Could you expound a bit on what this means (I’m curious!) and add a
>>> period?
>>
>> It's a quote from the home page. :-) But in reality this Python library
>> converts input string which contains XML to an OrderedDict object which
>> looks like a JSON.  Queries for data inside OrderedDict feels (I guess)
>> like you're working with JSON.  Maybe we should change a description to
>> “This package provides a Python library to convert XML to OrderedDict.”,
>
> @code{OrderedDict} even.  :-)
>
> LGTM with this change, thank you!

Pushed as 79a0eabd2a8765c294b3e2decf71a27cd1dd219d

Thanks,
Oleg.

Patch

diff --git a/gnu/packages/xml.scm b/gnu/packages/xml.scm
index 347ac878a3..1bb6ba48aa 100644
--- a/gnu/packages/xml.scm
+++ b/gnu/packages/xml.scm
@@ -39,6 +39,7 @@ 
 (define-module (gnu packages xml)
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
+  #:use-module (gnu packages check)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages curl)
   #:use-module (gnu packages gnupg)
@@ -2133,3 +2134,27 @@  It converts the procedure call into an XML document, sends it to a remote
 server using HTTP, and gets back the response as XML.  This library provides a
 modular implementation of XML-RPC for C and C++.")
     (license (list license:psfl license:expat))))
+
+(define-public python-xmltodict
+  (package
+    (name "python-xmltodict")
+    (version "0.11.0")
+    (source
+      (origin
+        (method url-fetch)
+        (uri (pypi-uri "xmltodict" version))
+        (sha256
+          (base32
+            "1pxh4yjhvmxi1h6f92skv41g4kbsws3ams57150kzn18m907v3cg"))))
+    (build-system python-build-system)
+    (native-inputs
+     `(("python-coverage" ,python-coverage)
+       ("python-nose" ,python-nose)))
+    (home-page "https://github.com/martinblech/xmltodict")
+    (synopsis "Work with XML like you are working with JSON")
+    (description "This package provides a Python library to work with XML like
+you are working with JSON")
+    (license license:expat)))
+
+(define-public python2-xmltodict
+  (package-with-python2 python-xmltodict))