[bug#33526] Utilities for emacs-irony-mode

Message ID b207d909-8ba0-1ffd-1696-bd161504bd45@yahoo.de
State Accepted
Headers show
Series [bug#33526] Utilities for emacs-irony-mode | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed

Commit Message

Tim Gesthuizen Nov. 30, 2018, 11:04 a.m. UTC
On 29.11.2018 09:48, Ludovic Courtès wrote:
> The tag should be “v1.0.0”, not “1.0.0”, but then the hash is different
> than the one here.
> 
> Also, ‘guix lint’ reports the same kind of issues as above.
> 
> Could you double-check and adjust the Git references and address the
> issues that ‘guix lint’ reports in the remaining patches?

Sorry for the bad patches.
I changed the following things:
- descriptions of the packages are now full sentences
- The source files now have proper names
- git references and hashs are updated so that the sources can be
  downloaded.

I hope that this resolves all issues.
The patches are attached.

Tim.

Comments

Ludovic Courtès Nov. 30, 2018, 4:01 p.m. UTC | #1
Hi Tim,

Tim Gesthuizen <tim.gesthuizen@yahoo.de> skribis:

> Sorry for the bad patches.
> I changed the following things:
> - descriptions of the packages are now full sentences
> - The source files now have proper names
> - git references and hashs are updated so that the sources can be
>   downloaded.
>
> I hope that this resolves all issues.

It does.  I applied both patches, thank you!

Ludo’.

Patch

From 210363912b79310eebaa621bf17438a1882565e3 Mon Sep 17 00:00:00 2001
From: Tim Gesthuizen <tim.gesthuizen@yahoo.de>
Date: Tue, 27 Nov 2018 17:57:28 +0100
Subject: [PATCH 2/2] gnu: Add emacs-irony-eldoc.

* gnu/packages/emacs.scm (emacs-irony-eldoc): New variable.
---
 gnu/packages/emacs.scm | 21 +++++++++++++++++++++
 1 file changed, 21 insertions(+)

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index 647625d0e..073f19b95 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -2891,6 +2891,27 @@  do the syntax checking.")
     (home-page "https://github.com/Sarcasm/flycheck-irony")
     (license license:gpl3+)))
 
+(define-public emacs-irony-eldoc
+  (package
+    (name "emacs-irony-eldoc")
+    (version (package-version emacs-irony-mode))
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/ikirill/irony-eldoc.git")
+             (commit "0df5831eaae264a25422b061eb2792aadde8b3f2")))
+       (sha256 (base32 "1l5qpr66v1l12fb50yh73grb2rr85xxmbj19mm33b5rdrq2bqmmd"))
+       (file-name (string-append name "-" version))))
+    (build-system emacs-build-system)
+    (inputs
+     `(("irony-mode" ,emacs-irony-mode)))
+    (synopsis "Eldoc integration for irony-mode")
+    (description "Irony-eldoc is an eldoc extension that shows documentation
+for the current function or variable in the minibuffer.")
+    (home-page "https://github.com/ikirill/irony-eldoc")
+    (license license:gpl3+)))
+
 (define-public emacs-company-quickhelp
   (package
     (name "emacs-company-quickhelp")
-- 
2.19.2