@@ -14,6 +14,7 @@
;;; Copyright © 2018 Pierre Neidhardt <mail@ambrevar.xyz>
;;; Copyright @ 2018, 2019 Katherine Cox-Buday <cox.katherine.e@gmail.com>
;;; Copyright @ 2019 Giovanni Biscuolo <g@xelera.eu>
+;;; Copyright @ 2019 Pkill -9 <pkill9@runbox.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -3274,3 +3275,25 @@ test.
All locks are implemented with read-write mutexes. To use them like a regular
mutex, simply ignore the RLock/RUnlock functions.")
(license license:unlicense))))
+
+(define-public go-github-com-gokyle-twofactor
+ (package
+ (name "go-github-com-gokyle-twofactor")
+ (version "1.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gokyle/twofactor.git")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0fhbw6cyq054w4frfvbgmffijg0bd1shvawm3ddl4cf1l12x1qxh"))))
+ (build-system go-build-system)
+ (arguments
+ `(#:import-path "github.com/gokyle/twofactor"))
+ (home-page "https://github.com/gokyle/twofactor")
+ (synopsis "Two-factor authentication")
+ (description "Golang package for providing two-factor authentication.")
+ (license license:expat)))