Message ID | 20190301080758.5548-5-anothersms@gmail.com |
---|---|
State | Accepted |
Headers | show |
Series | [bug#34695] gnu: add r-rex. | expand |
Context | Check | Description |
---|---|---|
cbaines/comparison | success | View comparison |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
cbaines/applying patch | success | Successfully applied |
Hi Nicolò, > --- > gnu/packages/cran.scm | 21 +++++++++++++++++++++ > 1 file changed, 21 insertions(+) > > diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm > index 111152d2d0..f3bd3ded8d 100644 > --- a/gnu/packages/cran.scm > +++ b/gnu/packages/cran.scm > @@ -10705,3 +10705,24 @@ functions are provided.") > help you to better understand object oriented programming in R, particularly > using @code{S3}.") > (license license:gpl3))) > + > +(define-public r-rex […] Sorry for the delay. I updated the commit message and the description and pushed this to the master branch with commit 296ea15cf3. Thanks!
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm index 111152d2d0..f3bd3ded8d 100644 --- a/gnu/packages/cran.scm +++ b/gnu/packages/cran.scm @@ -10705,3 +10705,24 @@ functions are provided.") help you to better understand object oriented programming in R, particularly using @code{S3}.") (license license:gpl3))) + +(define-public r-rex + (package + (name "r-rex") + (version "1.1.2") + (source + (origin + (method url-fetch) + (uri (cran-uri "rex" version)) + (sha256 + (base32 + "0alsadgjgass3wr8y5d247j12qqzg454sc84vpskclrkmz778g5x")))) + (build-system r-build-system) + (propagated-inputs + `(("r-lazyeval" ,r-lazyeval) + ("r-magrittr" ,r-magrittr))) + (home-page "https://github.com/kevinushey/rex") + (synopsis "Friendly Regular Expressions") + (description + "This package provides a friendly interface for the construction of regular expressions.") + (license license:expat)))