[bug#56717,1/2] gnu: Add python-i3ipc
Commit Message
* gnu/packages/python-xyz.scm (python-i3ipc): New variable.
Signed-off-by: Hilton Chain <hako@ultrarare.space>
---
gnu/packages/python-xyz.scm | 23 +++++++++++++++++++++++
1 file changed, 23 insertions(+)
Comments
Hello!
On Sat Jul 23, 2022 at 7:31 AM BST, Hilton Chain via Guix-patches via wrote:
> + (arguments
> + '(#:tests? #f))
Could you add an explanation of why the test fails in a comment, if
possible? Also, (arguments (list ...)) is now generally preferred to
(arguments '(...)) :)
-- (
On Sat Jul 23, 2022 at 7:31 AM BST, Hilton Chain via Guix-patches via wrote:
> + (inputs (list python-xlib))
You'll want to propagate this input, as is usually done for Python
libraries.
-- (
@@ -124,6 +124,7 @@
;;; Copyright © 2022 Artyom V. Poptsov <poptsov.artyom@gmail.com>
;;; Copyright © 2022 Paul A. Patience <paul@apatience.com>
;;; Copyright © 2022 Jean-Pierre De Jesus DIAZ <me@jeandudey.tech>
+;;; Copyright © 2022 Hilton Chain <hako@ultrarare.space>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -30203,3 +30204,25 @@ (define-public python-bsdiff4
binary diff utility. It also provides two command-line tools, @code{bsdiff4}
and @code{bspatch4}.")
(license license:bsd-2)))
+
+(define-public python-i3ipc
+ (package
+ (name "python-i3ipc")
+ (version "2.2.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/altdesktop/i3ipc-python")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "13bzs9dcv27czpnnbgz7a037lm8h991c8gk0qzzk5mq5yak24715"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:tests? #f))
+ (inputs (list python-xlib))
+ (home-page "https://github.com/altdesktop/i3ipc-python")
+ (synopsis "Python library for controlling i3wm and sway")
+ (description "An improved Python library to control i3wm and sway.")
+ (license license:bsd-3)))