diff mbox series

[bug#56717,2/2] gnu: Add python-autotiling.

Message ID d98d8429224b48f25db0ca9ba4419f30fd226dc4.1658559627.git.hako@ultrarare.space
State Accepted
Headers show
Series gnu: Add python-i3ipc and python-autotiling. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git-branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Hilton Chain July 23, 2022, 6:33 a.m. UTC
* gnu/packages/python-xyz.scm (python-autotiling): New variable.

Signed-off-by: Hilton Chain <hako@ultrarare.space>
---
 gnu/packages/python-xyz.scm | 27 +++++++++++++++++++++++++++
 1 file changed, 27 insertions(+)

Comments

\( July 23, 2022, 8:54 a.m. UTC | #1
On Sat Jul 23, 2022 at 7:33 AM BST, Hilton Chain via Guix-patches via wrote:
> +(define-public python-autotiling
I think this should be changed to `i3-autotiling`, since it's a Python
program, not a library.

> +  (package
> +    (name "autotiling")
Same here.

> +    (arguments
> +     '(#:tests? #f))
Can you add an explanation and change to (list ...) style here too,
please?

> +    (inputs (list python-wheel python-xlib))
I think python-wheel only needs to be a native-input, and python-xlib
can be removed if you propagate it in python-i3ipc.

    -- (
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4bf6b3d965..8fd413a683 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -30226,3 +30226,30 @@  (define-public python-i3ipc
     (synopsis "Python library for controlling i3wm and sway")
     (description "An improved Python library to control i3wm and sway.")
     (license license:bsd-3)))
+
+(define-public python-autotiling
+  (package
+    (name "autotiling")
+    (version "1.6")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/nwg-piotr/autotiling")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "1hjlvg7095s322gb43r9g7mqlsy3pj13l827jpnbn5x0918rq9rr"))))
+    (build-system python-build-system)
+    (arguments
+     '(#:tests? #f))
+    (inputs (list python-wheel python-xlib))
+    (propagated-inputs (list python-i3ipc))
+    (home-page "https://github.com/nwg-piotr/autotiling")
+    (synopsis
+     "Automatically switch the horizontal/vertical window split orientation in
+ i3 and sway")
+    (description "This script uses the i3ipc-python library to switch the layout
+splith/splitv depending on the currently focused window dimensions. It works on
+both sway and i3 window managers.")
+    (license license:gpl3)))