[bug#33338] gnu: Add emacs-webpaste

Message ID 20181110210451.16202-1-brettg@posteo.net
State Accepted
Headers show
Series [bug#33338] gnu: Add emacs-webpaste | expand

Checks

Context Check Description
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Brett Gilio Nov. 10, 2018, 9:04 p.m. UTC
---
 gnu/packages/emacs.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Brett Gilio Nov. 10, 2018, 9:08 p.m. UTC | #1
Small error in the patch. Please revise the email line to "brettg@posteo.net"
Ludovic Courtès Nov. 19, 2018, 9:36 p.m. UTC | #2
Hi Brett, and sorry for the delay!

Brett Gilio <brettg@posteo.net> skribis:

> ---
>  gnu/packages/emacs.scm | 26 ++++++++++++++++++++++++++
>  1 file changed, 26 insertions(+)

Could you add a commit log along the lines of what we usually do?  (See
‘git log’ to get an idea.)

> +  (package
> +    (name "emacs-webpaste")
> +    (version "20180815.1855")
> +    (source
> +     (origin
> +       (method url-fetch)
> +       (uri (string-append
> +             "https://melpa.org/packages/webpaste-"
> +             version
> +             ".el"))

Since files on MELPA disappear or are modified in place, it’s safer to
take them from upstream repositories.  Could you send an updated patch
that fetches code from the github.com repo?

Thank you!

Ludo’.
Brett Gilio Nov. 24, 2018, 9:02 p.m. UTC | #3
Ludovic Courtès writes:

> Hi Brett, and sorry for the delay!
>
> Brett Gilio <brettg@posteo.net> skribis:
>
>> ---
>>  gnu/packages/emacs.scm | 26 ++++++++++++++++++++++++++
>>  1 file changed, 26 insertions(+)
>
> Could you add a commit log along the lines of what we usually do?  (See
> ‘git log’ to get an idea.)
>
>> +  (package
>> +    (name "emacs-webpaste")
>> +    (version "20180815.1855")
>> +    (source
>> +     (origin
>> +       (method url-fetch)
>> +       (uri (string-append
>> +             "https://melpa.org/packages/webpaste-"
>> +             version
>> +             ".el"))
>
> Since files on MELPA disappear or are modified in place, it’s safer to
> take them from upstream repositories.  Could you send an updated patch
> that fetches code from the github.com repo?
>
> Thank you!
>
> Ludo’.

Hi Ludo,

When I run git format-patch -1 I suppose it isn't adding the commit log
to the patch file? I think that is what you are trying to say. How then
should I add it, because I am making commits before I generate the
patch?

Brett Gilio
Tobias Geerinckx-Rice Nov. 25, 2018, 10:07 a.m. UTC | #4
Brett,

Brett Gilio wrote:
> When I run git format-patch -1 I suppose it isn't adding the 
> commit log
> to the patch file? I think that is what you are trying to 
> say. How then
> should I add it, because I am making commits before I generate 
> the
> patch?

That's the normal (only?) way. ‘git format-patch’es will include 
whatever commit messages you wrote during ’git commit’, and which 
are displayed by ’git log’, ‘git show’, et al.

What do the latter commands show?

Kind regards,

T G-R
Brett Gilio Nov. 25, 2018, 3:52 p.m. UTC | #5
Tobias Geerinckx-Rice writes:

> Brett,
>
> Brett Gilio wrote:
>> When I run git format-patch -1 I suppose it isn't adding the commit
>> log
>> to the patch file? I think that is what you are trying to say. How
>> then
>> should I add it, because I am making commits before I generate the
>> patch?
>
> That's the normal (only?) way. ‘git format-patch’es will include
> whatever commit messages you wrote during ’git commit’, and which are
> displayed by ’git log’, ‘git show’, et al.
>
> What do the latter commands show?
>
> Kind regards,
>
> T G-R

The patches are including the commit in the name of the format itself,
but it seems like ludo is wanting something contained within the patch
itself which it is not doing.

Git log is showing my commit history with the messages, git show is
also. So, I am confused as to what exactly I am not doing correctly.

Brett
Ludovic Courtès Nov. 27, 2018, 10:58 a.m. UTC | #6
Hello Brett,

Just a friendly reminder.  :-)

Ludo’.

ludo@gnu.org (Ludovic Courtès) skribis:

> Hi Brett, and sorry for the delay!
>
> Brett Gilio <brettg@posteo.net> skribis:
>
>> ---
>>  gnu/packages/emacs.scm | 26 ++++++++++++++++++++++++++
>>  1 file changed, 26 insertions(+)
>
> Could you add a commit log along the lines of what we usually do?  (See
> ‘git log’ to get an idea.)
>
>> +  (package
>> +    (name "emacs-webpaste")
>> +    (version "20180815.1855")
>> +    (source
>> +     (origin
>> +       (method url-fetch)
>> +       (uri (string-append
>> +             "https://melpa.org/packages/webpaste-"
>> +             version
>> +             ".el"))
>
> Since files on MELPA disappear or are modified in place, it’s safer to
> take them from upstream repositories.  Could you send an updated patch
> that fetches code from the github.com repo?
>
> Thank you!
>
> Ludo’.
Arun Isaac Dec. 11, 2020, 7:34 a.m. UTC | #7
Hi,

I fixed this patch, packaged the tests, and pushed to master.

Cheers! :-)

Patch

diff --git a/gnu/packages/emacs.scm b/gnu/packages/emacs.scm
index c6008e6a9..72112cfc0 100644
--- a/gnu/packages/emacs.scm
+++ b/gnu/packages/emacs.scm
@@ -40,6 +40,7 @@ 
 ;;; Copyright © 2018 Pierre-Antoine Rouby <pierre-antoine.rouby@inria.fr>
 ;;; Copyright © 2018 Alex Branham <alex.branham@gmail.com>
 ;;; Copyright © 2018 Thorsten Wilms <t_w_@freenet.de>
+;;; Copyright © 2018 Brett Gilio <bgilio@posteo.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -9837,6 +9838,31 @@  CSS, JavaScript, JSON.")
 throw a shell history.")
       (license license:gpl3+))))
 
+(define-public emacs-webpaste
+  (package
+    (name "emacs-webpaste")
+    (version "20180815.1855")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append
+             "https://melpa.org/packages/webpaste-"
+             version
+             ".el"))
+       (sha256
+        (base32
+         "0afbyrqs0hk9b5a7g75lar31v8bmmbgvcl64z0i52bi78vz7fdv8"))))
+    (build-system emacs-build-system)
+    (propagated-inputs
+     `(("emacs-request" ,emacs-request)))
+    (home-page "https://github.com/etu/webpaste.el")
+    (synopsis "Paste to pastebin-like services")
+    (description "This mode allows to paste whole buffers or parts of buffers to
+pastebin-like services.  It supports more than one service and will
+failover if one service fails.  More services can easily be added
+over time and prefered services can easily be configured.")
+    (license license:gpl3+)))
+
 (define-public emacs-discover-my-major
   (package
     (name "emacs-discover-my-major")