[bug#33478] gnu: agda: Upgrade to 2.5.4.2

Message ID 20181124042450.8500-1-brettg@posteo.net
State Accepted
Headers show
Series [bug#33478] gnu: agda: Upgrade to 2.5.4.2 | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied

Commit Message

Brett Gilio Nov. 24, 2018, 4:24 a.m. UTC
---
 gnu/packages/agda.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

Comments

Ludovic Courtès Nov. 24, 2018, 9:30 p.m. UTC | #1
Hello Brett,

Brett Gilio <brettg@posteo.net> skribis:

> ---
>  gnu/packages/agda.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
> index 6bb38aac4..be82ff9ec 100644
> --- a/gnu/packages/agda.scm
> +++ b/gnu/packages/agda.scm
> @@ -31,7 +31,7 @@
>  (define-public agda
>    (package
>      (name "agda")
> -    (version "2.5.4.1")
> +    (version "2.5.4.2")

It fails to build here:

--8<---------------cut here---------------start------------->8---
[ 37 of 339] Compiling Agda.Utils.Memo  ( src/full/Agda/Utils/Memo.hs, dist/build/Agda/Utils/Memo.o )

src/full/Agda/Utils/Memo.hs:10:1: error:
    Bad interface file: /gnu/store/fmq6ybv1m3yr9x2y16gv85nv30df9xw8-ghc-hashable-1.2.7.0/lib/ghc-8.4.3/hashable-1.2.7.0/Data/Hashable.hi
        Something is amiss; requested module  hashable-1.2.7.0:Data.Hashable differs from name found in the interface file hashable-1.2.7.0:Data.Hashable (if these names look the same, try again with -dppr-debug)
   |
10 | import Data.Hashable
   | ^^^^^^^^^^^^^^^^^^^^
--8<---------------cut here---------------end--------------->8---

Could you take a look?

Thanks,
Ludo’.
Brett Gilio Nov. 24, 2018, 9:44 p.m. UTC | #2
Ludovic Courtès writes:

> Hello Brett,
>
> Brett Gilio <brettg@posteo.net> skribis:
>
>> ---
>>  gnu/packages/agda.scm | 4 ++--
>>  1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
>> index 6bb38aac4..be82ff9ec 100644
>> --- a/gnu/packages/agda.scm
>> +++ b/gnu/packages/agda.scm
>> @@ -31,7 +31,7 @@
>>  (define-public agda
>>    (package
>>      (name "agda")
>> -    (version "2.5.4.1")
>> +    (version "2.5.4.2")
>
> It fails to build here:
>
> --8<---------------cut here---------------start------------->8---
> [ 37 of 339] Compiling Agda.Utils.Memo  ( src/full/Agda/Utils/Memo.hs, dist/build/Agda/Utils/Memo.o )
>
> src/full/Agda/Utils/Memo.hs:10:1: error:
>     Bad interface file: /gnu/store/fmq6ybv1m3yr9x2y16gv85nv30df9xw8-ghc-hashable-1.2.7.0/lib/ghc-8.4.3/hashable-1.2.7.0/Data/Hashable.hi
>         Something is amiss; requested module  hashable-1.2.7.0:Data.Hashable differs from name found in the interface file hashable-1.2.7.0:Data.Hashable (if these names look the same, try again with -dppr-debug)
>    |
> 10 | import Data.Hashable
>    | ^^^^^^^^^^^^^^^^^^^^
> --8<---------------cut here---------------end--------------->8---
>
> Could you take a look?
>
> Thanks,
> Ludo’.

Sure, I am running it through 20 rounds right now. I will also check for
the Data.Hashable dependencies and see what is going on. Will report
back soon.

Brett Gilio
Brett Gilio Nov. 25, 2018, 2:04 a.m. UTC | #3
Ludovic Courtès writes:

> Hello Brett,
>
> Brett Gilio <brettg@posteo.net> skribis:
>
>> ---
>>  gnu/packages/agda.scm | 4 ++--
>>  1 file changed, 2 insertions(+), 2 deletions(-)
>>
>> diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
>> index 6bb38aac4..be82ff9ec 100644
>> --- a/gnu/packages/agda.scm
>> +++ b/gnu/packages/agda.scm
>> @@ -31,7 +31,7 @@
>>  (define-public agda
>>    (package
>>      (name "agda")
>> -    (version "2.5.4.1")
>> +    (version "2.5.4.2")
>
> It fails to build here:
>
> --8<---------------cut here---------------start------------->8---
> [ 37 of 339] Compiling Agda.Utils.Memo  ( src/full/Agda/Utils/Memo.hs, dist/build/Agda/Utils/Memo.o )
>
> src/full/Agda/Utils/Memo.hs:10:1: error:
>     Bad interface file: /gnu/store/fmq6ybv1m3yr9x2y16gv85nv30df9xw8-ghc-hashable-1.2.7.0/lib/ghc-8.4.3/hashable-1.2.7.0/Data/Hashable.hi
>         Something is amiss; requested module  hashable-1.2.7.0:Data.Hashable differs from name found in the interface file hashable-1.2.7.0:Data.Hashable (if these names look the same, try again with -dppr-debug)
>    |
> 10 | import Data.Hashable
>    | ^^^^^^^^^^^^^^^^^^^^
> --8<---------------cut here---------------end--------------->8---
>
> Could you take a look?
>
> Thanks,
> Ludo’.

Hi Ludo,

I put it through 20 rounds of building, and dumped the gc and
everything. I can not replicate it on my end, can we get a third person
to try it?

Best,
Brett Gilio
Ludovic Courtès Nov. 25, 2018, 2:22 p.m. UTC | #4
Hello Brett,

Brett Gilio <brettg@posteo.net> skribis:

> Ludovic Courtès writes:

[...]

>> --8<---------------cut here---------------start------------->8---
>> [ 37 of 339] Compiling Agda.Utils.Memo  ( src/full/Agda/Utils/Memo.hs, dist/build/Agda/Utils/Memo.o )
>>
>> src/full/Agda/Utils/Memo.hs:10:1: error:
>>     Bad interface file: /gnu/store/fmq6ybv1m3yr9x2y16gv85nv30df9xw8-ghc-hashable-1.2.7.0/lib/ghc-8.4.3/hashable-1.2.7.0/Data/Hashable.hi
>>         Something is amiss; requested module  hashable-1.2.7.0:Data.Hashable differs from name found in the interface file hashable-1.2.7.0:Data.Hashable (if these names look the same, try again with -dppr-debug)
>>    |
>> 10 | import Data.Hashable
>>    | ^^^^^^^^^^^^^^^^^^^^
>> --8<---------------cut here---------------end--------------->8---
>>
>> Could you take a look?
>>
>> Thanks,
>> Ludo’.
>
> Hi Ludo,
>
> I put it through 20 rounds of building, and dumped the gc and
> everything. I can not replicate it on my end, can we get a third person
> to try it?

I’m not sure what you mean by “20 rounds” and “dumped the gc”.  I would
expect such a failure to be deterministic.

Are you testing this on ‘master’?  Which commit?  I tested it on top of
63fd9f084a5e345d2edaeaf5e8f435a3130f9edc.

Thanks,
Ludo’.
Brett Gilio Nov. 25, 2018, 3:47 p.m. UTC | #5
Ludovic Courtès writes:

> Hello Brett,
>
> Brett Gilio <brettg@posteo.net> skribis:
>
>> Ludovic Courtès writes:
>
> [...]
>
>>> --8<---------------cut here---------------start------------->8---
>>> [ 37 of 339] Compiling Agda.Utils.Memo  ( src/full/Agda/Utils/Memo.hs, dist/build/Agda/Utils/Memo.o )
>>>
>>> src/full/Agda/Utils/Memo.hs:10:1: error:
>>>     Bad interface file: /gnu/store/fmq6ybv1m3yr9x2y16gv85nv30df9xw8-ghc-hashable-1.2.7.0/lib/ghc-8.4.3/hashable-1.2.7.0/Data/Hashable.hi
>>>         Something is amiss; requested module  hashable-1.2.7.0:Data.Hashable differs from name found in the interface file hashable-1.2.7.0:Data.Hashable (if these names look the same, try again with -dppr-debug)
>>>    |
>>> 10 | import Data.Hashable
>>>    | ^^^^^^^^^^^^^^^^^^^^
>>> --8<---------------cut here---------------end--------------->8---
>>>
>>> Could you take a look?
>>>
>>> Thanks,
>>> Ludo’.
>>
>> Hi Ludo,
>>
>> I put it through 20 rounds of building, and dumped the gc and
>> everything. I can not replicate it on my end, can we get a third person
>> to try it?
>
> I’m not sure what you mean by “20 rounds” and “dumped the gc”.  I would
> expect such a failure to be deterministic.
>
> Are you testing this on ‘master’?  Which commit?  I tested it on top of
> 63fd9f084a5e345d2edaeaf5e8f435a3130f9edc.
>
> Thanks,
> Ludo’.

--rounds=20 to see if it is deterministic. But as I said, I am not
  replicating the error. Yes, I tested it on master, commit and on the
  same commit number as you.

Brett
Ludovic Courtès Nov. 26, 2018, 10:27 a.m. UTC | #6
Hi Brett,

Brett Gilio <brettg@posteo.net> skribis:

> Ludovic Courtès writes:
>
>> Hello Brett,
>>
>> Brett Gilio <brettg@posteo.net> skribis:
>>
>>> Ludovic Courtès writes:
>>
>> [...]
>>
>>>> --8<---------------cut here---------------start------------->8---
>>>> [ 37 of 339] Compiling Agda.Utils.Memo  ( src/full/Agda/Utils/Memo.hs, dist/build/Agda/Utils/Memo.o )
>>>>
>>>> src/full/Agda/Utils/Memo.hs:10:1: error:
>>>>     Bad interface file: /gnu/store/fmq6ybv1m3yr9x2y16gv85nv30df9xw8-ghc-hashable-1.2.7.0/lib/ghc-8.4.3/hashable-1.2.7.0/Data/Hashable.hi
>>>>         Something is amiss; requested module  hashable-1.2.7.0:Data.Hashable differs from name found in the interface file hashable-1.2.7.0:Data.Hashable (if these names look the same, try again with -dppr-debug)
>>>>    |
>>>> 10 | import Data.Hashable
>>>>    | ^^^^^^^^^^^^^^^^^^^^
>>>> --8<---------------cut here---------------end--------------->8---
>>>>
>>>> Could you take a look?
>>>>
>>>> Thanks,
>>>> Ludo’.
>>>
>>> Hi Ludo,
>>>
>>> I put it through 20 rounds of building, and dumped the gc and
>>> everything. I can not replicate it on my end, can we get a third person
>>> to try it?
>>
>> I’m not sure what you mean by “20 rounds” and “dumped the gc”.  I would
>> expect such a failure to be deterministic.
>>
>> Are you testing this on ‘master’?  Which commit?  I tested it on top of
>> 63fd9f084a5e345d2edaeaf5e8f435a3130f9edc.
>>
>> Thanks,
>> Ludo’.
>
> --rounds=20 to see if it is deterministic. But as I said, I am not
>   replicating the error. Yes, I tested it on master, commit and on the
>   same commit number as you.

I’ve retried just now: applying the Agda patch alone on top of commit
0c17f72070cbfb04f311b776a080849b369aac25.  It’s the same derivation as
the one I tested above.

Are we in the exact same conditions?  I’m on x86_64.

Ludo’.
Brett Gilio Dec. 5, 2019, 12:39 a.m. UTC | #7
Brett Gilio <brettg@posteo.net> writes:

> ---
>  gnu/packages/agda.scm | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
> index 6bb38aac4..be82ff9ec 100644
> --- a/gnu/packages/agda.scm
> +++ b/gnu/packages/agda.scm
> @@ -31,7 +31,7 @@
>  (define-public agda
>    (package
>      (name "agda")
> -    (version "2.5.4.1")
> +    (version "2.5.4.2")
>      (source
>       (origin
>         (method url-fetch)
> @@ -40,7 +40,7 @@
>               version ".tar.gz"))
>         (sha256
>          (base32
> -         "0bxpibsk98n9xp42d92ma5vj2fam8rsnl61fbhr3askfjdvalnbp"))))
> +         "07wvawpfjhx3gw2w53v27ncv1bl0kkx08wkm6wzxldbslkcasign"))))
>      (build-system haskell-build-system)
>      (inputs
>       `(("cpphs" ,cpphs)

This is a historical bug report and is no longer relevant. It can be
closed.
Efraim Flashner Dec. 5, 2019, 8:34 a.m. UTC | #8
On Wed, Dec 04, 2019 at 06:39:32PM -0600, Brett Gilio wrote:
> 
> This is a historical bug report and is no longer relevant. It can be
> closed.
> 

The easiest way to do this is to send an email to
XXXXX-done@debbugs.gnu.org and that will close the bug.

Patch

diff --git a/gnu/packages/agda.scm b/gnu/packages/agda.scm
index 6bb38aac4..be82ff9ec 100644
--- a/gnu/packages/agda.scm
+++ b/gnu/packages/agda.scm
@@ -31,7 +31,7 @@ 
 (define-public agda
   (package
     (name "agda")
-    (version "2.5.4.1")
+    (version "2.5.4.2")
     (source
      (origin
        (method url-fetch)
@@ -40,7 +40,7 @@ 
              version ".tar.gz"))
        (sha256
         (base32
-         "0bxpibsk98n9xp42d92ma5vj2fam8rsnl61fbhr3askfjdvalnbp"))))
+         "07wvawpfjhx3gw2w53v27ncv1bl0kkx08wkm6wzxldbslkcasign"))))
     (build-system haskell-build-system)
     (inputs
      `(("cpphs" ,cpphs)