diff mbox series

[bug#74039,5/5] gnu: Add ledger hardware wallet support to electrum

Message ID 19e0e5b28f2a18f838d7cb6819385812facc9501.1729985174.git.jesse@eisses.email
State New
Headers show
Series Add ledger hardware wallet support | expand

Commit Message

ashish.is--- via Guix-patches" via Oct. 26, 2024, 11:58 p.m. UTC
From: Jesse Eisses <jesse@eisses.email>

Change-Id: I348533df6611a47dca5fd933eed19cebdfca025d
---
 gnu/packages/finance.scm | 4 ++++
 1 file changed, 4 insertions(+)

Comments

Jesse Eisses Oct. 27, 2024, 8:06 a.m. UTC | #1
Hi there,

I just realize that I forgot to add my name to the list of contributors,
and also to prefix the email subject with PATCH. Apologies, still
getting the hang of this 😅

Not sure how to fix this. Should I submit a whole new patch series to this
thread, or even start a new issue with the PATCH prefix?

Thanks,

Jesse

jesse@eisses.email writes:

> From: Jesse Eisses <jesse@eisses.email>
>
> Change-Id: I348533df6611a47dca5fd933eed19cebdfca025d
> ---
>  gnu/packages/finance.scm | 4 ++++
>  1 file changed, 4 insertions(+)
>
> diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
> index 317d4592f3..84373452c4 100644
> --- a/gnu/packages/finance.scm
> +++ b/gnu/packages/finance.scm
> @@ -132,6 +132,7 @@ (define-module (gnu packages finance)
>    #:use-module (gnu packages qt)
>    #:use-module (gnu packages readline)
>    #:use-module (gnu packages security-token)
> +  #:use-module (gnu packages serialization)
>    #:use-module (gnu packages sphinx)
>    #:use-module (gnu packages sqlite)
>    #:use-module (gnu packages tex)
> @@ -579,15 +580,18 @@ (define-public electrum
>             python-attrs
>             python-bitstring
>             python-btchip-python
> +           python-cbor
>             python-certifi
>             python-cryptography
>             python-dnspython
>             python-hidapi
>             python-ledgerblue
> +           python-ledger-bitcoin
>             python-protobuf
>             python-pyqt
>             python-qdarkstyle
>             python-qrcode
> +           libusb
>             zbar))
>      (arguments
>       `(#:tests? #f                      ; no tests
James Smith Oct. 27, 2024, 2:15 p.m. UTC | #2
Jesse Eisses via Guix-patches via <guix-patches@gnu.org> writes:

> Hi there,
>
> I just realize that I forgot to add my name to the list of contributors,
> and also to prefix the email subject with PATCH. Apologies, still
> getting the hang of this 😅
>
> Not sure how to fix this. Should I submit a whole new patch series to this
> thread, or even start a new issue with the PATCH prefix?
>
> Thanks,
>
> Jesse

Hi Jesse,

You can just add your name to the list, rebase the change to your first
commit, and resend this patch series to this issue with a v2. For
example, my workflow with Emacs and Magit is as follows:

1. Add copyright to gnu/packages/finance.scm after the last one.
2. Using Magit, stage your changes, press "c" for commit, followed by "F"
for instant fixup, the select the commit to apply the changes to (I.E.
for copyright, it'll typically be patch 1/5).
3. Once you're done making changes, use "git send-email" to send a new
set of patches. For example, you'll use "git send-email -5 -v2
--to=74039@debbugs.gnu.org".

For more details, you can check the relevant section of the manual at
https://guix.gnu.org/manual/devel/en/html_node/Sending-a-Patch-Series.html

Hope that helps,
James
Jesse Eisses Oct. 27, 2024, 9:08 p.m. UTC | #3
Hi James,

Thanks for that! New patch set is incoming

- Jesse

James Smith <jsubuntuxp@disroot.org> writes:

> Jesse Eisses via Guix-patches via <guix-patches@gnu.org> writes:
>
>> Hi there,
>>
>> I just realize that I forgot to add my name to the list of contributors,
>> and also to prefix the email subject with PATCH. Apologies, still
>> getting the hang of this 😅
>>
>> Not sure how to fix this. Should I submit a whole new patch series to this
>> thread, or even start a new issue with the PATCH prefix?
>>
>> Thanks,
>>
>> Jesse
>
> Hi Jesse,
>
> You can just add your name to the list, rebase the change to your first
> commit, and resend this patch series to this issue with a v2. For
> example, my workflow with Emacs and Magit is as follows:
>
> 1. Add copyright to gnu/packages/finance.scm after the last one.
> 2. Using Magit, stage your changes, press "c" for commit, followed by "F"
> for instant fixup, the select the commit to apply the changes to (I.E.
> for copyright, it'll typically be patch 1/5).
> 3. Once you're done making changes, use "git send-email" to send a new
> set of patches. For example, you'll use "git send-email -5 -v2
> --to=74039@debbugs.gnu.org".
>
> For more details, you can check the relevant section of the manual at
> https://guix.gnu.org/manual/devel/en/html_node/Sending-a-Patch-Series.html
>
> Hope that helps,
> James
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 317d4592f3..84373452c4 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -132,6 +132,7 @@  (define-module (gnu packages finance)
   #:use-module (gnu packages qt)
   #:use-module (gnu packages readline)
   #:use-module (gnu packages security-token)
+  #:use-module (gnu packages serialization)
   #:use-module (gnu packages sphinx)
   #:use-module (gnu packages sqlite)
   #:use-module (gnu packages tex)
@@ -579,15 +580,18 @@  (define-public electrum
            python-attrs
            python-bitstring
            python-btchip-python
+           python-cbor
            python-certifi
            python-cryptography
            python-dnspython
            python-hidapi
            python-ledgerblue
+           python-ledger-bitcoin
            python-protobuf
            python-pyqt
            python-qdarkstyle
            python-qrcode
+           libusb
            zbar))
     (arguments
      `(#:tests? #f                      ; no tests