[bug#74039,1/5] gnu: Add python-ledgercomm

Message ID 4daddcdedef78a17701759dd722dbea938e370cc.1729985174.git.jesse@eisses.email
State New
Headers
Series Add ledger hardware wallet support |

Commit Message

iyzsong--- via Guix-patches via Oct. 26, 2024, 11:58 p.m. UTC
  From: Jesse Eisses <jesse@eisses.email>

Change-Id: If62d5425c346063787da81a47907f5ee84a749ab
---
 gnu/packages/finance.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)
  

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index d4594a1083..59a11e6925 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -1100,6 +1100,24 @@  (define-public python-btchip-python
 Nano dongle.")
     (license license:asl2.0)))
 
+(define-public python-ledgercomm
+  (package
+    (name "python-ledgercomm")
+    (version "1.2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "ledgercomm" version))
+              (sha256
+               (base32
+                "019f13h59yxxhyhvi5xz8b20pfhazbvn9sgx5x98mp2shj6cks8y"))))
+    (arguments
+     (list #:tests? #f))
+    (build-system pyproject-build-system)
+    (home-page "https://github.com/LedgerHQ/ledgercomm")
+    (synopsis "Library to communicate with Ledger Nano S/X and Speculos")
+    (description "Library to communicate with Ledger Nano S/X and Speculos")
+    (license license:expat)))
+
 (define-public python-trezor
   (package
     (name "python-trezor")