diff mbox series

[bug#72396,v2,2/2] gnu: Add zydis.

Message ID 6c2035f759a89750900eafc23f7ab943649d8e28.1723947780.git.mcsinyx@disroot.org
State New
Headers show
Series [bug#72396,v2,1/2] gnu: Add zycore. | expand

Commit Message

ashish.is--- via Guix-patches" via Aug. 18, 2024, 2:23 a.m. UTC
* gnu/packages/engineering.scm (zydis): New variable.

Change-Id: I6e0b04e1d957f8c172e81177f6669415beeaf20a
---
This patch is identical to the one in v1.

 gnu/packages/engineering.scm | 31 +++++++++++++++++++++++++++++++
 1 file changed, 31 insertions(+)

Comments

Z572 Aug. 19, 2024, 6:19 a.m. UTC | #1
guix-patches--- via <guix-patches@gnu.org> writes:

> * gnu/packages/engineering.scm (zydis): New variable.
>
> Change-Id: I6e0b04e1d957f8c172e81177f6669415beeaf20a
> ---
> This patch is identical to the one in v1.
>
>  gnu/packages/engineering.scm | 31 +++++++++++++++++++++++++++++++
>  1 file changed, 31 insertions(+)
>
> diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
> index 24dc4f0197c7..fba30809e18b 100644
> --- a/gnu/packages/engineering.scm
> +++ b/gnu/packages/engineering.scm
> @@ -1951,6 +1951,37 @@ (define-public zycore
>  and a fallback for environments without libc for Zydis.")
>      (license license:expat)))
>  
> +(define-public zydis
> +  (package
> +    (name "zydis")
> +    (version "4.1.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/zyantific/zydis")
> +                    (commit (string-append "v" version))))
> +              (sha256
> +               (base32 "15iw6wcg2van8pw54xs15zk5cniqm8d8vbd1w1br9azv8jxsqjva"))
> +              (file-name (git-file-name name version))))

move file-name before sha256.

> +    (build-system cmake-build-system)
> +    (arguments `(#:configure-flags '("-DZYAN_SYSTEM_ZYCORE=ON"
> +                                     "-DZYDIS_BUILD_SHARED_LIB=ON"
> +                                     "-DZYDIS_BUILD_MAN=ON")))

use gexp.

> +    (native-inputs (list python ronn-ng))
> +    (inputs (list zycore))
> +    (home-page "https://zydis.re")
> +    (synopsis "Disassembler and code generation library for x86 and AMD64")
> +    (description
> +     "Zydis is a decoder and disassembler library with the following features:
> +@itemize
> +@item Support for all x86 and AMD64 instructions and extensions
> +@item Optimization for high performance
> +@item No dynamic memory allocation
> +@item Thread-safe by design
> +@item Smaller file-size overhead compared to other common disassembler libraries
> +@end itemize")
> +    (license license:expat)))
> +
>  (define-public asco
>    (package
>      (name "asco")
ashish.is--- via Guix-patches" via Aug. 19, 2024, 7:54 a.m. UTC | #2
On 2024-08-19 at 14:17+08:00, Zheng Junjie wrote:
> Nguyễn Gia Phong writes:
> > +    (source (origin
> > +              (method git-fetch)
> > +              (uri (git-reference
> > +                    (url "https://github.com/zyantific/zycore-c")
> > +                    (commit (string-append "v" version))))
> > +              (sha256
> > +               (base32 "0s962pkqybh1xbs75y4jb4bqc9qnq0sviqd570mirqdhhq87agib"))
> > +              (file-name (git-file-name name version))))
>
> i move file-name before sha256.
>
> Nguyễn Gia Phong writes:
> > +    (build-system cmake-build-system)
> > +    (native-inputs (list googletest))
> > +    (arguments `(#:configure-flags '("-DZYCORE_BUILD_SHARED_LIBS=ON"
>                                         is ZYCORE_BUILD_SHARED_LIB                    
> > +                                     "-DZYCORE_BUILD_TESTS=ON")))
>  
> i adjust to use gexp, and disable ZYCORE_BUILD_TESTS on cross-compilation.

On 2024-08-19 at 14:19+08:00, Zheng Junjie wrote:
> Nguyễn Gia Phong writes:
> > +    (source (origin
> > +              (method git-fetch)
> > +              (uri (git-reference
> > +                    (url "https://github.com/zyantific/zydis")
> > +                    (commit (string-append "v" version))))
> > +              (sha256
> > +               (base32 "15iw6wcg2van8pw54xs15zk5cniqm8d8vbd1w1br9azv8jxsqjva"))
> > +              (file-name (git-file-name name version))))
>
> move file-name before sha256.
>
> Nguyễn Gia Phong writes:
> > +    (build-system cmake-build-system)
> > +    (arguments `(#:configure-flags '("-DZYAN_SYSTEM_ZYCORE=ON"
> > +                                     "-DZYDIS_BUILD_SHARED_LIB=ON"
> > +                                     "-DZYDIS_BUILD_MAN=ON")))
>
> use gexp.

Thanks for the nits and application to master!
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 24dc4f0197c7..fba30809e18b 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -1951,6 +1951,37 @@  (define-public zycore
 and a fallback for environments without libc for Zydis.")
     (license license:expat)))
 
+(define-public zydis
+  (package
+    (name "zydis")
+    (version "4.1.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/zyantific/zydis")
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32 "15iw6wcg2van8pw54xs15zk5cniqm8d8vbd1w1br9azv8jxsqjva"))
+              (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (arguments `(#:configure-flags '("-DZYAN_SYSTEM_ZYCORE=ON"
+                                     "-DZYDIS_BUILD_SHARED_LIB=ON"
+                                     "-DZYDIS_BUILD_MAN=ON")))
+    (native-inputs (list python ronn-ng))
+    (inputs (list zycore))
+    (home-page "https://zydis.re")
+    (synopsis "Disassembler and code generation library for x86 and AMD64")
+    (description
+     "Zydis is a decoder and disassembler library with the following features:
+@itemize
+@item Support for all x86 and AMD64 instructions and extensions
+@item Optimization for high performance
+@item No dynamic memory allocation
+@item Thread-safe by design
+@item Smaller file-size overhead compared to other common disassembler libraries
+@end itemize")
+    (license license:expat)))
+
 (define-public asco
   (package
     (name "asco")