diff mbox series

[bug#72396,v2,1/2] gnu: Add zycore.

Message ID 64a3c8b8813df7ab161a485080cd04c75ce70022.1723947780.git.mcsinyx@disroot.org
State New
Headers show
Series [bug#72396,v2,1/2] gnu: Add zycore. | expand

Commit Message

guix-patches--- via Aug. 18, 2024, 2:22 a.m. UTC
* gnu/packages/engineering.scm (zycore): New variable.

Change-Id: Ia38413f43bc667a9a12916d3f0e786e06f6d358f
---
On 2024-08-15 at 16:19+02:00, Nicolas Graves wrote:
> On 2024-07-31 19:14, Nguyễn Gia Phong via wrote:
>
> > * gnu/packages/engineering.scm (zycore): New variable.
> >
> > +    (synopsis "Internal library for Zydis.")
> A minor nitpick:
> zycore@1.5.0: no period allowed at the end of the synopsis
>
> Checking `guix lint` would have told you ;)
>
> Otherwise LGTM, built and rebuilt deterministically.

Thanks, this revision fixes that.

I cannot get guix lint to tell that to me however
(I ran `./pre-inst-env guix lint zycore`).

 gnu/packages/engineering.scm | 24 ++++++++++++++++++++++++
 1 file changed, 24 insertions(+)


base-commit: 41c44ffd5659d13f5c1edb78d92ad27275ead78a

Comments

Zheng Junjie Aug. 19, 2024, 6:17 a.m. UTC | #1
guix-patches--- via <guix-patches@gnu.org> writes:

> * gnu/packages/engineering.scm (zycore): New variable.
>
> Change-Id: Ia38413f43bc667a9a12916d3f0e786e06f6d358f
> ---
> On 2024-08-15 at 16:19+02:00, Nicolas Graves wrote:
>> On 2024-07-31 19:14, Nguyễn Gia Phong via wrote:
>>
>> > * gnu/packages/engineering.scm (zycore): New variable.
>> >
>> > +    (synopsis "Internal library for Zydis.")
>> A minor nitpick:
>> zycore@1.5.0: no period allowed at the end of the synopsis
>>
>> Checking `guix lint` would have told you ;)
>>
>> Otherwise LGTM, built and rebuilt deterministically.
>
> Thanks, this revision fixes that.
>
> I cannot get guix lint to tell that to me however
> (I ran `./pre-inst-env guix lint zycore`).
>
>  gnu/packages/engineering.scm | 24 ++++++++++++++++++++++++
>  1 file changed, 24 insertions(+)
>
> diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
> index 7a9c0bc436f7..24dc4f0197c7 100644
> --- a/gnu/packages/engineering.scm
> +++ b/gnu/packages/engineering.scm
> @@ -40,6 +40,7 @@
>  ;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
>  ;;; Copyright © 2023 pinoaffe <pinoaffe@gmail.com>
>  ;;; Copyright © 2024 Juliana Sims <juli@incana.org>
> +;;; Copyright © 2024 Nguyễn Gia Phong <mcsinyx@disroot.org>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -1927,6 +1928,29 @@ (define-public radare2
>  it suitable for security research and analysis.")
>      (license license:lgpl3)))
>  
> +(define-public zycore
> +  (package
> +    (name "zycore")
> +    (version "1.5.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/zyantific/zycore-c")
> +                    (commit (string-append "v" version))))
> +              (sha256
> +               (base32 "0s962pkqybh1xbs75y4jb4bqc9qnq0sviqd570mirqdhhq87agib"))
> +              (file-name (git-file-name name version))))

i move file-name before sha256.

> +    (build-system cmake-build-system)
> +    (native-inputs (list googletest))
> +    (arguments `(#:configure-flags '("-DZYCORE_BUILD_SHARED_LIBS=ON"
                                        is ZYCORE_BUILD_SHARED_LIB                    
> +                                     "-DZYCORE_BUILD_TESTS=ON")))
 
i adjust to use gexp, and disable ZYCORE_BUILD_TESTS on cross-compilation.

> +    (home-page "https://github.com/zyantific/zycore-c")
> +    (synopsis "Internal library for Zydis")
> +    (description
> +     "This package provides platfrom-independent types, macros
> +and a fallback for environments without libc for Zydis.")
> +    (license license:expat)))
> +
>  (define-public asco
>    (package
>      (name "asco")
>
> base-commit: 41c44ffd5659d13f5c1edb78d92ad27275ead78a
diff mbox series

Patch

diff --git a/gnu/packages/engineering.scm b/gnu/packages/engineering.scm
index 7a9c0bc436f7..24dc4f0197c7 100644
--- a/gnu/packages/engineering.scm
+++ b/gnu/packages/engineering.scm
@@ -40,6 +40,7 @@ 
 ;;; Copyright © 2023 Sharlatan Hellseher <sharlatanus@gmail.com>
 ;;; Copyright © 2023 pinoaffe <pinoaffe@gmail.com>
 ;;; Copyright © 2024 Juliana Sims <juli@incana.org>
+;;; Copyright © 2024 Nguyễn Gia Phong <mcsinyx@disroot.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -1927,6 +1928,29 @@  (define-public radare2
 it suitable for security research and analysis.")
     (license license:lgpl3)))
 
+(define-public zycore
+  (package
+    (name "zycore")
+    (version "1.5.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/zyantific/zycore-c")
+                    (commit (string-append "v" version))))
+              (sha256
+               (base32 "0s962pkqybh1xbs75y4jb4bqc9qnq0sviqd570mirqdhhq87agib"))
+              (file-name (git-file-name name version))))
+    (build-system cmake-build-system)
+    (native-inputs (list googletest))
+    (arguments `(#:configure-flags '("-DZYCORE_BUILD_SHARED_LIBS=ON"
+                                     "-DZYCORE_BUILD_TESTS=ON")))
+    (home-page "https://github.com/zyantific/zycore-c")
+    (synopsis "Internal library for Zydis")
+    (description
+     "This package provides platfrom-independent types, macros
+and a fallback for environments without libc for Zydis.")
+    (license license:expat)))
+
 (define-public asco
   (package
     (name "asco")