diff mbox series

[bug#68828] gnu: libxft: Update to 2.3.8

Message ID 071b92407b4002b99326a54c211e9ee306775d46.1706641121.git.msglm@techchud.xyz
State New
Headers show
Series [bug#68828] gnu: libxft: Update to 2.3.8 | expand

Commit Message

msglm Jan. 30, 2024, 6:58 p.m. UTC
* gnu/packages/xorg.scm (libxft): Update to 2.3.8

Change-Id: I93190dd5ce204df6bd8c68220ea4f1d2d57f4e2d
---
 gnu/packages/xorg.scm | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)


base-commit: 2c5293afffa39d5d4aaec248a1973c7f62b1a0b4

Comments

msglm Feb. 7, 2024, 8:41 p.m. UTC | #1
Of note, this is to fix a problem with emojis crashing lukesmithxyz-st
(and perhaps proper st as well, but I haven't checked).
The current version of libxft has a known problem with causing these
crashes, see this FAQ for documentation:
https://git.suckless.org/st/file/FAQ.html#l224
msglm April 25, 2024, 9:21 p.m. UTC | #2
Adding more maintainers to this issue since I didn't before
Ricardo Wurmus April 26, 2024, 6:45 a.m. UTC | #3
Hi,

this patch cannot be applied because it misses the update of the hash.

As the upgrade would require thousands of rebuilds, this change should
be applied on a separate branch.
msglm April 26, 2024, 10:13 p.m. UTC | #4
>misses the update of the hash.
Oops! Sorry about that.

I'm trying to update that now on my end, and im getting a lot of errors
relating to finding a mirror. Can you confirm this is happening on your
end as well?

error exmaples:
download failed "http://mirror.csclub.uwaterloo.ca/x.org/individual/lib/libXft-2.3.8.tar.bz2" 404 "Not Found"

Starting download of /gnu/store/lcqg1f8z9y86amrpim5j5gci7s94ldd4-libXft-2.3.8.tar.bz2
From http://xorg.mirrors.pair.com/individual/lib/libXft-2.3.8.tar.bz2...
In procedure connect*: Connection timed out

I do know that libxft tarballs live here as well:
https://xorg.freedesktop.org/archive/individual/lib/libXft-2.3.8.tar.gz

I don't know if you would be opinionated on changing the source link if
you can reproduce the problem i'm having.

>this should be applied on a separate branch.
I'm new to email-based patches, would I just make a new branch in my
local repo and then make a patch targeting it? Or is there something
else I may need to do.

On Fri Apr 26, 2024 at 1:45 AM CDT, Ricardo Wurmus wrote:
> Hi,
>
> this patch cannot be applied because it misses the update of the hash.
>
> As the upgrade would require thousands of rebuilds, this change should
> be applied on a separate branch.
Simon Tournier May 6, 2024, 11:28 a.m. UTC | #5
HI,

On ven., 26 avril 2024 at 17:13, msglm via Guix-patches via <guix-patches@gnu.org> wrote:

> I'm trying to update that now on my end, and im getting a lot of errors
> relating to finding a mirror. Can you confirm this is happening on your
> end as well?
>
> error exmaples:
> download failed "http://mirror.csclub.uwaterloo.ca/x.org/individual/lib/libXft-2.3.8.tar.bz2" 404 "Not Found"
>
> Starting download of /gnu/store/lcqg1f8z9y86amrpim5j5gci7s94ldd4-libXft-2.3.8.tar.bz2
> From http://xorg.mirrors.pair.com/individual/lib/libXft-2.3.8.tar.bz2...
> In procedure connect*: Connection timed out
>
> I do know that libxft tarballs live here as well:
> https://xorg.freedesktop.org/archive/individual/lib/libXft-2.3.8.tar.gz

The problem is because the extension is not same: compare .bz2 vs .gz.

Indeed, the extension .bz2 does not exist on mirror servers.

--8<---------------cut here---------------start------------->8---
Starting download of /gnu/store/sbrx9br6h2n98z1xgg6ww11jr8fdln6q-libXft-2.3.8.tar.bz2
From http://www.x.org/releases/individual/lib/libXft-2.3.8.tar.bz2...
following redirection to `https://www.x.org/releases/individual/lib/libXft-2.3.8.tar.bz2'...
download failed "https://www.x.org/releases/individual/lib/libXft-2.3.8.tar.bz2" 404 "Not Found"
--8<---------------cut here---------------end--------------->8---

But the extension .gz is there:

--8<---------------cut here---------------start------------->8---
Starting download of /gnu/store/kqkqfp80cz3ldh40r4zbn67rhlgxrg4m-libXft-2.3.8.tar.gz
From http://www.x.org/releases/individual/lib/libXft-2.3.8.tar.gz...
following redirection to `https://www.x.org/releases/individual/lib/libXft-2.3.8.tar.gz'...
downloading from http://www.x.org/releases/individual/lib/libXft-2.3.8.tar.gz ...
 libXft-2.3.8.tar.gz  446KiB                                               103KiB/s 00:04 ▕██████████████████▏ 100.0%
--8<---------------cut here---------------end--------------->8---

The correct patch is thus:

--8<---------------cut here---------------start------------->8---
1 file changed, 3 insertions(+), 3 deletions(-)
gnu/packages/xorg.scm | 6 +++---

modified   gnu/packages/xorg.scm
@@ -1341,17 +1341,17 @@ (define-public libxdmcp
 (define-public libxft
   (package
     (name "libxft")
-    (version "2.3.4")
+    (version "2.3.8")
     (source
       (origin
         (method url-fetch)
         (uri (string-append
                "mirror://xorg/individual/lib/libXft-"
                version
-               ".tar.bz2"))
+               ".tar.gz"))
         (sha256
           (base32
-            "1pdbr6gzfvixc791pjf42i9gg8wvfq6cpq6sdca04h4i42mxmpjp"))))
+           "1a3qybcvhdshgj1wynhsahdnrlmfv2wrjklyh1j2whj4v3i8zr1j"))))
     (build-system gnu-build-system)
     (arguments
      '(#:configure-flags '("--disable-static")))
--8<---------------cut here---------------end--------------->8---

Do you want to send an updated (v2) patch?


Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/xorg.scm b/gnu/packages/xorg.scm
index b7279d0633..bbb686c819 100644
--- a/gnu/packages/xorg.scm
+++ b/gnu/packages/xorg.scm
@@ -1341,7 +1341,7 @@  (define-public libxdmcp
 (define-public libxft
   (package
     (name "libxft")
-    (version "2.3.4")
+    (version "2.3.8")
     (source
       (origin
         (method url-fetch)