diff mbox series

[bug#56026] gnu: Add python-pynrrd.

Message ID 20220616183716.9088-1-antero@mailbox.org
State New
Headers show
Series [bug#56026] gnu: Add python-pynrrd. | expand

Checks

Context Check Description
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch success View Laminar job
cbaines/issue success View issue

Commit Message

Antero Mejr June 16, 2022, 6:37 p.m. UTC
* gnu/packages/python-science.scm (python-pynrrd): New variable.
---
 gnu/packages/python-science.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

Comments

Sharlatan Hellseher Feb. 6, 2024, 9:22 p.m. UTC | #1
Hi,

Pushed as 36f5db706c22d7d643154fc841d0a4018195189b to master.

Thanks,
Oleg
diff mbox series

Patch

diff --git a/gnu/packages/python-science.scm b/gnu/packages/python-science.scm
index 0684826a6c..f7be371512 100644
--- a/gnu/packages/python-science.scm
+++ b/gnu/packages/python-science.scm
@@ -1367,3 +1367,29 @@  (define-public python-gpy
 Python, from the Sheffield machine learning group.  GPy implements a range of
 machine learning algorithms based on GPs.")
     (license license:bsd-3)))
+
+(define-public python-pynrrd
+  (package
+    (name "python-pynrrd")
+    (version "0.4.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/mhe/pynrrd")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "12vlgx2k7jxbq9r9maiix4dbk8alixa0il420bqwhzln08s3chz1"))))
+    (build-system python-build-system)
+    (arguments
+     (list #:phases
+           #~(modify-phases %standard-phases
+               (delete 'ensure-no-mtimes-pre-1980))))
+    (propagated-inputs (list python-numpy))
+    (home-page "https://github.com/mhe/pynrrd")
+    (synopsis "Python module for reading and writing NRRD files")
+    (description
+     "@code{pynrrd} is a Python module for reading and writing NRRD
+files into and from numpy arrays.")
+    (license license:expat)))