[bug#33448,3/3] describe: Add recutils format.

Message ID 20181121141715.16417-3-go.wigust@gmail.com
State Accepted
Headers show
Series [bug#33448,1/3] describe: Use a procedure to format output. | expand

Checks

Context Check Description
cbaines/applying patch success Successfully applied
cbaines/applying patch fail Apply failed
cbaines/applying patch fail Apply failed

Commit Message

Oleg Pykhalov Nov. 21, 2018, 2:17 p.m. UTC
* guix/channels.scm (channel->recutils): New procedure.
* guix/scripts/describe.scm (%options): Add 'recutils' option.
(display-checkout-info, display-profile-info): Use 'channel->recutils'.
* doc/guix.texi (Invoking guix describe): Document this.
---
 doc/guix.texi             |  4 +++-
 guix/channels.scm         |  8 ++++++++
 guix/scripts/describe.scm | 18 +++++++++++++++---
 3 files changed, 26 insertions(+), 4 deletions(-)

Comments

Ludovic Courtès Nov. 21, 2018, 9:34 p.m. UTC | #1
Oleg Pykhalov <go.wigust@gmail.com> skribis:

> * guix/channels.scm (channel->recutils): New procedure.
> * guix/scripts/describe.scm (%options): Add 'recutils' option.
> (display-checkout-info, display-profile-info): Use 'channel->recutils'.
> * doc/guix.texi (Invoking guix describe): Document this.

[...]

> +(define (channel->recutils c port)
> +  (match c
> +    (($ <channel> name url branch commit location)
> +     (format port "name: ~a~%" name)
> +     (format port "url: ~a~%" url)
> +     (format port "commit: ~a~%" commit))))

Same thing here: I’d have a preference for moving it to (guix scripts
describe).

Otherwise LGTM, thanks!

Ludo’.

Patch

diff --git a/doc/guix.texi b/doc/guix.texi
index 3413eb30f..44594d168 100644
--- a/doc/guix.texi
+++ b/doc/guix.texi
@@ -3276,7 +3276,9 @@  pull -C} or installed as @file{~/.config/guix/channels.scm} (@pxref{Invoking
 guix pull});
 @item json
 @cindex JSON
-produce a list of channel specifications in JSON format.
+produce a list of channel specifications in JSON format;
+@item recutils
+produce a list of channel specifications in Recutils format.
 @end table
 
 @item --profile=@var{profile}
diff --git a/guix/channels.scm b/guix/channels.scm
index 9f2c9103e..ed9bc67c3 100644
--- a/guix/channels.scm
+++ b/guix/channels.scm
@@ -41,6 +41,7 @@ 
             channel-location
 
             channel->json
+            channel->recutils
             channel->sexp
 
             %default-channels
@@ -106,6 +107,13 @@ 
        (cons 'url url)
        (cons 'commit commit))))))
 
+(define (channel->recutils c port)
+  (match c
+    (($ <channel> name url branch commit location)
+     (format port "name: ~a~%" name)
+     (format port "url: ~a~%" url)
+     (format port "commit: ~a~%" commit))))
+
 (define-record-type <channel-instance>
   (channel-instance channel commit checkout)
   channel-instance?
diff --git a/guix/scripts/describe.scm b/guix/scripts/describe.scm
index d7e276769..90365b7ae 100644
--- a/guix/scripts/describe.scm
+++ b/guix/scripts/describe.scm
@@ -39,7 +39,7 @@ 
   ;; Specifications of the command-line options.
   (list (option '(#\f "format") #t #f
                 (lambda (opt name arg result)
-                  (unless (member arg '("human" "channels" "json"))
+                  (unless (member arg '("human" "channels" "json" "recutils"))
                     (leave (G_ "~a: unsupported output format~%") arg))
                   (alist-cons 'format (string->symbol arg) result)))
         (option '(#\p "profile") #t #f
@@ -112,7 +112,12 @@  within a Git checkout."
        (display (channel->json (channel (name 'guix)
                                         (url (dirname directory))
                                         (commit commit))))
-       (newline)))
+       (newline))
+      ('recutils
+       (channel->recutils (channel (name 'guix)
+                                   (url (dirname directory))
+                                   (commit commit))
+                          #t)))
     (display-package-search-path fmt)))
 
 (define (display-profile-info profile fmt)
@@ -151,7 +156,14 @@  in the format specified by FMT."
     ('channels
      (pretty-print (map channel->sexp (channels))))
     ('json
-     (format #t "[~a]~%" (string-join (map channel->json (channels)) ","))))
+     (format #t "[~a]~%" (string-join (map channel->json (channels)) ",")))
+    ('recutils
+     (format #t "~{~a~%~}"
+             (map (lambda (channel)
+                    (with-output-to-string
+                      (lambda ()
+                        (channel->recutils channel (current-output-port)))))
+                  (channels)))))
   (display-package-search-path fmt))