diff mbox series

[bug#51725,01/12] gnu: Add rust-lifeguard-0.6.

Message ID XUaKIovshvVvCMi_96Qzjl1ZtLCPZUh9etJrp9SbKoFR48fWCQPv-P05GkKsvjWk9KYKJodOBXW1rG3snVxnjWWRX2RIWBOb7fey2jeXOPg=@protonmail.com
State New
Headers show
Series [bug#51725,01/12] gnu: Add rust-lifeguard-0.6. | expand

Commit Message

phodina Nov. 9, 2021, 4:50 p.m. UTC
Greetings!

The following series of patches add rust-adblock as a small milestone for upstreaming Brave browser.


* gnu/packages/crates-io.scm (rust-lifeguard-0.6): New variable.

----8<--------cut here----------------->8-----

--
2.33.1

Comments

Vagrant Cascadian Sept. 1, 2023, 9:22 p.m. UTC | #1
On 2021-11-09, phodina wrote:
> The following series of patches add rust-adblock as a small milestone for upstreaming Brave browser.

It appears the other patches ended up in some other bug.

> +(define-public rust-lifeguard-0.6
> +  (package
> +    (name "rust-lifeguard")
> +    (version "0.6.1")

And this appears to have been merged as
01b64290cba63586371189b937ed6f1481396086.

Marking as done.

live well,
  vagrant
diff mbox series

Patch

diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 4ccf463e23..35f334ac4f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -26490,6 +26490,25 @@  (define-public rust-libz-sys-1
     (license (list license:asl2.0
                    license:expat))))

+(define-public rust-lifeguard-0.6
+  (package
+    (name "rust-lifeguard")
+    (version "0.6.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (crate-uri "lifeguard" version))
+       (file-name (string-append name "-" version ".tar.gz"))
+       (sha256
+        (base32
+         "09iwwy7888i1kfvbrgwpl4xv3pwsz1fbzx54djs3gnvmszdr9gl9"))))
+    (build-system cargo-build-system)
+    (arguments `(#:skip-build? #t))
+    (home-page "https://github.com/zslayton/lifeguard")
+    (synopsis "Object pool manager in Rust")
+    (description "This package provides an object pool manager in Rust.")
+    (license license:expat)))
+
 (define-public rust-line-0.1
   (package
     (name "rust-line")