diff mbox series

[bug#62201] gnu: Add payload-dumper.

Message ID 863566xkg6.fsf@conses.eu
State New
Headers show
Series [bug#62201] gnu: Add payload-dumper. | expand

Commit Message

Miguel Ángel Moreno March 15, 2023, 12:34 p.m. UTC
* gnu/packages/android.scm (payload-dumper): New variable.
---
 gnu/packages/android.scm | 53 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 53 insertions(+)

Comments

Andrew Tropin June 13, 2023, 10:58 a.m. UTC | #1
On 2023-03-15 13:34, conses wrote:

> * gnu/packages/android.scm (payload-dumper): New variable.
> ---
>  gnu/packages/android.scm | 53 ++++++++++++++++++++++++++++++++++++++++
>  1 file changed, 53 insertions(+)
>
> diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
> index 881b75d763..d7a308775f 100644
> --- a/gnu/packages/android.scm
> +++ b/gnu/packages/android.scm
> @@ -51,6 +51,7 @@ (define-module (gnu packages android)
>    #:use-module (gnu packages java)
>    #:use-module (gnu packages linux)
>    #:use-module (gnu packages pcre)
> +  #:use-module (gnu packages protobuf)
>    #:use-module (gnu packages python)
>    #:use-module (gnu packages python-crypto)
>    #:use-module (gnu packages python-web)
> @@ -982,6 +983,58 @@ (define-public git-repo
>  script that you can put anywhere in your path.")
>      (license license:asl2.0)))
>  
> +(define-public payload-dumper
> +  (let ((commit "35134a28d641deda899c30aed57aace21bfd4a3c")
> +        (revision "0"))
> +    (package
> +      (name "payload-dumper")
> +      (version (git-version "0" revision commit))
> +      (source
> +       (origin
> +         (method git-fetch)
> +         (uri
> +          (git-reference
> +           (url "https://github.com/vm03/payload_dumper")
> +           (commit commit)))
> +         (file-name (git-file-name name version))
> +         (sha256
> +          (base32 "1sdq6dgva5yxz147bkv8xbf79pz60vwc33f0cmj9awgfbxha2b43"))))
> +      (inputs
> +       (list python-3 python-protobuf python-six python-bsdiff4))
> +      (build-system python-build-system)
> +      (arguments
> +       (list
> +        #:use-setuptools? #f
> +        #:tests? #f
> +        #:phases
> +        #~(modify-phases %standard-phases
> +            (delete 'build)
> +            (replace 'install
> +              (lambda* (#:key outputs #:allow-other-keys)
> +                (begin
> +                  (use-modules (guix build utils))
> +                  (let* ((python (string-append
> +                                  #$(this-package-input "python")
> +                                  "/bin"))
> +                         (bin (string-append #$output "/bin"))
> +                         (target (string-append bin "/payload_dumper"))
> +                         (version (python-version
> +                                   #$(this-package-input "python")))
> +                         (pydir (string-append #$output "/lib/python"
> +                                               version "/site-packages")))
> +                    (mkdir-p bin)
> +                    (copy-file (string-append #$source "/payload_dumper.py")
> +                               target)
> +                    (install-file "update_metadata_pb2.py" pydir)
> +                    (substitute* target
> +                      (("/usr/bin/env python") (which "python3")))
> +                    (chmod target #o555))))))))
> +      (synopsis "Android OTA payload dumper")
> +      (description "Script to extract the payload of incremental and full
> +OTA's.")
> +      (home-page "https://github.com/vm03/payload_dumper")
> +      (license license:gpl3+))))
> +
>  (define-public abootimg
>    (package
>      (name "abootimg")
> -- 
> 2.39.1

Hi Miguel!

I can't find the license for this project, can you ask an author to
specify it, please?
Miguel Ángel Moreno June 28, 2023, 7:51 a.m. UTC | #2
Hi Andrew,

Thanks for having a look.  I raised an issue on the repo, but
the maintainer told me he isn't the original author of the tool and thus
doesn't feel comfortable adding a license to it, see
<https://github.com/vm03/payload_dumper/issues/58>.  How should we
proceed in this case?
Andrew Tropin June 29, 2023, 1:14 p.m. UTC | #3
On 2023-06-28 09:51, Miguel Ángel Moreno wrote:

> Hi Andrew,
>
> Thanks for having a look.  I raised an issue on the repo, but
> the maintainer told me he isn't the original author of the tool and thus
> doesn't feel comfortable adding a license to it, see
> <https://github.com/vm03/payload_dumper/issues/58>.  How should we
> proceed in this case?

I would summon more advanced in this topic colleagues :)

CCed Ludo and Liliana.
Liliana Marie Prikler June 29, 2023, 4:59 p.m. UTC | #4
Am Donnerstag, dem 29.06.2023 um 17:14 +0400 schrieb Andrew Tropin:
> On 2023-06-28 09:51, Miguel Ángel Moreno wrote:
> 
> > Hi Andrew,
> > 
> > Thanks for having a look.  I raised an issue on the repo, but
> > the maintainer told me he isn't the original author of the tool and
> > thus doesn't feel comfortable adding a license to it, see
> > <https://github.com/vm03/payload_dumper/issues/58>.  How should we
> > proceed in this case?
> 
> I would summon more advanced in this topic colleagues :)
> 
> CCed Ludo and Liliana.
No license, no original source?  No, thanks.  
For more background, see [1,2].

Cheers

[1] https://www.gnu.org/licenses/license-list.html#NoLicense
[2] https://www.gnu.org/licenses/license-list.html.en#NoLicense
Miguel Ángel Moreno June 30, 2023, 8:52 a.m. UTC | #5
On 2023-06-29 18:59, Liliana Marie Prikler wrote:

> Am Donnerstag, dem 29.06.2023 um 17:14 +0400 schrieb Andrew Tropin:
>> On 2023-06-28 09:51, Miguel Ángel Moreno wrote:
>> 
>> > Hi Andrew,
>> > 
>> > Thanks for having a look.  I raised an issue on the repo, but
>> > the maintainer told me he isn't the original author of the tool and
>> > thus doesn't feel comfortable adding a license to it, see
>> > <https://github.com/vm03/payload_dumper/issues/58>.  How should we
>> > proceed in this case?
>> 
>> I would summon more advanced in this topic colleagues :)
>> 
>> CCed Ludo and Liliana.
> No license, no original source?  No, thanks.  
> For more background, see [1,2].
>
> Cheers
>
> [1] https://www.gnu.org/licenses/license-list.html#NoLicense
> [2] https://www.gnu.org/licenses/license-list.html.en#NoLicense

Thanks for the heads up.  Unless Ludo or someone else has some pointers
on what could be done to tackle this scenario, I'll try to package this
elsewhere.
Ludovic Courtès July 10, 2023, 9:29 p.m. UTC | #6
Hi,

Miguel Ángel Moreno <mail@migalmoreno.com> skribis:

> On 2023-06-29 18:59, Liliana Marie Prikler wrote:
>
>> Am Donnerstag, dem 29.06.2023 um 17:14 +0400 schrieb Andrew Tropin:
>>> On 2023-06-28 09:51, Miguel Ángel Moreno wrote:
>>> 
>>> > Hi Andrew,
>>> > 
>>> > Thanks for having a look.  I raised an issue on the repo, but
>>> > the maintainer told me he isn't the original author of the tool and
>>> > thus doesn't feel comfortable adding a license to it, see
>>> > <https://github.com/vm03/payload_dumper/issues/58>.  How should we
>>> > proceed in this case?
>>> 
>>> I would summon more advanced in this topic colleagues :)
>>> 
>>> CCed Ludo and Liliana.
>> No license, no original source?  No, thanks.  
>> For more background, see [1,2].
>>
>> Cheers
>>
>> [1] https://www.gnu.org/licenses/license-list.html#NoLicense
>> [2] https://www.gnu.org/licenses/license-list.html.en#NoLicense
>
> Thanks for the heads up.  Unless Ludo or someone else has some pointers
> on what could be done to tackle this scenario, I'll try to package this
> elsewhere.

Sorry for the delay!  If there’s no license, it’s indeed not
even distributable, so definitely not suitable for Guix.

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/android.scm b/gnu/packages/android.scm
index 881b75d763..d7a308775f 100644
--- a/gnu/packages/android.scm
+++ b/gnu/packages/android.scm
@@ -51,6 +51,7 @@  (define-module (gnu packages android)
   #:use-module (gnu packages java)
   #:use-module (gnu packages linux)
   #:use-module (gnu packages pcre)
+  #:use-module (gnu packages protobuf)
   #:use-module (gnu packages python)
   #:use-module (gnu packages python-crypto)
   #:use-module (gnu packages python-web)
@@ -982,6 +983,58 @@  (define-public git-repo
 script that you can put anywhere in your path.")
     (license license:asl2.0)))
 
+(define-public payload-dumper
+  (let ((commit "35134a28d641deda899c30aed57aace21bfd4a3c")
+        (revision "0"))
+    (package
+      (name "payload-dumper")
+      (version (git-version "0" revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri
+          (git-reference
+           (url "https://github.com/vm03/payload_dumper")
+           (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "1sdq6dgva5yxz147bkv8xbf79pz60vwc33f0cmj9awgfbxha2b43"))))
+      (inputs
+       (list python-3 python-protobuf python-six python-bsdiff4))
+      (build-system python-build-system)
+      (arguments
+       (list
+        #:use-setuptools? #f
+        #:tests? #f
+        #:phases
+        #~(modify-phases %standard-phases
+            (delete 'build)
+            (replace 'install
+              (lambda* (#:key outputs #:allow-other-keys)
+                (begin
+                  (use-modules (guix build utils))
+                  (let* ((python (string-append
+                                  #$(this-package-input "python")
+                                  "/bin"))
+                         (bin (string-append #$output "/bin"))
+                         (target (string-append bin "/payload_dumper"))
+                         (version (python-version
+                                   #$(this-package-input "python")))
+                         (pydir (string-append #$output "/lib/python"
+                                               version "/site-packages")))
+                    (mkdir-p bin)
+                    (copy-file (string-append #$source "/payload_dumper.py")
+                               target)
+                    (install-file "update_metadata_pb2.py" pydir)
+                    (substitute* target
+                      (("/usr/bin/env python") (which "python3")))
+                    (chmod target #o555))))))))
+      (synopsis "Android OTA payload dumper")
+      (description "Script to extract the payload of incremental and full
+OTA's.")
+      (home-page "https://github.com/vm03/payload_dumper")
+      (license license:gpl3+))))
+
 (define-public abootimg
   (package
     (name "abootimg")