diff mbox series

[bug#63739] gnu: Add font-intel-one-mono

Message ID d67452b9058258d7a02b040e3520e6a459611bc7.1685112598.git.gemmaro.dev@gmail.com
State New
Headers show
Series [bug#63739] gnu: Add font-intel-one-mono | expand

Commit Message

gemmaro May 26, 2023, 2:51 p.m. UTC
* gnu/packages/fonts.scm (font-intel-one-mono): New variable.
---
 gnu/packages/fonts.scm | 22 ++++++++++++++++++++++
 1 file changed, 22 insertions(+)


base-commit: a9cde26133bd98498869a3528d9dff0d3f456a96

Comments

Nicolas Goaziou July 1, 2023, 10:14 a.m. UTC | #1
Hello,

gemmaro <gemmaro.dev@gmail.com> writes:

> * gnu/packages/fonts.scm (font-intel-one-mono): New variable.

Applied with changes described below. Thank you.

> +(define-public font-intel-one-mono
> +  (package
> +    (name "font-intel-one-mono")
> +    (version "1.2.0")
> +    (source (origin
> +              (method git-fetch)
> +              (uri (git-reference
> +                    (url "https://github.com/intel/intel-one-mono")
> +                    (commit "9effabe19a60bdd46cbfbdcc6e81facd8a13b762")))

We prefer tags over raw commit hashes. In this case, the tag is
"V1.2.0", so you need to use instead:

  (string-append "V" version)

If there's no tag, we bind the hash string to a `commit' variable around
the package definition, possibly along with a `revision' if the commit
does not match any version bump,  a and write:

  (commit commit)

> +    (description
> +     "Introducing Intel One Mono, an expressive monospaced font family that's built
> +with clarity, legibility, and the needs of developers in mind.")

The description should consist of complete sentences:

 "This package introduces..."

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/fonts.scm b/gnu/packages/fonts.scm
index 12c6b04bd70..cfce3becf5a 100644
--- a/gnu/packages/fonts.scm
+++ b/gnu/packages/fonts.scm
@@ -55,6 +55,7 @@ 
 ;;; Copyright © 2023 Nicolas Graves <ngraves@ngraves.fr>
 ;;; Copyright © 2023 Ahmad Draidi <a.r.draidi@redscript.org>
 ;;; Copyright © 2023 Arnaud Lechevallier <arnaud.lechevallier@free.fr>
+;;; Copyright © 2023 gemmaro <gemmaro.dev@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -185,6 +186,27 @@  (define-public font-inconsolata
 in print.  With attention to detail for high resolution rendering.")
     (license license:silofl1.1)))
 
+(define-public font-intel-one-mono
+  (package
+    (name "font-intel-one-mono")
+    (version "1.2.0")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/intel/intel-one-mono")
+                    (commit "9effabe19a60bdd46cbfbdcc6e81facd8a13b762")))
+              (file-name (git-file-name name version))
+              (sha256
+               (base32
+                "12lywni8bgkr8h4pz1lkw4imr2y896rnsvipbqgqv3c1b54b5g7n"))))
+    (build-system font-build-system)
+    (home-page "https://github.com/intel/intel-one-mono")
+    (synopsis "Expressive monospaced font family")
+    (description
+     "Introducing Intel One Mono, an expressive monospaced font family that's built
+with clarity, legibility, and the needs of developers in mind.")
+    (license license:silofl1.1)))
+
 (define-public font-dejavu
   (package
     (name "font-dejavu")