diff mbox series

[bug#63901,1/2] gnu: Add tuba.

Message ID ecee41aa9efb2775d3c11d01b7eebea9fe8e71f2.1685949908.git.efraim@flashner.co.il
State New
Headers show
Series Add tuba | expand

Commit Message

Efraim Flashner June 5, 2023, 7:28 a.m. UTC
* gnu/packages/mastodon.scm (tuba): New variable.
---
 gnu/packages/mastodon.scm | 46 +++++++++++++++++++++++++++++++++++++++
 1 file changed, 46 insertions(+)

Comments

Efraim Flashner June 14, 2023, 7:16 p.m. UTC | #1
I've pushed this one but I've held off on pushing the second one,
deprecating tootle for tuba. It's abandoned upstream but I'd rather not
rip it out of anyone's hands just yet.
diff mbox series

Patch

diff --git a/gnu/packages/mastodon.scm b/gnu/packages/mastodon.scm
index 9c1d3cd26f..0d430391dc 100644
--- a/gnu/packages/mastodon.scm
+++ b/gnu/packages/mastodon.scm
@@ -81,6 +81,52 @@  (define-public toot
 @end itemize")
     (license license:gpl3)))
 
+(define-public tuba
+  (package
+    (name "tuba")
+    (version "0.3.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/GeopJr/Tuba")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "1xhyz6wi17g4m76lr6qc75q4xnnw7c3dh3d04dg8m5gzk6j0y89x"))))
+    (build-system meson-build-system)
+    (arguments
+     `(#:glib-or-gtk? #t
+       #:configure-flags (list "-Ddistro=true")
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'glib-or-gtk-wrap 'symlink-package
+           (lambda* (#:key outputs #:allow-other-keys)
+             (with-directory-excursion
+               (string-append (assoc-ref outputs "out") "/bin")
+               (symlink "dev.geopjr.Tuba" "tuba")))))))
+    (native-inputs
+     (list gettext-minimal
+           `(,glib "bin") ; for glib-compile-resources
+           pkg-config))
+    (inputs
+     (list gtk
+           gtksourceview
+           json-glib
+           libadwaita
+           libgee
+           libsoup-minimal
+           libsecret
+           libwebp
+           libxml2
+           vala))
+    (home-page "https://tuba.geopjr.dev/")
+    (synopsis "GTK client for Mastodon")
+    (description "Tuba is a GTK client for Mastodon.  It provides a clean,
+native interface that allows you to integrate Mastodon's social experience
+seamlessly with your desktop environment.")
+    (license license:gpl3)))
+
 (define-public tootle
   (package
     (name "tootle")