diff mbox series

[bug#61644,v4] gnu: Add swig-next

Message ID 20230323053437.11875-1-atai@atai.org
State New
Headers show
Series [bug#61644,v4] gnu: Add swig-next | expand

Commit Message

Andy Tai March 23, 2023, 5:34 a.m. UTC
* gnu/packages/swig.scm (swig-next): New variable.
---
 gnu/packages/swig.scm | 18 ++++++++++++++++++
 1 file changed, 18 insertions(+)


base-commit: 5174820753be045ba4fc7cc93da33f4e0b730bc3
prerequisite-patch-id: 88a340e0d72bd9cd0531b3441c54210b443c4318

Comments

Ludovic Courtès June 8, 2023, 9:21 p.m. UTC | #1
Andy Tai <atai@atai.org> skribis:

> * gnu/packages/swig.scm (swig-next): New variable.

Finally applied, thanks!
diff mbox series

Patch

diff --git a/gnu/packages/swig.scm b/gnu/packages/swig.scm
index b5195e2cc5..74f42a3b52 100644
--- a/gnu/packages/swig.scm
+++ b/gnu/packages/swig.scm
@@ -65,3 +65,21 @@  (define-public swig
 
     ;; See http://www.swig.org/Release/LICENSE for details.
     (license gpl3+)))
+
+(define-public swig-next
+  ;; a number of packages using swig do not build with this version
+  ;; so we need to keep swig 4.0.2 above and place the current release
+  ;; as swig-next
+  (package
+    (inherit swig)
+    (name "swig")
+    (version "4.1.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/" name "/" name "/"
+                                 name "-" version "/"
+                                 name "-" version ".tar.gz"))
+              (sha256
+               (base32
+                "16xc767gf5ip40jh698wbdrxrghli5v2c966bkdmrmpwv378mw1a"))))
+    (inputs (list pcre2))))