diff mbox series

[bug#62078,v2] gnu: Add python-redo.

Message ID 855dc5d7-657c-f9db-b819-792ee1b0a430@disroot.org
State New
Headers show
Series [bug#62078,v2] gnu: Add python-redo. | expand

Commit Message

Adam Faiz June 3, 2023, 4:02 a.m. UTC
From 971c628998b36dc32bafd30364f635bafc8ff7cd Mon Sep 17 00:00:00 2001
Message-Id: <971c628998b36dc32bafd30364f635bafc8ff7cd.1685764335.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Thu, 9 Mar 2023 21:59:48 +0800
Subject: [PATCH v2] gnu: Add python-redo.

* gnu/packages/python-xyz.scm (python-redo): New variable.
---
  gnu/packages/python-xyz.scm | 35 +++++++++++++++++++++++++++++++++++
  1 file changed, 35 insertions(+)


base-commit: 12e6a5923812abf180f03bea9e07dd99244a3fcd

Comments

jgart June 4, 2023, 1:14 p.m. UTC | #1
Hi Adam,

Thanks for sending an update.

How did you take this patch? I'm trying to debug why this patch is not applying cleanly on my end.

I get the following error:

warning: Patch sent with format=flowed; space at the end of lines might be lost.
Applying: gnu: Add python-redo.
error: corrupt patch at line 51
Patch failed at 0001 gnu: Add python-redo.

all best,

jgart
jgart June 22, 2023, 5:19 a.m. UTC | #2
tags 62078 moreinfo
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 19f4ec97ff..2e2387a14a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -29988,6 +29988,41 @@  (define-public python-recommonmark
  lets you write CommonMark inside of Docutils & Sphinx projects.")
      (license license:expat)))
  
+(define-public python-redo
+  ; The latest release isn't tagged:
+  ; https://github.com/mozilla-releng/redo/issues/76
+  (let ((commit "50cfe8e3656f253f9e51df3a998530351d2d9a8c")
+        (revision "0"))
+    (package
+      (name "python-redo")
+      (version (git-version "2.0.4" revision commit))
+      (source
+       (origin
+         (method git-fetch)               ; no tests in PyPI release
+         (uri (git-reference
+               (url "https://github.com/mozilla-releng/redo")
+               (commit commit)))
+         (file-name (git-file-name name version))
+         (sha256
+          (base32 "0xpylx97qr4ikdhsr208ri41007mpp57a4n8mmlmlqmdljmsdpdb"))))
+      (build-system python-build-system)
+      (native-inputs
+       (list python-mock
+             python-pytest))
+      (arguments
+       (list #:phases
+             #~(modify-phases %standard-phases
+                 (replace 'check
+                   (lambda* (#:key tests? #:allow-other-keys)
+                     (when tests?
+                       ;; The project uses tox to run the tests via pytest.
+                       (invoke "pytest")))))))
+      (home-page "https://github.com/mozilla-releng/redo")
+      (synopsis "Utilities to retry Python callables")
+      (description "Redo provides various means to add seamless ability to
+retry to any Python callable.")
+      (license license:mpl2.0))))
+
  (define-public python-pyhull
    (package
      (name "python-pyhull")