diff mbox series

[bug#62078] gnu: Add python-redo.

Message ID e311e1ad-1dcf-2ef1-8086-6706045a78d1@disroot.org
State New
Headers show
Series [bug#62078] gnu: Add python-redo. | expand

Commit Message

Adam Faiz March 9, 2023, 4:47 p.m. UTC
From f22e04ade259930dc3c3e282d044b7b8b6b1f774 Mon Sep 17 00:00:00 2001
Message-Id: <f22e04ade259930dc3c3e282d044b7b8b6b1f774.1678379861.git.adam.faiz@disroot.org>
In-Reply-To: <f788ce8ebc205a6e05bcc270865d793d94bf51e9.1678379861.git.adam.faiz@disroot.org>
References: <f788ce8ebc205a6e05bcc270865d793d94bf51e9.1678379861.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Thu, 9 Mar 2023 21:59:48 +0800
Subject: [PATCH] gnu: Add python-redo.

* gnu/packages/python-xyz.scm (python-redo): New variable.
---
  gnu/packages/python-xyz.scm | 17 +++++++++++++++++
  1 file changed, 17 insertions(+)

Comments

jgart June 2, 2023, 12:48 p.m. UTC | #1
Hi Adam,

Thanks for the patch!

Could you send an updated patch (v2) enabling the tests on python-redo and adding any test inputs that are required for that?

This current patch also does not apply cleanly to master:

error: corrupt patch at line 33
Patch failed at 0001 gnu: Add python-redo.

all best,

jgart
jgart July 12, 2023, 6:24 a.m. UTC | #2
Hi Adam,

Thanks for the patch. APPLIED.

all best,

jgart
diff mbox series

Patch

diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 4bacd86432..d4f0a83a5d 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -3595,6 +3595,23 @@  (define-public python-miniupnpc
      (home-page "http://miniupnp.free.fr")
      (license license:bsd-3)))
  
+(define-public python-redo
+  (package
+    (name "python-redo")
+    (version "2.0.4")
+    (source (origin
+              (method url-fetch)
+              (uri (pypi-uri "redo" version))
+              (sha256
+               (base32
+                "0hx0yyl2mz13v513vyjc3h9lbkkxhyh6bswich73p18w0ianj1l1"))))
+    (build-system python-build-system)
+    (home-page "https://github.com/mozilla-releng/redo")
+    (synopsis "Utilities to retry Python callables")
+    (description "Redo provides various means to add seamless ability to
+retry to any Python callable.")
+    (license license:mpl2.0)))
+
  (define-public python-py
    (package
      (name "python-py")