diff mbox series

[bug#62922,v2] gnu: python-lazr-restfulclient: Add missing dependencies.

Message ID a070a7aa7e2cafd0a4d63b4f9335ed296ae76b39.1684780475.git.ivan@selidor.net
State New
Headers show
Series [bug#62922,v2] gnu: python-lazr-restfulclient: Add missing dependencies. | expand

Commit Message

Ivan Vilata i Balaguer May 22, 2023, 6:38 p.m. UTC
Fixes <https://issues.guix.gnu.org/62922>.

* gnu/packages/python-web.scm (python-lazr-restfulclient): Add missing
dependencies.
[propagated-inputs] Add python-pyparsing and python-six.
---
The original patch from Tom Willemse still issued a DistributionNotFound error
on pyparsing.  This alternative version adds both dependencies (without extra
reformatting).  Thanks Tom for the initiative!

 gnu/packages/python-web.scm | 3 +++
 1 file changed, 3 insertions(+)


base-commit: dff1689bb37e5303868584d3f1d7a33cbcb7f51e

Comments

Ivan Vilata i Balaguer May 23, 2023, 7:27 a.m. UTC | #1
An equivalent patch was commited by jgart:
87d75d915152b150c3800d7011b04b4d11cd339c.

This issue can be closed now, thanks!


Ivan Vilata i Balaguer (2023-05-22 20:38:17 +0200) wrote:

> Fixes <https://issues.guix.gnu.org/62922>.
> 
> * gnu/packages/python-web.scm (python-lazr-restfulclient): Add missing
> dependencies.
> [propagated-inputs] Add python-pyparsing and python-six.
> ---
> The original patch from Tom Willemse still issued a DistributionNotFound error
> on pyparsing.  This alternative version adds both dependencies (without extra
> reformatting).  Thanks Tom for the initiative!
> 
>  gnu/packages/python-web.scm | 3 +++
>  1 file changed, 3 insertions(+)
> 
> diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
> index b6ad489626..262309032f 100644
> --- a/gnu/packages/python-web.scm
> +++ b/gnu/packages/python-web.scm
> @@ -59,6 +59,7 @@
>  ;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
>  ;;; Copyright © 2022 Baptiste Strazzulla <bstrazzull@hotmail.fr>
>  ;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
> +;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -143,6 +144,8 @@ (define-public python-lazr-restfulclient
>       (list python-distro
>             python-httplib2
>             python-oauthlib
> +           python-pyparsing
> +           python-six
>             python-wadllib))
>      (home-page "https://launchpad.net/lazr.restfulclient")
>      (synopsis "Web client Python library extending wadlib")
> 
> base-commit: dff1689bb37e5303868584d3f1d7a33cbcb7f51e
> -- 
> 2.39.2
diff mbox series

Patch

diff --git a/gnu/packages/python-web.scm b/gnu/packages/python-web.scm
index b6ad489626..262309032f 100644
--- a/gnu/packages/python-web.scm
+++ b/gnu/packages/python-web.scm
@@ -59,6 +59,7 @@ 
 ;;; Copyright © 2022 Michael Rohleder <mike@rohleder.de>
 ;;; Copyright © 2022 Baptiste Strazzulla <bstrazzull@hotmail.fr>
 ;;; Copyright © 2023 John Kehayias <john.kehayias@protonmail.com>
+;;; Copyright © 2023 Ivan Vilata-i-Balaguer <ivan@selidor.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -143,6 +144,8 @@  (define-public python-lazr-restfulclient
      (list python-distro
            python-httplib2
            python-oauthlib
+           python-pyparsing
+           python-six
            python-wadllib))
     (home-page "https://launchpad.net/lazr.restfulclient")
     (synopsis "Web client Python library extending wadlib")