diff mbox series

[bug#62545] gnu: Add Free as in Freedom (2.0).

Message ID 20230330143109.17484-1-iyzsong@envs.net
State New
Headers show
Series [bug#62545] gnu: Add Free as in Freedom (2.0). | expand

Commit Message

Deslauriers, Douglas via Guix-patches" via March 30, 2023, 2:31 p.m. UTC
From: 宋文武 <iyzsong@member.fsf.org>

* gnu/packages/fsf.scm: New file.
* gnu/local.mk (GNU_SYSTEM_MODULES): Add it.
---
 gnu/local.mk         |  1 +
 gnu/packages/fsf.scm | 72 ++++++++++++++++++++++++++++++++++++++++++++
 2 files changed, 73 insertions(+)
 create mode 100644 gnu/packages/fsf.scm

Comments

宋文武 May 12, 2023, 12:23 p.m. UTC | #1
Pushed now!
diff mbox series

Patch

diff --git a/gnu/local.mk b/gnu/local.mk
index aee0b8a645..2b99402ae0 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -262,6 +262,7 @@  GNU_SYSTEM_MODULES =				\
   %D%/packages/forth.scm			\
   %D%/packages/freedesktop.scm			\
   %D%/packages/freeipmi.scm			\
+  %D%/packages/fsf.scm				\
   %D%/packages/ftp.scm				\
   %D%/packages/fribidi.scm			\
   %D%/packages/fvwm.scm				\
diff --git a/gnu/packages/fsf.scm b/gnu/packages/fsf.scm
new file mode 100644
index 0000000000..70a5df741a
--- /dev/null
+++ b/gnu/packages/fsf.scm
@@ -0,0 +1,72 @@ 
+;;; GNU Guix --- Functional package management for GNU
+;;; Copyright © 2023 Sou Bunnbu <iyzsong@envs.net>
+;;;
+;;; This file is part of GNU Guix.
+;;;
+;;; GNU Guix is free software; you can redistribute it and/or modify it
+;;; under the terms of the GNU General Public License as published by
+;;; the Free Software Foundation; either version 3 of the License, or (at
+;;; your option) any later version.
+;;;
+;;; GNU Guix is distributed in the hope that it will be useful, but
+;;; WITHOUT ANY WARRANTY; without even the implied warranty of
+;;; MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
+;;; GNU General Public License for more details.
+;;;
+;;; You should have received a copy of the GNU General Public License
+;;; along with GNU Guix.  If not, see <http://www.gnu.org/licenses/>.
+
+(define-module (gnu packages fsf)
+  #:use-module (gnu packages tex)
+  #:use-module (guix build-system copy)
+  #:use-module (guix download)
+  #:use-module (guix gexp)
+  #:use-module (guix packages)
+  #:use-module ((guix licenses) #:prefix license:))
+
+(define-public faif
+  (package
+    (name "faif")
+    (version "2.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://www.fsf.org/faif/faif-" version
+                                  ".tar.bz2"))
+              (sha256
+               (base32
+                "0qf14d0n6k1dn9z0fdnx9qkhn4iq685xd443w7l7w54bm931p7dw"))))
+    (build-system copy-build-system)
+    (native-inputs
+     (list (texlive-updmap.cfg
+            (list
+             texlive-caption
+             texlive-endnotes
+             texlive-fonts-ec
+             texlive-helvetic
+             texlive-hyperref
+             texlive-latex-fncychap
+             texlive-latex-geometry
+             texlive-latex-ucs
+             texlive-times))))
+    (arguments
+     (list
+      #:install-plan #~'(("faif-2.0.pdf" "share/doc/"))
+      #:phases
+      #~(modify-phases %standard-phases
+          (add-before 'install 'build
+            (lambda _
+              (invoke "pdflatex" "faif-2.0.tex"))))))
+    (home-page "https://www.fsf.org/faif")
+    (synopsis "Free as in Freedom (2.0)")
+    (description
+     "In 2002, Sam Williams wrote Free as in Freedom, a biography of Richard
+M. Stallman.  In its epilogue, Williams expressed hope that choosing to
+distribute his book under the GNU Free Documentation License would enable and
+encourage others to share corrections and their own perspectives through
+modifications to his work.  Free as in Freedom (2.0) is Stallman's revision of
+the original biography.  While preserving Williams's viewpoint, it includes
+factual corrections and extensive new commentary by Stallman, as well as new
+prefaces by both authors written for the occasion.  It is a rare kind of
+biography, where the reader has the benefit of both the biographer's original
+words and the subject's response.")
+    (license license:fdl1.3+)))