diff mbox series

[bug#44165] gnu: Add emacs-xonsh-mode.

Message ID 87zh466t16.fsf@odyssey.lafreniere.xyz
State New
Headers show
Series [bug#44165] gnu: Add emacs-xonsh-mode. | expand

Checks

Context Check Description
cbaines/submitting builds success
cbaines/issue success View issue
cbaines/comparison success View comparision
cbaines/git branch success View Git branch
cbaines/applying patch fail View Laminar job

Commit Message

LaFreniere, Joseph Oct. 28, 2020, 7:37 p.m. UTC
Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:
> The version is actually "O" according to the "Version" keyword 
> in the
> Elisp file, not "0.0.0".

Updated.

>   Emacs major mode for editing @file{xonshrc} files
>
> seems slightly more accurate.

I pulled in the change denoting that the package provides an 
_Emacs_ major mode.  I'm less sure about changing @code{xonsh} to 
@file{xonshrc}.  You suggestion is what the Emacs Lisp package's 
header says, but that header is slightly misleading because the 
major mode is not just for xonsh rc files but also full xonsh 
script files (.xsh).

> Mind the two spaces after the full stop above.

Updated.

> @file{.xonshrc} or @file{.xsh} extension

Updated.

> Could you send an updated patch?

Patch file is attached.  Thank you for the review!

--
Joseph LaFreniere

Comments

Hilton Chain April 25, 2023, 7:39 a.m. UTC | #1
Hello Nicolas,

It seems that you missed the updated patch (<https://issues.guix.gnu.org/44165#2>).

This patch looks good to me, and there's no update on the source side.  Can you review it later?

Thanks!
Nicolas Goaziou April 25, 2023, 9:51 a.m. UTC | #2
Hello,

Hilton Chain via Guix-patches via <guix-patches@gnu.org> writes:

> Hello Nicolas,
>
> It seems that you missed the updated patch (<https://issues.guix.gnu.org/44165#2>).
>
> This patch looks good to me, and there's no update on the source side.
> Can you review it later?

Done. It indeed fell through the cracks.

Applied. Thank you.

Regards,
diff mbox series

Patch

From 1c8450c5ef7666cd0334d52e70ed9ce962400de1 Mon Sep 17 00:00:00 2001
From: Joseph LaFreniere <joseph@lafreniere.xyz>
Date: Thu, 22 Oct 2020 20:15:59 -0500
Subject: [PATCH] gnu: Add emacs-xonsh-mode.

* gnu/packages/emacs-xyz.scm (emacs-xonsh-mode): New variable.
---
 gnu/packages/emacs-xyz.scm | 26 ++++++++++++++++++++++++++
 1 file changed, 26 insertions(+)

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 818db3e4e5..b0c533dc22 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -25191,3 +25191,29 @@  the TypeScript implementation.")
       (description "This package provides an Emacs client for the Rocket.chat
 service.")
       (license license:expat))))
+
+(define-public emacs-xonsh-mode
+  ;; There is no tagged release yet.
+  (let ((tag "0")
+        (commit "7fa581524533a9b6b770426e4445e571a69e469d")
+        (revision "0"))
+    (package
+      (name "emacs-xonsh-mode")
+      (version (git-version tag revision commit))
+      (source
+       (origin
+         (method git-fetch)
+         (uri (git-reference
+               (url "https://github.com/seanfarley/xonsh-mode.git")
+               (commit commit)))
+         (sha256
+          (base32 "0lfi2372clkkzi4a940fwparsfhxxzb7bmysfd50n1myakgldri5"))))
+      (build-system emacs-build-system)
+      (home-page "https://github.com/seanfarley/xonsh-mode")
+      (synopsis "Emacs major mode for editing @code{xonsh} files")
+      (description
+       "This package implements a major mode for xonsh scripts.  The basic
+functionality includes syntax highlight for xonsh operators.  Files with the
+@file{.xonshrc} or @file{.xsh} extension are automatically opened with this
+mode.")
+      (license license:gpl3+))))
-- 
2.28.0