diff mbox series

[bug#59355,v1] gnu: Add dataparksearch.

Message ID 62129599-010b-9ca4-e254-167b2980699e@disroot.org
State New
Headers show
Series [bug#59355,v1] gnu: Add dataparksearch. | expand

Commit Message

Adam Faiz Feb. 19, 2023, 12:29 a.m. UTC
From 10067c9599d06ea2518b0adb561eaf2f825ae1a5 Mon Sep 17 00:00:00 2001
Message-Id: 
<10067c9599d06ea2518b0adb561eaf2f825ae1a5.1676766217.git.adam.faiz@disroot.org>
From: AwesomeAdam54321 <adam.faiz@disroot.org>
Date: Fri, 18 Nov 2022 08:55:02 +0800
Subject: [PATCH 1/6] gnu: Add dataparksearch.

* gnu/packages/search.scm (dataparksearch): New variable.
---
  gnu/packages/search.scm | 55 +++++++++++++++++++++++++++++++++++++++++
  1 file changed, 55 insertions(+)

+
  (define-public fsearch
    (package
      (name "fsearch")

base-commit: 08edbd2535ae622d319a51e6f877d23d75dc24f3
prerequisite-patch-id: 66a677452cec5da7e4db37327b344d02556968f6
prerequisite-patch-id: e13c3b4b4ed06ce521ff679ec64e3cd816183388
prerequisite-patch-id: 1eb4d567a14802495169b3e400e02de0b4941729

Comments

Nicolas Goaziou April 22, 2023, 10:03 a.m. UTC | #1
Hello,

Adam Faiz via Guix-patches via <guix-patches@gnu.org> writes:

>  From 10067c9599d06ea2518b0adb561eaf2f825ae1a5 Mon Sep 17 00:00:00 2001
> Message-Id: 
> <10067c9599d06ea2518b0adb561eaf2f825ae1a5.1676766217.git.adam.faiz@disroot.org>
> From: AwesomeAdam54321 <adam.faiz@disroot.org>
> Date: Fri, 18 Nov 2022 08:55:02 +0800
> Subject: [PATCH 1/6] gnu: Add dataparksearch.

Thank you.

I removed ""--disable-syslog" since there was no clear consensus about
it (we can always add it again later, of course), reordered inputs
alphabetically, fixed indentation, added a copyright line for you in the
module and applied your patch.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/search.scm b/gnu/packages/search.scm
index fe69fd3775..262f63821d 100644
--- a/gnu/packages/search.scm
+++ b/gnu/packages/search.scm
@@ -40,6 +40,7 @@  (define-module (gnu packages search)
    #:use-module (guix build-system python)
    #:use-module (guix build-system meson)
    #:use-module (gnu packages)
+  #:use-module (gnu packages adns)
    #:use-module (gnu packages aspell)
    #:use-module (gnu packages autotools)
    #:use-module (gnu packages base)
@@ -51,6 +52,7 @@  (define-module (gnu packages search)
    #:use-module (gnu packages gawk)
    #:use-module (gnu packages gettext)
    #:use-module (gnu packages glib)
+  #:use-module (gnu packages gnunet)
    #:use-module (gnu packages groff)
    #:use-module (gnu packages gtk)
    #:use-module (gnu packages icu4c)
@@ -67,6 +69,7 @@  (define-module (gnu packages search)
    #:use-module (gnu packages qt)
    #:use-module (gnu packages sphinx)
    #:use-module (gnu packages time)
+  #:use-module (gnu packages tls)
    #:use-module (gnu packages web)
    #:use-module (gnu packages xdisorg)
    #:use-module (gnu packages xml)
@@ -328,6 +331,58 @@  (define-public bool
  for parsing HTML files.")
      (license license:gpl3+)))

+(define-public dataparksearch
+  (let ((commit "8efa28f31ce1273c0556fd5c7e06abe955197a69")
+             (revision "0"))
+  (package
+    (name "dataparksearch")
+    (version (string-append "4.54" revision "." (string-take commit 7) ))
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://github.com/Maxime2/dataparksearch")
+                    (commit commit)))
+              (sha256
+               (base32 
"01z7s3ws5px2p9brzrq9j41jbdh1cvj8n8y3ghx45gfv1n319ipg"))
+              (modules '((guix build utils)))
+              (snippet
+               #~(begin
+                   (for-each delete-file '("config.sub"
+                                           "config.guess"
+                                           "configure"
+                                           "Makefile.in"
+                                           "missing"
+                                           "depcomp"
+                                           "ltmain.sh"
+                                           "compile"))))
+              (file-name (git-file-name name version))))
+    (build-system gnu-build-system)
+    (arguments
+     (list #:configure-flags
+           #~(list "--disable-syslog"
+                   "--with-extra-charsets=all"
+                   (string-append "--with-aspell="
+                                  #$(this-package-input "aspell"))
+                   (string-append "--with-pgsql="
+                                  #$(this-package-input "postgresql")))
+           #:make-flags
+           #~(list 
"DPS_TEST_DBADDR=postgresql://localhost/tmp/postgresql/")))
+    (native-inputs
+     (list pkg-config automake autoconf libtool openjade))
+    (inputs
+     (list mbedtls-apache zlib postgresql aspell c-ares libextractor))
+    (synopsis "Feature rich search engine")
+    (description
+     "Dataparksearch is a full featured web search engine.
+It has support for http, https, ftp (passive mode), nntp and news URL 
schemes, and
+other URL schemes with external parsers.
+It can tweak URLs with session IDs and other weird formats,
+including some JavaScript link decoding.
+Options to query with all words, all words near to each others, any 
words, or Boolean queries.
+A subset of VQL (Verity Query Language) is supported.")
+    (home-page "https://www.dataparksearch.org/")
+    (license license:gpl2+))))