diff mbox series

[bug#62292,v2] gnu: Add kitsas

Message ID 20230322125443.6561-1-saku@laesvuori.fi
State New
Headers show
Series [bug#62292,v2] gnu: Add kitsas | expand

Commit Message

Saku Laesvuori March 22, 2023, 12:54 p.m. UTC
* gnu/packages/finance.scm (kitsas): New variable.
---
 gnu/packages/finance.scm | 49 ++++++++++++++++++++++++++++++++++++++++
 1 file changed, 49 insertions(+)


base-commit: 3a2200e1ad2049ad7e25295e6b4e013f74dd84e2

Comments

Ludovic Courtès April 17, 2023, 9:29 p.m. UTC | #1
Hi Saku,

Saku Laesvuori <saku@laesvuori.fi> skribis:

>     * gnu/packages/finance.scm (kitsas): New variable.

Thanks for the updated patch.  I went ahead and applied it with the
changes below (the license is ‘gpl3+’ because the ‘LICENSE’ file
explicitly says “version 3 or any later version”).

The test failures are worrisome though.  Could you investigate why those
tests are failing or crashing?

Those failures may indicate real issues.  Or it could be that they
require a running X server (other packages usually solve that by
spawning ‘Xvfb’ right before the ‘check’ phase).

Thank you, and thanks Bruno for reviewing.

Ludo’.
Saku Laesvuori April 18, 2023, 2:51 p.m. UTC | #2
> The test failures are worrisome though.  Could you investigate why those
> tests are failing or crashing?
> 
> Those failures may indicate real issues.  Or it could be that they
> require a running X server (other packages usually solve that by
> spawning ‘Xvfb’ right before the ‘check’ phase).

The tests also fail on an Arch linux machine with a running X server. I
tried removing the failing ones, but that caused some of the previously
passing ones to start segfaulting, so I have no idea how to fix them
properly.

- Saku
Ludovic Courtès April 20, 2023, 10:30 a.m. UTC | #3
Saku Laesvuori <saku@laesvuori.fi> skribis:

>> The test failures are worrisome though.  Could you investigate why those
>> tests are failing or crashing?
>> 
>> Those failures may indicate real issues.  Or it could be that they
>> require a running X server (other packages usually solve that by
>> spawning ‘Xvfb’ right before the ‘check’ phase).
>
> The tests also fail on an Arch linux machine with a running X server. I
> tried removing the failing ones, but that caused some of the previously
> passing ones to start segfaulting, so I have no idea how to fix them
> properly.

OK.  Could you report it upstream?

Thanks,
Ludo’.
Saku Laesvuori April 20, 2023, 11:38 a.m. UTC | #4
> >> The test failures are worrisome though.  Could you investigate why those
> >> tests are failing or crashing?
> >> 
> >> Those failures may indicate real issues.  Or it could be that they
> >> require a running X server (other packages usually solve that by
> >> spawning ‘Xvfb’ right before the ‘check’ phase).
> >
> > The tests also fail on an Arch linux machine with a running X server. I
> > tried removing the failing ones, but that caused some of the previously
> > passing ones to start segfaulting, so I have no idea how to fix them
> > properly.
> 
> OK.  Could you report it upstream?

I'll send the maintainer an email as their issue tracker is on Github
and I'd prefer not registering an account there.
Saku Laesvuori April 20, 2023, 12:37 p.m. UTC | #5
On Thu, Apr 20, 2023 at 02:38:14PM +0300, Saku Laesvuori wrote:
> > >> The test failures are worrisome though.  Could you investigate why those
> > >> tests are failing or crashing?
> > >> 
> > >> Those failures may indicate real issues.  Or it could be that they
> > >> require a running X server (other packages usually solve that by
> > >> spawning ‘Xvfb’ right before the ‘check’ phase).
> > >
> > > The tests also fail on an Arch linux machine with a running X server. I
> > > tried removing the failing ones, but that caused some of the previously
> > > passing ones to start segfaulting, so I have no idea how to fix them
> > > properly.
> > 
> > OK.  Could you report it upstream?
> 
> I'll send the maintainer an email as their issue tracker is on Github
> and I'd prefer not registering an account there.

Apparently the tests haven't been kept up to date with Qt and may get
fixed when Kitsas is updated to Qt 6.
diff mbox series

Patch

diff --git a/gnu/packages/finance.scm b/gnu/packages/finance.scm
index 3f3fc078f0..a4b7ede62a 100644
--- a/gnu/packages/finance.scm
+++ b/gnu/packages/finance.scm
@@ -109,6 +109,7 @@  (define-module (gnu packages finance)
   #:use-module (gnu packages multiprecision)
   #:use-module (gnu packages ncurses)
   #:use-module (gnu packages networking)
+  #:use-module (gnu packages pdf)
   #:use-module (gnu packages pkg-config)
   #:use-module (gnu packages popt)
   #:use-module (gnu packages protobuf)
@@ -1290,6 +1291,54 @@  (define-public keepkey-agent
 agent.")
     (license license:lgpl3)))
 
+(define-public kitsas
+  (package
+    (name "kitsas")
+    (version "4.0.3")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/artoh/kitupiikki")
+                     (commit (string-append "v" version))))
+              (sha256
+               (base32
+                "0hrbsqqm6v2pmjq17s7i4akjgclz3d051mg02vcykq80xgxvbkgf"))))
+    (build-system qt-build-system)
+    (inputs (list qtbase-5 libzip poppler-qt5 qtsvg-5))
+    (arguments
+     (list
+       ; Some tests fail and others segfault
+       #:tests #f
+       #:test-target "check"
+       #:phases #~(modify-phases %standard-phases
+                    (replace 'configure
+                      (lambda* _
+                        (invoke "qmake" "kitsasproject.pro" "CONFIG+=release")))
+                    (replace 'install
+                      (lambda* _
+                        (install-file "kitsas/kitsas" (string-append #$output "/bin/"))
+                        (install-file "kitsas.png" (string-append #$output "/share/icons/"))
+                        (install-file "kitsas.desktop" (string-append #$output "/share/applications/")))))))
+    (home-page "https://kitsas.fi")
+    (synopsis "Finnish bookkeeping software for small organisations")
+    (description
+     "The software is in Finnish only.
+
+      Finnish free software accounting program with the following goals and features:
+
+      @itemize @bullet
+      @item Ease of use
+      @item Digital management of documents
+      @item Creating a digital archive
+      @item Built-in invoicing
+      @item Creating reports
+      @end itemize")
+    ; GPL3 with additional terms:
+    ; - Modified versions of this software should be clearly mentioned as modified
+    ; - Kitsas Oy will not support any modified version of this software
+    ; - The name Kitsas Oy should not be used in any modified version
+    (license license:gpl3)))
+
 (define-public python-stdnum
   (package
     (name "python-stdnum")