diff mbox series

[bug#62467,gnome-team,v3,01/15] gnu: librsvg-2.40: Fix test failure with Pango 1.50.

Message ID 0ff0469c1b12b2572b7707e1da89408b65b96de3.camel@protonmail.com
State New
Headers show
Series [bug#62467,gnome-team,v3,01/15] gnu: librsvg-2.40: Fix test failure with Pango 1.50. | expand

Commit Message

Liliana Marie Prikler April 3, 2023, 4:37 p.m. UTC
* gnu/packages/gnome.scm (librsvg-2.40): Fix test failure with Pango 1.50.

Signed-off-by: Andreas Enge <andreas@enge.fr>
Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
---
 gnu/packages/gnome.scm | 7 +++++++
 1 file changed, 7 insertions(+)

Comments

Maxim Cournoyer April 11, 2023, 8:52 p.m. UTC | #1
Hi,

Kaelyn Takata <liliana.prikler@gmail.com> writes:

> * gnu/packages/gnome.scm (librsvg-2.40): Fix test failure with Pango 1.50.
>
> Signed-off-by: Andreas Enge <andreas@enge.fr>
> Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com>
> ---
>  gnu/packages/gnome.scm | 7 +++++++
>  1 file changed, 7 insertions(+)
>
> diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
> index 49ff1464f5..6db6004356 100644
> --- a/gnu/packages/gnome.scm
> +++ b/gnu/packages/gnome.scm
> @@ -73,6 +73,7 @@
>  ;;; Copyright © 2022 Rene Saavedra <nanuui@protonmail.com>
>  ;;; Copyright © 2022 Alexandros Theodotou <alex@zrythm.org>
>  ;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
> +;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
>  ;;;
>  ;;; This file is part of GNU Guix.
>  ;;;
> @@ -3780,6 +3781,12 @@ (define-public librsvg-2.40
>                 (("gdk_pixbuf_cache_file = .*$")
>                  "gdk_pixbuf_cache_file = $(TMPDIR)/loaders.cache\n"))
>               #t))
> +         (add-before 'check 'fix-test-with-pango-1.50
> +           (lambda _
> +	     ;; Changes between pango 1.48 and 1.50 caused the text to be one
> +	     ;; pixel lower in the output image compared to the reference.
> +             (substitute* "tests/fixtures/reftests/bugs/587721-text-transform.svg"
> +	       (("660\\.9") "659.9"))))
>           (add-before 'check 'remove-failing-tests
>             (lambda _
>               (with-directory-excursion "tests/fixtures/reftests"

LGTM, although such fragil tests perhaps could be simply disabled to
spare someone the hassle to investigate them when they break again in
the future.
diff mbox series

Patch

diff --git a/gnu/packages/gnome.scm b/gnu/packages/gnome.scm
index 49ff1464f5..6db6004356 100644
--- a/gnu/packages/gnome.scm
+++ b/gnu/packages/gnome.scm
@@ -73,6 +73,7 @@ 
 ;;; Copyright © 2022 Rene Saavedra <nanuui@protonmail.com>
 ;;; Copyright © 2022 Alexandros Theodotou <alex@zrythm.org>
 ;;; Copyright © 2022 Arjan Adriaanse <arjan@adriaan.se>
+;;; Copyright © 2023 Kaelyn Takata <kaelyn.alexi@protonmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -3780,6 +3781,12 @@  (define-public librsvg-2.40
                (("gdk_pixbuf_cache_file = .*$")
                 "gdk_pixbuf_cache_file = $(TMPDIR)/loaders.cache\n"))
              #t))
+         (add-before 'check 'fix-test-with-pango-1.50
+           (lambda _
+	     ;; Changes between pango 1.48 and 1.50 caused the text to be one
+	     ;; pixel lower in the output image compared to the reference.
+             (substitute* "tests/fixtures/reftests/bugs/587721-text-transform.svg"
+	       (("660\\.9") "659.9"))))
          (add-before 'check 'remove-failing-tests
            (lambda _
              (with-directory-excursion "tests/fixtures/reftests"