diff mbox series

[bug#62730] gnu: Add libxisf.

Message ID 20230408205418.9146-1-sharlatanus@gmail.com
State New
Headers show
Series [bug#62730] gnu: Add libxisf. | expand

Commit Message

Sharlatan Hellseher April 8, 2023, 8:54 p.m. UTC
* gnu/packages/astronomy.scm (libxisf): New variable.
---
 gnu/packages/astronomy.scm | 29 +++++++++++++++++++++++++++++
 1 file changed, 29 insertions(+)

Comments

Nicolas Goaziou April 9, 2023, 7:30 p.m. UTC | #1
Hello,

Sharlatan Hellseher <sharlatanus@gmail.com> writes:

> * gnu/packages/astronomy.scm (libxisf): New variable.

I fixed the typo in th description and applied your patch. Thank you.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 3af948efe4..17b3c4aeba 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -2057,6 +2057,35 @@  (define-public libpasastro
 @end itemize\n")
       (license license:gpl2+))))
 
+(define-public libxisf
+  (package
+    (name "libxisf")
+    ;; TODO: v0.2.2 (current latest) failed to build on configure phase, issue
+    ;; was open directly with author as he hosts source on seflhosted gitea.
+    (version "0.2.1")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://gitea.nouspiro.space/nou/libXISF")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0fz9mmj1nz5v7hlr53q8na7khadfn1hm0d1gfpzzw3167bqpy2xv"))))
+    (build-system cmake-build-system)
+    (arguments
+     (list #:configure-flags
+           #~(list "-DUSE_BUNDLED_LIBS=OFF")))
+    (native-inputs
+     (list pkg-config))
+    (inputs
+     (list lz4 pugixml zlib))
+    (home-page "https://nouspiro.space/?page_id=306")
+    (synopsis "Astronomical library to load and write XISF file format")
+    (description "LibXISF is C++ library that can read and write XISF files produced by
+PixInsight.  It implement XISF 1.0 specification.")
+    (license license:gpl3+)))
+
 (define-public missfits
   (package
     (name "missfits")