diff mbox series

[bug#62544] gnu: tcsh: fix riscv64 cross-build.

Message ID tencent_54378B524BB2DEFE4E74C2CAC94BD46A1909@qq.com
State New
Headers show
Series [bug#62544] gnu: tcsh: fix riscv64 cross-build. | expand

Commit Message

Z572 March 30, 2023, 12:32 p.m. UTC
* gnu/packages/shells.scm(tcsh): fix riscv64 cross-build.
[arguments]<#:phase>: Add update-config-scripts phase for riscv64.
[native-inputs]: Add config for riscv64.
---
 gnu/packages/shells.scm | 18 +++++++++++++++++-
 1 file changed, 17 insertions(+), 1 deletion(-)

Comments

Ludovic Courtès April 6, 2023, 2:47 p.m. UTC | #1
Hi,

Z572 <873216071@qq.com> skribis:

> * gnu/packages/shells.scm(tcsh): fix riscv64 cross-build.
> [arguments]<#:phase>: Add update-config-scripts phase for riscv64.
> [native-inputs]: Add config for riscv64.

Tweaked indentation and applied it, thanks!

Ludo’.
diff mbox series

Patch

diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index c2b08afbe9..9c892f4bd2 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -20,6 +20,7 @@ 
 ;;; Copyright © 2021, 2022 Nicolas Goaziou <mail@nicolasgoaziou.fr>
 ;;; Copyright © 2021, 2022 Felix Gruber <felgru@posteo.net>
 ;;; Copyright © 2022 Andrew Tropin <andrew@trop.in>
+;;; Copyright © 2023 Zheng Junjie <873216071@qq.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -398,7 +399,10 @@  (define-public tcsh
               (patch-flags '("-p0"))))
     (build-system gnu-build-system)
     (native-inputs
-     (list autoconf perl))
+     (append (if (target-riscv64?)
+                 (list config)
+                 '())
+             (list autoconf perl)))
     (inputs
      (list ncurses))
     (arguments
@@ -412,6 +416,18 @@  (define-public tcsh
                           "CC_FOR_GETHOST=\"gcc\""))
                        #t)))
                 '())
+          ,@(if (target-riscv64?)
+                ;; TODO: remove after commit
+                ;; 3c33503f9aec4412dc1a95927a8c5c357c7b851e or 6.24.00
+                `((add-after 'unpack 'update-config-scripts
+                               (lambda* (#:key native-inputs inputs #:allow-other-keys)
+                                 (for-each (lambda (file)
+                                             (install-file
+                                              (search-input-file
+                                               (or native-inputs inputs)
+                                               (string-append "/bin/" file)) "."))
+                                           '("config.guess" "config.sub")))))
+                '())
           (add-before 'check 'patch-test-scripts
             (lambda _
               ;; Take care of pwd