diff mbox series

[bug#61990,v2] gnu: grep: Update to 3.10

Message ID 20230325221033.10797-1-atai@atai.org
State New
Headers show
Series [bug#61990,v2] gnu: grep: Update to 3.10 | expand

Commit Message

Andy Tai March 25, 2023, 10:10 p.m. UTC
* gnu/packages/base.scm (grep): Update to 3.10
---
 gnu/packages/base.scm | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)


base-commit: 04724e59971b03f86a410285653d24005c62b924

Comments

Simon Tournier April 4, 2023, 11:18 a.m. UTC | #1
Hi,

On Sat, 25 Mar 2023 at 15:10, Andy Tai <atai@atai.org> wrote:
> * gnu/packages/base.scm (grep): Update to 3.10

As Andreas pointed, this patch cannot go to master because it is an
intensive rebuild,

--8<---------------cut here---------------start------------->8---
$ guix refresh -l grep | cut -f1 -d':'
Building the following 2879 packages would ensure 7748 dependent packages are rebuilt
--8<---------------cut here---------------end--------------->8---

Therefore, this change must go to the core-updates branch as documented
by point #9 in [1].

1: https://guix.gnu.org/manual/devel/en/guix.html#Submitting-Patches

Cheers,
simon
diff mbox series

Patch

diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index fa5f1ef32b..5363370e53 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -106,14 +106,14 @@  (define-public hello
 (define-public grep
   (package
    (name "grep")
-   (version "3.6")
+   (version "3.10")
    (source (origin
             (method url-fetch)
             (uri (string-append "mirror://gnu/grep/grep-"
                                 version ".tar.xz"))
             (sha256
              (base32
-              "0gipv6bzkm1aihj0ncqpyh164xrzgcxcv9r1kwzyk2g1mzl1azk6"))
+              "0nw5ys5bhcr6c162rl43q5qpmf0bia3bhlcvhw072npvjnssbvr4"))
             (patches (search-patches "grep-timing-sensitive-test.patch"))))
    (build-system gnu-build-system)
    (native-inputs (list perl))                   ;some of the tests require it