diff mbox series

[bug#62235] gnu: wireshark: Update to 4.0.4.

Message ID 20230317092723.249913-1-mail@nicolasgoaziou.fr
State New
Headers show
Series [bug#62235] gnu: wireshark: Update to 4.0.4. | expand

Commit Message

Nicolas Goaziou March 17, 2023, 9:27 a.m. UTC
* gnu/packages/networking.scm (wireshark): Update to 4.0.4.
[arguments]<#:phases>: Re-introduce a now succeeding test.
---
 gnu/packages/networking.scm | 14 ++++----------
 1 file changed, 4 insertions(+), 10 deletions(-)


base-commit: 3893758dac76fc30b23d4715e849e262306f268d

Comments

Maxim Cournoyer March 22, 2023, 2:13 p.m. UTC | #1
Hi!

Nicolas Goaziou <mail@nicolasgoaziou.fr> writes:

> * gnu/packages/networking.scm (wireshark): Update to 4.0.4.
> [arguments]<#:phases>: Re-introduce a now succeeding test.

Thanks for this.

> ---
>  gnu/packages/networking.scm | 14 ++++----------
>  1 file changed, 4 insertions(+), 10 deletions(-)
>
> diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
> index 3fac05c411..bec707a390 100644
> --- a/gnu/packages/networking.scm
> +++ b/gnu/packages/networking.scm
> @@ -1758,29 +1758,23 @@ (define-public whois
>  (define-public wireshark
>    (package
>      (name "wireshark")
> -    (version "4.0.3")
> +    (version "4.0.4")
>      (source
>       (origin
>         (method url-fetch)
>         (uri (string-append "https://www.wireshark.org/download/src/wireshark-"
>                             version ".tar.xz"))
>         (sha256
> -        (base32 "04cmgvmkyvxdpfy08adxf3smklgzakrvyvb89rrr7yqaridy2lbc"))))
> +        (base32 "0jz76ra86gy7r4wwb174lggnl5y29nn68l7ydw1kj1phcijrz854"))))
>      (build-system cmake-build-system)
>      (arguments
>       `(#:phases
>         (modify-phases %standard-phases
>           (replace 'check
>             (lambda* (#:key tests? #:allow-other-keys)
> -             ;; Skip test suite failing with "Program reassemble_test is not
> -             ;; available" and alike errors.  Also skip test suite failing
> -             ;; with "AssertionError: Program extcap/sdjournal is not
> -             ;; available" error.'
> +             ;; Skip failing test suite.
>               (when tests?
> -               (invoke "ctest"
> -                       "-E"
> -                       (string-join (list "suite_unittests" "suite_extcaps")
> -                                    "|"))))))
> +               (invoke "ctest" "-E" "suite_extcaps")))))

I've modified the change like this, preserving the useful comment (and
enabling parallel tests):

--8<---------------cut here---------------start------------->8---
modified   gnu/packages/networking.scm
@@ -1771,10 +1771,16 @@ (define-public wireshark
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
-           (lambda* (#:key tests? #:allow-other-keys)
-             ;; Skip failing test suite.
+           (lambda* (#:key parallel-tests? tests? #:allow-other-keys)
              (when tests?
-               (invoke "ctest" "-E" "suite_extcaps")))))
+               (invoke "ctest" "-VV"
+                       "-j" (if parallel-tests?
+                                (number->string (parallel-job-count))
+                                "1")
+                       ;; Skip the suite_extcaps.case_extcaps.test_sdjournal
+                       ;; test as it requires sdjournal (from systemd) and
+                       ;; fails.
+                       "-E" "suite_extcaps")))))
        ;; Build process chokes during `validate-runpath' phase.
        ;;
        ;; Errors are like the following:
--8<---------------cut here---------------end--------------->8---

I've now installed this change, along a few others updating the
dependencies to Qt6 and restoring validate-runpath.
diff mbox series

Patch

diff --git a/gnu/packages/networking.scm b/gnu/packages/networking.scm
index 3fac05c411..bec707a390 100644
--- a/gnu/packages/networking.scm
+++ b/gnu/packages/networking.scm
@@ -1758,29 +1758,23 @@  (define-public whois
 (define-public wireshark
   (package
     (name "wireshark")
-    (version "4.0.3")
+    (version "4.0.4")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.wireshark.org/download/src/wireshark-"
                            version ".tar.xz"))
        (sha256
-        (base32 "04cmgvmkyvxdpfy08adxf3smklgzakrvyvb89rrr7yqaridy2lbc"))))
+        (base32 "0jz76ra86gy7r4wwb174lggnl5y29nn68l7ydw1kj1phcijrz854"))))
     (build-system cmake-build-system)
     (arguments
      `(#:phases
        (modify-phases %standard-phases
          (replace 'check
            (lambda* (#:key tests? #:allow-other-keys)
-             ;; Skip test suite failing with "Program reassemble_test is not
-             ;; available" and alike errors.  Also skip test suite failing
-             ;; with "AssertionError: Program extcap/sdjournal is not
-             ;; available" error.'
+             ;; Skip failing test suite.
              (when tests?
-               (invoke "ctest"
-                       "-E"
-                       (string-join (list "suite_unittests" "suite_extcaps")
-                                    "|"))))))
+               (invoke "ctest" "-E" "suite_extcaps")))))
        ;; Build process chokes during `validate-runpath' phase.
        ;;
        ;; Errors are like the following: