diff mbox series

[bug#62348,1/3] gnu: psmisc: Make description more informative.

Message ID 40a8417b0c696509da522c9b5c072f004c0615f0.1679418658.git.mirai@makinata.eu
State New
Headers show
Series Update psmisc to 23.6. | expand

Commit Message

Bruno Victal March 21, 2023, 5:11 p.m. UTC
From: mikadoZero <mikadozero@yandex.com>

The text for the description is taken from the psmisc readme.

* gnu/packages/linux.scm (psmisc)[description]: Make description more informative.

Co-authored-by: Bruno Victal <mirai@makinata.eu>
---
 gnu/packages/linux.scm | 13 ++++++++++---
 1 file changed, 10 insertions(+), 3 deletions(-)

Comments

Nicolas Goaziou March 21, 2023, 5:20 p.m. UTC | #1
Hello,

Bruno Victal <mirai@makinata.eu> writes:

> From: mikadoZero <mikadozero@yandex.com>
>
> The text for the description is taken from the psmisc readme.
>
> * gnu/packages/linux.scm (psmisc)[description]: Make description more
> informative.

Thanks.

> +     "A package of small utilities that use the proc file-system.

This should be a complete sentence, e.g.,

  Psmisc is a set of small utilities…

> +@itemize @bullet
> +@item @command{fuser} - Identifies processes using files or sockets
> +@item @command{killall} - kills processes by name, e.g. @samp{killall -HUP @var{name}}
> +@item @command{prtstat} - prints statistics of a process
> +@item @command{pslog} - prints log path(s) of a process
> +@item @command{pstree} - shows the currently running processes as a tree
> +@item @command{peekfd} - shows the data travelling over a file descriptor
> +@end itemize")

I suggest to remove the dashes, and probably add semicolons at the end
of all but last item:

  @item @command{fuser} identifies processes using files or sockets;

I suggest to add a comma after "e.g.", so Texinfo cannot consider it to
be the end of a sentence:

  @item @command{killall} kills processes by name, e.g., @samp{killall -HUP @var{name}};

Actually, I even wonder if providing an example if worth being in
a generic description. I probably belongs to a user manual:

  @item @command{killall} kills processes by name;

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index ef05e77ec8..14e6f46a39 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -33,6 +33,7 @@ 
 ;;; Copyright © 2018, 2019 Pierre Langlois <pierre.langlois@gmx.com>
 ;;; Copyright © 2018 Vasile Dumitrascu <va511e@yahoo.com>
 ;;; Copyright © 2019 Tim Gesthuizen <tim.gesthuizen@yahoo.de>
+;;; Copyright © 2019 mikadoZero <mikadozero@yandex.com>
 ;;; Copyright © 2019, 2020, 2021, 2022 Maxim Cournoyer <maxim.cournoyer@gmail.com>
 ;;; Copyright © 2019 Stefan Stefanović <stefanx2ovic@gmail.com>
 ;;; Copyright © 2019-2022 Brice Waegeneire <brice@waegenei.re>
@@ -2039,9 +2040,15 @@  (define-public psmisc
     (home-page "https://gitlab.com/psmisc/psmisc")
     (synopsis "Small utilities that use the proc file system")
     (description
-     "This PSmisc package is a set of some small useful utilities that
-use the proc file system.  We're not about changing the world, but
-providing the system administrator with some help in common tasks.")
+     "A package of small utilities that use the proc file-system.
+@itemize @bullet
+@item @command{fuser} - Identifies processes using files or sockets
+@item @command{killall} - kills processes by name, e.g. @samp{killall -HUP @var{name}}
+@item @command{prtstat} - prints statistics of a process
+@item @command{pslog} - prints log path(s) of a process
+@item @command{pstree} - shows the currently running processes as a tree
+@item @command{peekfd} - shows the data travelling over a file descriptor
+@end itemize")
     (license license:gpl2+)))
 
 (define-public util-linux