diff mbox series

[bug#62123,3/4] gnu: Add emacs-pippel.

Message ID CAEtmmezZWwj5k1su3mwazHMJ9FYi=8CR99r9HdTgXpLzqkbLkw@mail.gmail.com
State New
Headers show
Series None | expand

Commit Message

Rostislav Svoboda March 13, 2023, 1:01 p.m. UTC
Oh, the patch is broken, ignore it. sorry. Here's a correction. Please
have a look at the 'python2 vs. python3' comment. Is it OK to make it
work just for python3?

Cheers
Bost

From 29c79c13c4cdfe5c6014cd9ba35cea41a465a106 Mon Sep 17 00:00:00 2001
From: Rostislav Svoboda <Rostislav.Svoboda@gmail.com>
Date: Sat, 11 Mar 2023 15:36:11 +0100
Subject: [PATCH 3/4] gnu: Add emacs-pippel.

* gnu/packages/emacs-xyz.scm (emacs-pippel): New variable.
---
 gnu/packages/emacs-xyz.scm | 37 +++++++++++++++++++++++++++++++++++++
 1 file changed, 37 insertions(+)

   (package
     (name "emacs-reverse-im")

Comments

Nicolas Goaziou March 17, 2023, 8:51 a.m. UTC | #1
Hello,

Rostislav Svoboda <rostislav.svoboda@gmail.com> writes:

> Oh, the patch is broken, ignore it. sorry. Here's a correction.

Thanks. Some comments follow.

> Please have a look at the 'python2 vs. python3' comment. Is it OK to
> make it work just for python3?

Guix does not support Python 2 anymore. Note, however,
that you can provide `python-wrapper' as input instead of `python', and
use "python" executable. Anyway sticking to "python3" is OK.

> +      (inputs (list python))
> +      (propagated-inputs (list emacs-dash emacs-s))

Nitpick: usually, inputs and propagated inputs are located after arguments.

> +      (arguments
> +       (list #:phases #~(modify-phases %standard-phases

You can add a newline characther after `list' and another one after
`#:phases'.

> +                          (add-after 'unpack 'substitute-python-path
> +                            (lambda* (#:key inputs #:allow-other-keys)
> +                              (emacs-substitute-variables "pippel.el"
> +
> ("pippel-python-command"
> +                                                           (search-input-file
> +                                                            inputs
> +;;; For 'python2 vs. python3' see the choice:
> +;;; https://github.com/arifer612/pippel/blob/cb194952ee150e77601d3233dabdb521b976ee79/pippel.el#L65
> +
> "/bin/python3"))))))))
> +      (home-page "https://github.com/arifer612/pippel")
> +      (synopsis "Emacs frontend to Python package manager pip")

pip -> Pip

> +      (description
> +       "Emacs frontend for the Python package manager pip.  As pippel also uses
> +@code{tabulated-list-mode}, it provides a similar package menu like
> +@code{package-list-packages}.")

The first sentence is not complete : "Pippel is an Emacs…"

Also, pip -> Pip, pippel -> Pippel, @code{tabulated-list-mode} ->
Tabulated List mode.

> +      (license license:gpl3+))))

I think you also need to include "pippel.py" file through #:include
keyword and possibly configure `pippel-package-path'.

Regards,
diff mbox series

Patch

diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index d371cfd6f3..f4e557e98a 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -17358,6 +17358,43 @@  (define-public emacs-pinyinlib
 letter of Pinyin to Simplified/Traditional Chinese characters.")
     (license license:gpl3+)))

+(define-public emacs-pippel
+  (let ((commit "cb194952ee150e77601d3233dabdb521b976ee79")
+        (revision "0"))
+    (package
+      (name "emacs-pippel")
+      (version (git-version "1.4" revision commit))
+      (source (origin
+                (method git-fetch)
+                (uri (git-reference
+                      (url "https://github.com/arifer612/pippel")
+                      (commit commit)))
+                (file-name (git-file-name name version))
+                (sha256
+                 (base32
+                  "17606l24yyrjxa4rc0p2zj50lfbayqldw4phhi59yqf61289d520"))))
+      (build-system emacs-build-system)
+      (inputs (list python))
+      (propagated-inputs (list emacs-dash emacs-s))
+      (arguments
+       (list #:phases #~(modify-phases %standard-phases
+                          (add-after 'unpack 'substitute-python-path
+                            (lambda* (#:key inputs #:allow-other-keys)
+                              (emacs-substitute-variables "pippel.el"
+
("pippel-python-command"
+                                                           (search-input-file
+                                                            inputs
+;;; For 'python2 vs. python3' see the choice:
+;;; https://github.com/arifer612/pippel/blob/cb194952ee150e77601d3233dabdb521b976ee79/pippel.el#L65
+
"/bin/python3"))))))))
+      (home-page "https://github.com/arifer612/pippel")
+      (synopsis "Emacs frontend to Python package manager pip")
+      (description
+       "Emacs frontend for the Python package manager pip.  As pippel also uses
+@code{tabulated-list-mode}, it provides a similar package menu like
+@code{package-list-packages}.")
+      (license license:gpl3+))))
+
 (define-public emacs-reverse-im