diff mbox series

[bug#62073] gnu: samba: Update to 4.18.0

Message ID 20230309102154.10528-1-atai@atai.org
State New
Headers show
Series [bug#62073] gnu: samba: Update to 4.18.0 | expand

Commit Message

Andy Tai March 9, 2023, 10:21 a.m. UTC
* gnu/packages/samba.scm (samba): Update to 4.18.0
---
 gnu/packages/samba.scm | 6 ++----
 1 file changed, 2 insertions(+), 4 deletions(-)


base-commit: f289fe316aaa06e60f4b10e75e113cf1aeb03629
prerequisite-patch-id: 9563cb533c5a03a05e260e77cdcf1b4347832000

Comments

Christopher Baines March 14, 2023, 9:50 a.m. UTC | #1
Andy Tai <atai@atai.org> writes:

> * gnu/packages/samba.scm (samba): Update to 4.18.0
> ---
>  gnu/packages/samba.scm | 6 ++----
>  1 file changed, 2 insertions(+), 4 deletions(-)

Thanks for the patch Andy, I've put a couple of comments below.

> diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
> index da103ed839..d171c33e52 100644
> --- a/gnu/packages/samba.scm
> +++ b/gnu/packages/samba.scm
> @@ -172,16 +172,14 @@ (define (install dir)
>  (define-public samba
>    (package
>      (name "samba")
> -    (version "4.16.8")
> +    (version "4.18.0")
>      (source
> -     ;; For updaters: the current PGP fingerprint is
> -     ;; 81F5E2832BD2545A1897B713AA99442FB680B620.

Why remove this comment?

>       (origin
>         (method url-fetch)
>         (uri (string-append "https://download.samba.org/pub/samba/stable/"
>                             "samba-" version ".tar.gz"))
>         (sha256
> -        (base32 "11a1vikbijaq7csg49h5ivn25gx84v6wx8z8kgsj1wmkhsf9bcmv"))))
> +        (base32 "0jc182w1ik44qv956hi3is0rjkggghawlra4pv4fjyw0xxb8cd3h"))))
>      (build-system gnu-build-system)
>      (arguments
>       (list
>
> base-commit: f289fe316aaa06e60f4b10e75e113cf1aeb03629
> prerequisite-patch-id: 9563cb533c5a03a05e260e77cdcf1b4347832000

According to https://qa.guix.gnu.org/issue/62073 it seems that the sssd
package fails to build with this change, could you check if it builds
locally with this change for you?
diff mbox series

Patch

diff --git a/gnu/packages/samba.scm b/gnu/packages/samba.scm
index da103ed839..d171c33e52 100644
--- a/gnu/packages/samba.scm
+++ b/gnu/packages/samba.scm
@@ -172,16 +172,14 @@  (define (install dir)
 (define-public samba
   (package
     (name "samba")
-    (version "4.16.8")
+    (version "4.18.0")
     (source
-     ;; For updaters: the current PGP fingerprint is
-     ;; 81F5E2832BD2545A1897B713AA99442FB680B620.
      (origin
        (method url-fetch)
        (uri (string-append "https://download.samba.org/pub/samba/stable/"
                            "samba-" version ".tar.gz"))
        (sha256
-        (base32 "11a1vikbijaq7csg49h5ivn25gx84v6wx8z8kgsj1wmkhsf9bcmv"))))
+        (base32 "0jc182w1ik44qv956hi3is0rjkggghawlra4pv4fjyw0xxb8cd3h"))))
     (build-system gnu-build-system)
     (arguments
      (list