diff mbox series

[bug#62138] gnu: a2ps: Update to 4.15

Message ID 20230312064815.24022-1-atai@atai.org
State New
Headers show
Series [bug#62138] gnu: a2ps: Update to 4.15 | expand

Commit Message

Andy Tai March 12, 2023, 6:48 a.m. UTC
* gnu/packages/pretty-print.scm (a2ps): update to 4.15
---
 gnu/packages/pretty-print.scm | 16 +++++++---------
 1 file changed, 7 insertions(+), 9 deletions(-)


base-commit: f289fe316aaa06e60f4b10e75e113cf1aeb03629
prerequisite-patch-id: 8c2c8788f860cf601f04bf10e2f932f63c0c449a

Comments

Andreas Enge March 12, 2023, 11:14 a.m. UTC | #1
Hello Andy,

when you take out a patch from a package recipe, you also need to delete
the patch files with "git rm gnu/packages/patches/...", and you need to
deregister them from gnu/local.mk. Hopefully the etc/committers.scm then
does the right thing for the commit message, otherwise you can find examples
in the git repository.

Moreover, the package now fails its tests on QA:
   https://bordeaux.guix.gnu.org/build/d46748d0-7257-4675-b025-05daf16b092c
Hm, I am not completely sure, but this looks like the previous version
of your patch. So maybe it is enough to wait here.

Andreas
diff mbox series

Patch

diff --git a/gnu/packages/pretty-print.scm b/gnu/packages/pretty-print.scm
index 7bc54c4a0b..bc104447d5 100644
--- a/gnu/packages/pretty-print.scm
+++ b/gnu/packages/pretty-print.scm
@@ -37,7 +37,9 @@  (define-module (gnu packages pretty-print)
   #:use-module (gnu packages)
   #:use-module (gnu packages bison)
   #:use-module (gnu packages boost)
+  #:use-module (gnu packages bdw-gc)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages file)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gperf)
@@ -52,14 +54,14 @@  (define-module (gnu packages pretty-print)
 (define-public a2ps
   (package
     (name "a2ps")
-    (version "4.14")
+    (version "4.15")
     (source (origin
               (method url-fetch)
               (uri (string-append "mirror://gnu/a2ps/a2ps-"
                                   version ".tar.gz"))
               (sha256
                (base32
-                "195k78m1h03m961qn7jr120z815iyb93gwi159p1p9348lyqvbpk"))
+                "0lk6qycjw26z6jhnf353z7m469xp91lypdf6ay54961g4alwbbd5"))
               (modules '((guix build utils)))
               (snippet
                ;; Remove timestamp from the installed 'README' file.
@@ -67,16 +69,12 @@  (define-public a2ps
                   (substitute* "etc/README.in"
                     (("@date@")
                      "1st of some month, sometime after 1970"))
-                  #t))
-              (patches (search-patches
-                        "a2ps-CVE-2001-1593.patch"
-                        "a2ps-CVE-2014-0466.patch"
-                        "a2ps-CVE-2015-8107.patch"))))
+                  #t))))
     (build-system gnu-build-system)
     (inputs
-     (list psutils gv))
+     (list psutils file gv libgc libpaper))
     (native-inputs
-     (list gperf groff perl))
+     (list gperf groff perl pkg-config))
     (arguments
      '(#:phases
        (modify-phases %standard-phases